Search found 47 matches

by SpikeyGG
Sat Dec 16, 2017 8:02 pm
Forum: ZoneMinder 1.30.x
Topic: ERR: Only read XXXX bytes of YYYY and "Incomplete frame write" Errors
Replies: 10
Views: 2516

Re: ERR: Only read XXXX bytes of YYYY and "Incomplete frame write" Errors

Yes, don't use the Remote -> RTSP method. This method is no longer being maintained as it attempts to recreate the wheel. The errors you see are exactly why our documentation states to use a source type of ffmpeg for rtsp devices: http://zoneminder.readthedocs.io/en/stable/userguide/definemonitor.h...
by SpikeyGG
Sat Dec 16, 2017 1:46 pm
Forum: ZoneMinder 1.30.x
Topic: ERR: Only read XXXX bytes of YYYY and "Incomplete frame write" Errors
Replies: 10
Views: 2516

Re: ERR: Only read XXXX bytes of YYYY and "Incomplete frame write" Errors

Okay, it looks like the original warnings/errors disappeared but now I'm seeing "Unexpected channel selector XXX in RTSP interleaved data" errors and a few other warnings... Here's a screen shot: ZM Errors2.png I did some googling around for the error and I found a few threads but no one seems to ha...
by SpikeyGG
Wed Dec 13, 2017 2:51 am
Forum: ZoneMinder 1.30.x
Topic: ERR: Only read XXXX bytes of YYYY and "Incomplete frame write" Errors
Replies: 10
Views: 2516

Re: ERR: Only read XXXX bytes of YYYY and "Incomplete frame write" Errors

For starters, turn off the frame server under options. The frame server ends up causing more problems than it attempts to solve. It has been removed from the latest master branch, and won't be part of the next release of ZoneMinder. I just modified that setting on my setup. I'll monitor over the ne...
by SpikeyGG
Sat Dec 09, 2017 6:23 pm
Forum: ZoneMinder 1.30.x
Topic: ERR: Only read XXXX bytes of YYYY and "Incomplete frame write" Errors
Replies: 10
Views: 2516

Re: ERR: Only read XXXX bytes of YYYY and "Incomplete frame write" Errors

How do you have the camera configured? Which Linux distro and version? The camera is throttled at 6fps and 720p on my setup. I have 5 zones with varying amounts of blob detection in each zone. I'm using RTP/RTSP with the hardcoded IP of the camera using the standard port 554. I'm not sure what kind...
by SpikeyGG
Sat Nov 04, 2017 5:37 pm
Forum: ZoneMinder 1.30.x
Topic: ERR: Only read XXXX bytes of YYYY and "Incomplete frame write" Errors
Replies: 10
Views: 2516

ERR: Only read XXXX bytes of YYYY and "Incomplete frame write" Errors

So I'm running ZM 1.30.4 and it looks like I'm getting a lot of this kind of stuff: Date/Time Component Server PID Level Message File Line 11/4/17 11:14 AM zmf 12781 WAR Socket closed at remote end zmf.cpp 312 11/4/17 11:14 AM zmf 12781 ERR Only read 219224 bytes of 979149 zmf.cpp 305 11/4/17 11:14 ...
by SpikeyGG
Tue Nov 29, 2016 2:22 pm
Forum: ZoneMinder 1.30.x
Topic: Cant maintain FPS
Replies: 12
Views: 4712

Re: Cant maintain FPS

Yeah, it seems like there's an issue with zoneminder after an alarm triggers. My camera is fine at 10fps in idle mode, but as soon as an alarm triggers the frame rate drops to 2-3 FPS. Here's an example that just triggered this morning: https://dl.dropboxusercontent.com/u/14826228/ZoneMinder/Event-1...
by SpikeyGG
Sun Nov 27, 2016 4:18 pm
Forum: ZoneMinder 1.29.x
Topic: Capture frame rate changes mid recording.
Replies: 1
Views: 1092

Re: Capture frame rate changes mid recording.

FYI, I just upgraded to 1.30 and the problem persists.
by SpikeyGG
Fri Nov 25, 2016 5:30 pm
Forum: ZoneMinder 1.29.x
Topic: Capture frame rate changes mid recording.
Replies: 1
Views: 1092

Capture frame rate changes mid recording.

Hi, I've used ZM for a long time and I've always had an issue with this but I have never figured it out. When a recording is triggered the first few frames ~20-30 are at an acceptable frame rate (and motion is smooth), after that the frame rate drops to a much lower value and you can see this as the...
by SpikeyGG
Thu Jun 30, 2016 5:38 pm
Forum: ZoneMinder 1.29.x
Topic: Recordings seems to freeze, then become jerky
Replies: 1
Views: 837

Recordings seems to freeze, then become jerky

I've noticed something weird about the system, when an alarm triggers and the system starts to build a recording the first section of the recording is good and smooth for approximately 3-4 seconds the frame rate appears to be a good 10 fps. After about 4 seconds, there's a short freeze, then the vid...
by SpikeyGG
Thu Jun 30, 2016 1:08 pm
Forum: ZoneMinder 1.29.x
Topic: Upgrade from 1.28 to 1.29, cannot run zmupdate.pl
Replies: 23
Views: 6266

Re: Upgrade from 1.28 to 1.29, cannot run zmupdate.pl

OMG, I found it: /usr/local/share/perl/5.18.2/ZoneMinder/Base.pm . presumably left over from source installation: $ sudo find /usr -name Base.pm |grep Zone /usr/share/perl5/ZoneMinder/Base.pm /usr/src/junk/scripts/ZoneMinder/lib/ZoneMinder/Base.pm /usr/local/share/perl/5.18.2/ZoneMinder/Base.pm $ Am...
by SpikeyGG
Thu Jun 30, 2016 12:55 pm
Forum: ZoneMinder 1.29.x
Topic: Upgrade from 1.28 to 1.29, cannot run zmupdate.pl
Replies: 23
Views: 6266

Re: Upgrade from 1.28 to 1.29, cannot run zmupdate.pl

More detail: I just figured out that my ZM_VERSION is wrong. When I issue zmpkg.pl version it spits out 1.28! $ sudo /usr/bin/zmpkg.pl version 1.28.0 $ so I look at the code and the print statement is: print ZoneMinder::Base::ZM_VERSION . "\n"; So where does this ZoneMinder::Base::ZM_VERSION value c...
by SpikeyGG
Thu Jun 30, 2016 12:29 pm
Forum: ZoneMinder 1.29.x
Topic: Upgrade from 1.28 to 1.29, cannot run zmupdate.pl
Replies: 23
Views: 6266

Re: Upgrade from 1.28 to 1.29, cannot run zmupdate.pl

Okay, I tried this again today, check out the sequence (previously manually clearing out all files I could find and dropping the zm DB): $ sudo apt-get install zoneminder Reading package lists... Done Building dependency tree Reading state information... Done Suggested packages: fcgiwrap The followi...
by SpikeyGG
Fri Jun 17, 2016 12:33 pm
Forum: ZoneMinder 1.29.x
Topic: Upgrade from 1.28 to 1.29, cannot run zmupdate.pl
Replies: 23
Views: 6266

Re: Upgrade from 1.28 to 1.29, cannot run zmupdate.pl

It sounds like your using the web console php code for v1.28 and not v1.29. Check the paths that Apache (or your web server) and ZoneMinder are configured for. I had some mismatch problems when first upgrading from a package manager installed ZM and then to go to 1.30.rc1 I built it from source. Ev...
by SpikeyGG
Sat Jun 11, 2016 3:15 am
Forum: ZoneMinder 1.29.x
Topic: Upgrade from 1.28 to 1.29, cannot run zmupdate.pl
Replies: 23
Views: 6266

Re: Upgrade from 1.28 to 1.29, cannot run zmupdate.pl

bump, still no dice on this.
by SpikeyGG
Tue May 24, 2016 1:52 pm
Forum: ZoneMinder 1.29.x
Topic: Upgrade from 1.28 to 1.29, cannot run zmupdate.pl
Replies: 23
Views: 6266

Re: Upgrade from 1.28 to 1.29, cannot run zmupdate.pl

Your best bet would be to dump your current database and start with a fresh one. Yes, you could run each .sql which is what the zmupdate does but you could still have issues. You may be farther ahead to install Ubuntu 16.04 server with ZM 1.29.0 bb So I tried dumping the DB and then using the instr...