Search found 24 matches

by lorenjz
Fri Sep 18, 2020 2:39 pm
Forum: ZoneMinder 1.34.x
Topic: Issues with storage
Replies: 1
Views: 217

Issues with storage

I have two issues that may or may not be related. The first is that I am using freenas to store all of the footage from zoneminder and followed this tutorial from the wiki: https://wiki.zoneminder.com/Common_Issues_with_Zoneminder_Installation_on_Ubuntu#Use_Systemd_to_Mount_Internal_Drive_or_NAS Whe...
by lorenjz
Thu Sep 17, 2020 7:55 pm
Forum: Mobile Apps
Topic: zmninja inconsistency
Replies: 14
Views: 1432

Re: zmninja inconsistency

Thanks for looking at the logs, I appreciate it.

It only happens some of the time. I'll blast you info about a test account via pm.
by lorenjz
Fri Sep 04, 2020 12:48 pm
Forum: Mobile Apps
Topic: zmninja inconsistency
Replies: 14
Views: 1432

Re: zmninja inconsistency

I've never been able to replicate this, but I have heard of this happening. 1. Do you use ZM auth? yes 2. Which version ZM? 1.34.20 Attached is a log following the instructions. To clarify I cleared the log closed zmninja, opened the app it worked, closed it, reopened it and then had the issue. I h...
by lorenjz
Tue Sep 01, 2020 8:19 pm
Forum: Mobile Apps
Topic: zmninja inconsistency
Replies: 14
Views: 1432

zmninja inconsistency

I think I'm starting to get my configuration nailed down and I am impressed with how much you can do with zoneminder, the event server and zmninja. The one stumbling block for my wife and I is that about 80% of the time when we load the app on our phones (android) the only way to get the montage and...
by lorenjz
Tue Sep 01, 2020 3:11 am
Forum: Mobile Apps
Topic: having issues getting hooks going
Replies: 22
Views: 3560

Re: having issues getting hooks going

asker wrote:
Mon Aug 31, 2020 12:37 pm
1. I noticed your script doesn't have "#!/usr/bin/python" or wherever python is located at the top

Good catch. That was it Again thanks a ton!
by lorenjz
Mon Aug 31, 2020 2:35 am
Forum: Mobile Apps
Topic: having issues getting hooks going
Replies: 22
Views: 3560

Re: having issues getting hooks going

I don't quite understand the issue. Both your event start and event end scripts are being called according to your logs. 08/30/2020 09:39:17.171694 zmeventnotification[9887].DBG [main:935] [|----> FORK:Small Room Sub (12), eid:10099 invoking user start notification script '/var/lib/zmeventnotificat...
by lorenjz
Sun Aug 30, 2020 3:39 pm
Forum: Mobile Apps
Topic: having issues getting hooks going
Replies: 22
Views: 3560

Re: having issues getting hooks going

I had a little more time this morning to try and troubleshoot this. I can see where the logs say that they start example.py and lzhomeseer.py. Both scripts run without any errors when executed manually as the www-data user. example.py hasn't been changed. lzhomeseer.py is a copy of example.py with a...
by lorenjz
Fri Aug 21, 2020 2:52 am
Forum: Mobile Apps
Topic: having issues getting hooks going
Replies: 22
Views: 3560

Re: having issues getting hooks going

Any thoughts as to why neither event_start_hook_notify_userscript or event_end_hook_notify_userscript are getting called. I double checked both scripts (I copied the example.py and renamed it and have the end userscript variable pointing to it) are owned by www-data and are executable. I also did a ...
by lorenjz
Thu Aug 20, 2020 1:00 pm
Forum: Mobile Apps
Topic: having issues getting hooks going
Replies: 22
Views: 3560

Re: having issues getting hooks going

You are right that was the cause of the error. Thank you! Just checking to see if there might be a typo in zmeventnotification.ini. If line 215 is #event_start_hook_notify_userscript = '{{base_data_path}}/contrib/example.py' should line 227 be: #event_end_hook_notify_userscript = '{{base_data_path}}...
by lorenjz
Wed Aug 19, 2020 11:10 am
Forum: Mobile Apps
Topic: having issues getting hooks going
Replies: 22
Views: 3560

Re: having issues getting hooks going

https://zmeventnotification.readthedocs.io/en/latest/guides/breaking.html Option 1. Switch to yolo v3 Option 2. Upgrade opencv. Zoneminder: 1.34.18 hook version 0.1.24 ES version 6.0.0 opencv 4.4.0 I've upgraded to and tried both versions of yolo. I still get: Traceback (most recent call last): Fil...
by lorenjz
Sat Jul 11, 2020 2:05 pm
Forum: Mobile Apps
Topic: having issues getting hooks going
Replies: 22
Views: 3560

Re: having issues getting hooks going

@asker, kicking myself for not remembering reading that however... After going through the breaking changes post. I couldn't find the differences. Here is what I did: Downloaded the latest version from github last night Ran install.sh reinstalling everything including the config files to ensure that...
by lorenjz
Fri Jul 10, 2020 5:00 pm
Forum: Mobile Apps
Topic: having issues getting hooks going
Replies: 22
Views: 3560

Re: having issues getting hooks going

@asker thanks for your help with all of this! I was able to get the imutils permissions thing sorted I think. Then I had this pop up Traceback (most recent call last): File "/var/lib/zmeventnotification/bin/zm_detect.py", line 402, in <module> b, l, c = m.detect(image) File "/usr/local/lib/python3.8...
by lorenjz
Thu Jul 09, 2020 10:28 pm
Forum: Mobile Apps
Topic: having issues getting hooks going
Replies: 22
Views: 3560

Re: having issues getting hooks going

That means you are missing "imutils" as a dependent package for detection to work. Not sure how you installed it, but I'd suggest reinstalling using the official install instructions of using install.sh to make sure all dependencies are pulled. make sure you monitor the output of the installation. ...
by lorenjz
Thu Jul 09, 2020 7:08 pm
Forum: Mobile Apps
Topic: having issues getting hooks going
Replies: 22
Views: 3560

Re: having issues getting hooks going

My vm running zoneminder died the other day. I'm tryiing to get everything back up and running. When I execute: sudo -u www-data /var/lib/zmeventnotification/bin/zm_event_start.sh I receive an error: Traceback (most recent call last): File "/var/lib/zmeventnotification/bin/zm_detect.py", line 15, in...
by lorenjz
Wed Jul 01, 2020 2:26 pm
Forum: Mobile Apps
Topic: having issues getting hooks going
Replies: 22
Views: 3560

Re: having issues getting hooks going

Nevermind... I found that this: https://github.com/pliablepixels/zmeven ... issues/156 was the issue