Search found 10 matches

by rkaule
Mon May 21, 2018 7:31 pm
Forum: ZoneMinder 1.30.x
Topic: Convert stand alone to multi server
Replies: 16
Views: 830

Re: Convert stand alone to multi server

After doing more testing I found this. If you have ZM_SERVER_HOST set to an entry in the Servers table the web app, when you click on a monitor's name on the main page, will generate the html for the streaming video that has in the <img> tag src="https://<server_host_field_from_servers_table>/cgi-bi...
by rkaule
Mon May 14, 2018 7:33 pm
Forum: ZoneMinder 1.30.x
Topic: Convert stand alone to multi server
Replies: 16
Views: 830

Re: Convert stand alone to multi server

No firewalls on either server. The one mistake that I made was with the storage array. I attached the same lun's on both servers. It will let you do this. It will even look like they are shared. But without something like GlusterFS they are not shared. So I mounted the storage on one server and crea...
by rkaule
Fri May 11, 2018 11:17 am
Forum: ZoneMinder 1.30.x
Topic: Convert stand alone to multi server
Replies: 16
Views: 830

Re: Convert stand alone to multi server

I did change the Source-Server value for each camera. Are you saying that I need to delete the camera and re-add it? Maybe it is an issue with changing the Source-Server value of an existing monitor? I will set the servers to multi server, then delete the monitor and re-add it to see if that works.
by rkaule
Thu May 10, 2018 3:50 pm
Forum: ZoneMinder 1.30.x
Topic: Convert stand alone to multi server
Replies: 16
Views: 830

Re: Convert stand alone to multi server

I have reviewed the WiKI. The only differences are as follows: I have the original server (I'll refer to as ZM1) running Centos 7.3 with 64Gb of ram dual Xeon processors (top shows 32 cpus). We had 12Tb of storage on an IBM storage array (dual 10Gb iScsi controllers). The server has 2 10Gb iScsi int...
by rkaule
Wed May 09, 2018 3:40 pm
Forum: ZoneMinder 1.30.x
Topic: Convert stand alone to multi server
Replies: 16
Views: 830

Re: Convert stand alone to multi server

I have checked all permissions on both servers, both the file system and the database. As soon as I enter a ZM_SERVER_HOST the video stops. I have been going thru the source (web, perl and cpp) to try to get a handle on what happens when you click on the monitor name on the home page. Anybody have a...
by rkaule
Mon May 07, 2018 6:42 pm
Forum: ZoneMinder 1.30.x
Topic: Convert stand alone to multi server
Replies: 16
Views: 830

Re: Convert stand alone to multi server

Which of the log files would show this?
by rkaule
Mon May 07, 2018 2:49 pm
Forum: ZoneMinder 1.30.x
Topic: Convert stand alone to multi server
Replies: 16
Views: 830

Re: Convert stand alone to multi server

I just tried this. Everything went well. But as soon a I put a value in for ZM_SERVER_HOST and restart zoneminder I can no longer view the video. When logged into ZM1, I change the monitor to use a server it's ip address turns red if on ZM2 and green if it's on ZM1. If I log into ZM2 I see the rever...
by rkaule
Fri Apr 21, 2017 9:02 pm
Forum: ZoneMinder 1.30.x
Topic: 1.30.2 upgrade breaks API access
Replies: 51
Views: 9481

Re: 1.30.2 upgrade breaks API access

Hi all, I had the above problem. I would get a blank page back when trying to access the api page. I did the fix above (systemd-tmpfiles --create zoneminder.conf) and now I get a red bar that states : Error: The requested address '/zm/api/' was not found on this server. Thanks, Bob Assume you have ...
by rkaule
Thu Apr 20, 2017 2:30 am
Forum: ZoneMinder 1.30.x
Topic: 1.30.2 upgrade breaks API access
Replies: 51
Views: 9481

Re: 1.30.2 upgrade breaks API access

No, I'm running Centos 7.
by rkaule
Wed Apr 19, 2017 7:04 pm
Forum: ZoneMinder 1.30.x
Topic: 1.30.2 upgrade breaks API access
Replies: 51
Views: 9481

Re: 1.30.2 upgrade breaks API access

Hi all,

I had the above problem. I would get a blank page back when trying to access the api page. I did the fix above (systemd-tmpfiles --create zoneminder.conf) and now I get a red bar that states :

Error: The requested address '/zm/api/' was not found on this server.

Thanks,
Bob