Search found 674 matches

by mastertheknife
Sat May 20, 2017 7:07 pm
Forum: Hardware Compatibility List
Topic: Logitech HD Pro Webcam C920 on ZoneMinder 1.29.0/Debian Jessie
Replies: 1
Views: 1602

Re: Logitech HD Pro Webcam C920 on ZoneMinder 1.29.0/Debian Jessie

This camera supports H264 (through V4L2), but the current ZoneMinder code doesn't support H264 for local (V4L1\V4L2) cameras.
After support for H264 capture palette is added, you should be able to capture at 1080p.
by mastertheknife
Tue May 16, 2017 8:02 pm
Forum: ZoneMinder 1.29.x
Topic: Raspberry pi3 and h264_mmal
Replies: 57
Views: 10332

Re: Raspberry pi3 and h264_mmal

Regarding the 24bit vs 32bit debate, i have an AArch64 VPS from Scaleway (ARM64-2GB) running 1.30.4 with the neon stuff in it. So i did some tests: ZoneMinder Version: v1.30.4 with ARM Neon code merged in OS: Ubuntu 16.04.2 LTS Server AArch64 CPU: 2 cores of Cavium ThunderX RAM: 2GB, unknown speed M...
by mastertheknife
Sat May 13, 2017 5:27 pm
Forum: ZoneMinder 1.29.x
Topic: Raspberry pi3 and h264_mmal
Replies: 57
Views: 10332

Re: Raspberry pi3 and h264_mmal

The difference should be only in zma. Make sure to use 8bit grayscale or 32bit colour, the optimized delta function isn't used with 24bit colour. This is very similar to what i am seeing on my server. Thanks for sharing :) Sometime in the future i'll probably also optimize AlarmedPixels, which curre...
by mastertheknife
Fri May 12, 2017 10:24 am
Forum: ZoneMinder 1.29.x
Topic: Raspberry pi3 and h264_mmal
Replies: 57
Views: 10332

Re: Raspberry pi3 and h264_mmal

You can fetch the master branch. The neon stuff (AArch32 only at this moment, AArch64 very soon) and its fix was merged to master. You can get a tarball of the master branch here: https://github.com/ZoneMinder/ZoneMinder/tarball/master Keep in mind it the master branch contains untested code. It con...
by mastertheknife
Thu May 11, 2017 6:47 am
Forum: ZoneMinder 1.29.x
Topic: Raspberry pi3 and h264_mmal
Replies: 57
Views: 10332

Re: Raspberry pi3 and h264_mmal

Yes, my bad. It is fixed in pull request #1878:
https://github.com/ZoneMinder/ZoneMinder/pull/1878

Also, this is AArch32 (32bit mode) only. I am still working adding the optimizations for AArch64 (64bit mode).
Raspbian is 32bit, so it should work :)
by mastertheknife
Tue May 09, 2017 6:18 pm
Forum: ZoneMinder 1.30.x
Topic: Image tearing and other issues
Replies: 6
Views: 759

Re: Image tearing and other issues

The image is interlaced by default when using V4L2.
Please select "V4L2: Capture top field only" or "V4L2: Capture bottom field only" in the "Deinterlacing" selection.
Regarding the corruption, what card are you using?
by mastertheknife
Tue Apr 18, 2017 6:15 am
Forum: ZoneMinder 1.30.x
Topic: Modect - use existing events to test new zone rules?
Replies: 4
Views: 1147

Re: Modect - use existing events to test new zone rules?

I did this once, but for development purposes.
If you have the events as videos, create a new monitor with ffmpeg source type, and feed it with the video file. It'll work.
by mastertheknife
Thu Feb 05, 2015 8:26 am
Forum: ZoneMinder 1.28.x
Topic: Linking errors
Replies: 3
Views: 734

Re: Linking errors

Hi,

This happened because ffmpeg was compiled against different versions of those two libraries than what you have installed on your system.

Kfir Itzhak
by mastertheknife
Fri Sep 12, 2014 3:50 pm
Forum: ZoneMinder 1.27.x
Topic: Camera Config Issue
Replies: 2
Views: 972

Re: Camera Config Issue

Hi,

That error means there is a resolution mismatch. The resolution you entered for the monitor does not match the actual resolution of the stream.

mastertheknife
by mastertheknife
Fri Jun 13, 2014 5:23 am
Forum: ZoneMinder 1.27.x
Topic: zmfix?
Replies: 4
Views: 845

Re: zmfix?

zmfix was removed in v1.27
You can safely delete the line that runs zmfix and it should work.
by mastertheknife
Sun Jun 08, 2014 5:02 am
Forum: ZoneMinder 1.27.x
Topic: Make errors, won't install.
Replies: 1
Views: 838

Re: Make errors, won't install.

Hi, Your ffmpeg depends on the bz2 library, so we need to include it in our linking process. If you are using cmake, add -DZM_EXTRA_LIBS="bz2" to your cmake command line. EDIT: it seems you are also missing another library, a one that contains the avresample_* functions. Your ffmpeg was built with -...
by mastertheknife
Sat Jun 07, 2014 3:36 pm
Forum: Feature Requests
Topic: Limit motion detect FPS
Replies: 7
Views: 2190

Re: Limit motion detect FPS

This is now possible in zm v1.27.1 (not yet released).
There is a new option called "Motion Frame Skip" which works like the "Write Frame Skip" option but this one is for motion detection.
by mastertheknife
Fri Jun 06, 2014 5:52 am
Forum: ZoneMinder 1.27.x
Topic: mjpeg issues
Replies: 5
Views: 1007

Re: mjpeg issues

Hi,

Looks like your camera is using Chunked Encoding, which is a HTTP/1.1 feature that ZM's "Remote" source type does not support. If this is ZM v1.27 or newer, you can use the cURL source type, which does support chunked encoding.
by mastertheknife
Mon May 19, 2014 4:53 am
Forum: ZoneMinder 1.27.x
Topic: Cmake prob. ZLIB missing - found 1.2.7
Replies: 3
Views: 1330

Re: Cmake prob. ZLIB missing - found 1.2.7

Hi,

This looks like a bug within cmake, but no fear, zlib and curl are not required dependencies, so you should have no problems continuing the installation.
by mastertheknife
Wed May 14, 2014 9:59 am
Forum: ZoneMinder 1.27.x
Topic: Camera Settings for D-link DCS942L
Replies: 48
Views: 3992

Re: Camera Settings for D-link DCS942L

Now when I cmake it says could not find perl modules missing: PERLMODULES_EXTUTILS_MAKEMAKER_MODULE: How do I fix that? Hi, You are missing the ExtUtils::MakeMaker perl module, which is required for compiling zm's perl modules. You can try installing it using your package manager (e.g. apt-get or y...