[EDIT] Can't install ZM on OrangePiPC+ (Armbian / Debian 10)

Support and queries relating to third party Live CDs and DVD, VM images and other packaged distributions
Post Reply
laurentp
Posts: 4
Joined: Sun May 10, 2020 2:20 pm
Location: Poland / Masovia

[EDIT] Can't install ZM on OrangePiPC+ (Armbian / Debian 10)

Post by laurentp » Mon May 11, 2020 12:01 pm

Hi there,
I have an OrangePiPC+ (ARM, 4 core, 1.8GHz, 1GB RAM, 32GB uSD) with Armbian (Debian 10 for ARMHF + OPi specific kernel / initrd / bootloader), I have tried installation procedure for Debian https://zoneminder.readthedocs.io/en/st ... an-stretch only changing from "Stretch" to "Buster", it works until "apt install zoneminder", then it fails "no package found". Like it does not recognize repo.
What should I do?
Last edited by laurentp on Sat May 23, 2020 2:32 pm, edited 1 time in total.

User avatar
iconnor
Posts: 1197
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: Can't install ZM on OrangePiPC+ (Armbian / Debian 10)

Post by iconnor » Mon May 11, 2020 1:53 pm

If you followed those old instructions it will have given you the wrong line to add to /etc/apt/sources.list

Use this one instead.
deb https://zmrepo.zoneminder.com/debian/release-1.34 buster/

laurentp
Posts: 4
Joined: Sun May 10, 2020 2:20 pm
Location: Poland / Masovia

Re: Can't install ZM on OrangePiPC+ (Armbian / Debian 10)

Post by laurentp » Mon May 11, 2020 5:56 pm

THX, now it works, zoneminder found, it tries now to download dependencies (107 packages).
As I have 2x OPi's, will try on both.

[EDIT]
On second OPi unit, with "OOB" Armbian Buster, some progress:
(2 lines from bottom)
"MySQL/MariaDB not found; assuming remote server.
zoneminder.service is a disabled or a static unit not running, not starting it."

[EDIT2]
Same on "first" OPi unit, with Armbian Jessie updated to Buster (same kernel, same initrd but for some reason does not recognize 4 cores, only 1, so OpenHAB2 in java sometimes kills it, only reboot helps).

WIll explore this.

[EDIT3]
apt install mysql-server (from the same manual page),

"
Package mysql-server has no available version, but is referenced by another package
...
E: package mysql-server has no candidate for installation"
(backtranslating from Polish, so message may not be exact).
also apt search mysql shows no package with such name.

Whats next step?

laurentp
Posts: 4
Joined: Sun May 10, 2020 2:20 pm
Location: Poland / Masovia

Re: [EDIT] Can't install ZM on OrangePiPC+ (Armbian / Debian 10)

Post by laurentp » Sat May 23, 2020 2:42 pm

Ok, partially solved:
- on 32bit OPiPC+ package name is "default-mysql-server", NOT "mysql-server",
installed also apache2.
Reinstalled zoneminder package, found "creating zm db".
Now service starts, I can see perl scripts running (ps -ef), but going to http://server_name/zm leads to totally blank page.
a2enmod (all 3 statements) executed.
No errors in Apache log.

What should I look for?

Second question, CAN'T install ZM on 64 bit OPi3 (same(?) Armbian buster but 64 bit).
error message follows:

Code: Select all

root@orangepi3:~# apt install zoneminder
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 zoneminder:armhf : Depends: libjs-mootools:armhf (>= 1.4.5~debian1) but it is not installable
                    Depends: perl:armhf but it is not going to be installed
                    Depends: javascript-common:armhf but it is not installable
                    Depends: libmime-lite-perl:armhf but it is not installable
                    Depends: libmime-tools-perl:armhf but it is not installable
                    Depends: libdbd-mysql-perl:armhf but it is not going to be installed
                    Depends: libphp-serialization-perl:armhf but it is not installable
                    Depends: libnet-sftp-foreign-perl:armhf but it is not installable
                    Depends: libarchive-zip-perl:armhf but it is not installable
                    Depends: libdevice-serialport-perl:armhf but it is not going to be installed
                    Depends: libimage-info-perl:armhf but it is not installable
                    Depends: libjson-maybexs-perl:armhf but it is not installable
                    Depends: libsys-mmap-perl:armhf but it is not going to be installed
                    Depends: liburi-encode-perl:armhf but it is not installable
                    Depends: libdata-dump-perl:armhf but it is not installable
                    Depends: libdatetime-perl:armhf but it is not going to be installed
                    Depends: libclass-std-fast-perl:armhf but it is not installable
                    Depends: libsoap-wsdl-perl:armhf but it is not installable
                    Depends: libio-socket-multicast-perl:armhf but it is not going to be installed
                    Depends: libsys-cpu-perl:armhf but it is not going to be installed
                    Depends: libsys-meminfo-perl:armhf but it is not going to be installed
                    Depends: libdata-uuid-perl:armhf
                    Depends: libnumber-bytes-human-perl:armhf but it is not installable
                    Depends: libfile-slurp-perl:armhf but it is not installable
                    Depends: mysql-client:armhf but it is not installable or
                             mariadb-client:armhf but it is not installable or
                             virtual-mysql-client:armhf
                    Depends: php5-mysql:armhf but it is not installable or
                             php-mysql:armhf but it is not installable
                    Depends: php5-gd:armhf but it is not installable or
                             php-gd:armhf
                    Depends: php5-apcu:armhf but it is not installable or
                             php-apcu:armhf but it is not going to be installed
                    Depends: php-apc:armhf but it is not installable or
                             php-apcu-bc:armhf but it is not going to be installed
                    Depends: php-json:armhf or
                             php5-json:armhf but it is not installable
                    Depends: rsyslog:armhf but it is not going to be installed or
                             system-log-daemon:armhf
                    Depends: libcrypt-eksblowfish-perl:armhf but it is not going to be installed
                    Depends: libdata-entropy-perl:armhf but it is not installable
E: Unable to correct problems, you have held broken packages.
For some (mysterious to me, but I am new to 64bit world) it looks for 32bit packages (armhf, not arm64).

Last (added as instructed in this thread) of /etc/apt/sources.list are:
#Zoneminder repo
deb https://zmrepo.zoneminder.com/debian/release-1.34 buster/

Same question.

User avatar
iconnor
Posts: 1197
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: [EDIT] Can't install ZM on OrangePiPC+ (Armbian / Debian 10)

Post by iconnor » Mon May 25, 2020 1:29 pm

I probably havn't built it for arm64.

You might be better off using our do_debian_package.sh script to build your own.

laurentp
Posts: 4
Joined: Sun May 10, 2020 2:20 pm
Location: Poland / Masovia

Re: [EDIT] Can't install ZM on OrangePiPC+ (Armbian / Debian 10)

Post by laurentp » Tue May 26, 2020 7:33 am

iconnor wrote:
Mon May 25, 2020 1:29 pm
...You might be better off using our do_debian_package.sh script to build your own.
OK, where are instructions about this process? (URL) Compilation isn't new for me :)

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest