[SOLVED] zoneminder-nginx conflicts zoneminder-httpd

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
davama
Posts: 6
Joined: Tue Oct 15, 2019 4:07 pm

[SOLVED] zoneminder-nginx conflicts zoneminder-httpd

Post by davama » Tue Oct 15, 2019 4:28 pm

Hello,
First time poster on this forum.
Attempting to follow the redhat guide https://zoneminder.readthedocs.io/en/la ... edhat.html
But want to use nginx instead of apache.

Code: Select all

[root@video ~]# cat /etc/redhat-release 
CentOS Linux release 7.7.1908 (Core)
[root@video ~]# uname -a
Linux video 3.10.0-1062.1.2.el7.x86_64 #1 SMP Mon Sep 30 14:19:46 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
[root@video ~]# zmc -v
1.32.3
When trying to install zoneminder-nginx I get the following conflicts:

Code: Select all

[root@video ~]# yum install zoneminder-nginx
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.atlanticmetro.net
 * epel: fedora-epel.mirrors.tds.net
 * extras: mirror.atlanticmetro.net
 * rpmfusion-free-updates: mirror.math.princeton.edu
 * updates: mirror.atlanticmetro.net
Resolving Dependencies
--> Running transaction check
---> Package zoneminder-nginx.x86_64 0:1.32.3-1.el7 will be installed
--> Processing Conflict: zoneminder-httpd-1.32.3-1.el7.x86_64 conflicts zoneminder-nginx
--> Processing Conflict: zoneminder-nginx-1.32.3-1.el7.x86_64 conflicts zoneminder-httpd
--> Finished Dependency Resolution
Error: zoneminder-nginx conflicts with zoneminder-httpd-1.32.3-1.el7.x86_64
Error: zoneminder-httpd conflicts with zoneminder-nginx-1.32.3-1.el7.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
I did try installing zoneminder withouth zoneminder-httpd but zoneminder depends on httpd

Code: Select all

[root@video ~]# yum install  zoneminder --exclude="zoneminder-httpd"
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.siena.edu
 * epel: fedora-epel.mirrors.tds.net
 * extras: mirror.siena.edu
 * rpmfusion-free-updates: mirror.math.princeton.edu
 * updates: mirror.siena.edu
Resolving Dependencies
--> Running transaction check
---> Package zoneminder.x86_64 0:1.32.3-1.el7 will be installed
--> Processing Dependency: zoneminder-httpd(x86-64) = 1.32.3-1.el7 for package: zoneminder-1.32.3-1.el7.x86_64
--> Finished Dependency Resolution
Error: Package: zoneminder-1.32.3-1.el7.x86_64 (rpmfusion-free-updates)
           Requires: zoneminder-httpd(x86-64) = 1.32.3-1.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Wondering how I can go about this without breakage?
Any input is much appreciated!

Thank you,
Dave
Last edited by davama on Wed Oct 16, 2019 2:12 pm, edited 1 time in total.

kitkat
Posts: 88
Joined: Sun Jan 27, 2019 5:17 pm

Re: zoneminder-nginx conflicts zoneminder-httpd

Post by kitkat » Tue Oct 15, 2019 7:36 pm

davama wrote:
Tue Oct 15, 2019 4:28 pm
[root@video ~]# zmc -v
1.32.3
You'll probably have to remove the old version before installing the new one...

Code: Select all

$ yum autoremove zoneminder

davama
Posts: 6
Joined: Tue Oct 15, 2019 4:07 pm

Re: zoneminder-nginx conflicts zoneminder-httpd

Post by davama » Tue Oct 15, 2019 8:29 pm

Thank you for the reply @kitkat
kitkat wrote:
Tue Oct 15, 2019 7:36 pm
You'll probably have to remove the old version before installing the new one...
Unfortunately I do not understand what you mean by that. You men 1.33.x? I believe this is still in development, not for public release.

I am using, as the doc says, rpmfusion repo which has the 1.32.x release. https://download1.rpmfusion.org/free/el ... /x86_64/z/

For some reason zoneminder-1.32.3-1.el7.x86_64.rpm depends on zoneminder-httpd-1.32.3-1.el7.x86_64.rpm and you cannot install zoneminder-nginx-1.32.3-1.el7.x86_64.rpm without receiving the "yum conflict error" on POST#1

Is this by design or am I doing something wrong?
Personally does not make sense the dependency, since the packages are separated but I am a first time user of this software, so probably i'm wrong.

Any more input is much appreciated!

kitkat
Posts: 88
Joined: Sun Jan 27, 2019 5:17 pm

Re: zoneminder-nginx conflicts zoneminder-httpd

Post by kitkat » Tue Oct 15, 2019 9:05 pm

I may be misreading all this but, as you have zmc installed I'm presuming that you also have some version of zoneminder already installed, probably the -httpd version (that's what I ended up with without specifying a version), and that the conflict message therefore relates to the -nginx version conflicting with the already-installed version.

'yum autoremove zoneminder' should remove the installed version along with all of its otherwise-unused dependencies and allow the -nginx version to be installed instead.


e2a: Maybe 'yum autoremove zoneminder-httpd' would suffice?

davama
Posts: 6
Joined: Tue Oct 15, 2019 4:07 pm

Re: zoneminder-nginx conflicts zoneminder-httpd

Post by davama » Wed Oct 16, 2019 12:33 pm

Thank you for the reply @kitkat

This is a new install so there is no previous version.

Code: Select all

[root@video ~]# yum remove zoneminder-httpd
Loaded plugins: fastestmirror
Resolving Dependencies
--> Running transaction check
---> Package zoneminder-httpd.x86_64 0:1.32.3-1.el7 will be erased
--> Processing Dependency: zoneminder-httpd(x86-64) = 1.32.3-1.el7 for package: zoneminder-1.32.3-1.el7.x86_64
--> Running transaction check
---> Package zoneminder.x86_64 0:1.32.3-1.el7 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

====================================================================================================================================================================================================
 Package                                          Arch                                   Version                                      Repository                                               Size
====================================================================================================================================================================================================
Removing:
 zoneminder-httpd                                 x86_64                                 1.32.3-1.el7                                 @rpmfusion-free-updates                                 7.0 k
Removing for dependencies:
 zoneminder                                       x86_64                                 1.32.3-1.el7                                 @rpmfusion-free-updates                                 0.0  

Transaction Summary
====================================================================================================================================================================================================
Remove  1 Package (+1 Dependent package)

Installed size: 7.0 k
Is this ok [y/N]: 

Problem is that I CANNOT install -nginx package without yum complaining of conflict. zoneminder depends on -httpd, why? it should be the other way around. -httpd or -nginx should depend on zoneminder.

Code: Select all

[root@video ~]# yum deplist zoneminder
[...]
package: zoneminder.x86_64 1.32.3-1.el7
  dependency: /bin/sh
   provider: bash.x86_64 4.2.46-33.el7
  dependency: zoneminder-common(x86-64) = 1.32.3-1.el7
   provider: zoneminder-common.x86_64 1.32.3-1.el7
  dependency: zoneminder-httpd(x86-64) = 1.32.3-1.el7
   provider: zoneminder-httpd.x86_64 1.32.3-1.el7

[root@video ~]# yum deplist zoneminder-httpd
[...]
package: zoneminder-httpd.x86_64 1.32.3-1.el7
  dependency: /bin/sh
   provider: bash.x86_64 4.2.46-33.el7
  dependency: httpd
   provider: httpd.x86_64 2.4.6-90.el7.centos
  dependency: php
   provider: php.x86_64 5.4.16-46.el7
  dependency: zoneminder-common(x86-64) = 1.32.3-1.el7
   provider: zoneminder-common.x86_64 1.32.3-1.el7
   
[root@video ~]# yum deplist zoneminder-nginx
[...]
package: zoneminder-nginx.x86_64 1.32.3-1.el7
  dependency: /bin/sh
   provider: bash.x86_64 4.2.46-33.el7
  dependency: fcgiwrap
   provider: fcgiwrap.x86_64 1.1.0-9.20181108git99c942c.el7
  dependency: nginx
   provider: nginx.x86_64 1:1.12.2-3.el7
  dependency: php-fpm
   provider: php-fpm.x86_64 5.4.16-46.el7
  dependency: zoneminder-common(x86-64) = 1.32.3-1.el7
   provider: zoneminder-common.x86_64 1.32.3-1.el7
To summarize, one cannot install -nginx package because it will conflict with -httpd package.

kitkat
Posts: 88
Joined: Sun Jan 27, 2019 5:17 pm

Re: zoneminder-nginx conflicts zoneminder-httpd

Post by kitkat » Wed Oct 16, 2019 1:14 pm

davama wrote:
Wed Oct 16, 2019 12:33 pm
Thank you for the reply @kitkat

This is a new install so there is no previous version.
So where did your copy of zmc in the first post come from?

Code: Select all

[root@video ~]# zmc -v
1.32.3
Problem is that I CANNOT install -nginx package without yum complaining of conflict. zoneminder depends on -httpd, why? it should be the other way around. -httpd or -nginx should depend on zoneminder.

Code: Select all

[root@video ~]# yum deplist zoneminder
[...]
package: zoneminder.x86_64 1.32.3-1.el7
  dependency: /bin/sh
   provider: bash.x86_64 4.2.46-33.el7
  dependency: zoneminder-common(x86-64) = 1.32.3-1.el7
   provider: zoneminder-common.x86_64 1.32.3-1.el7
  dependency: zoneminder-httpd(x86-64) = 1.32.3-1.el7
   provider: zoneminder-httpd.x86_64 1.32.3-1.el7

[root@video ~]# yum deplist zoneminder-httpd
[...]
package: zoneminder-httpd.x86_64 1.32.3-1.el7
  dependency: /bin/sh
   provider: bash.x86_64 4.2.46-33.el7
  dependency: httpd
   provider: httpd.x86_64 2.4.6-90.el7.centos
  dependency: php
   provider: php.x86_64 5.4.16-46.el7
  dependency: zoneminder-common(x86-64) = 1.32.3-1.el7
   provider: zoneminder-common.x86_64 1.32.3-1.el7
   
[root@video ~]# yum deplist zoneminder-nginx
[...]
package: zoneminder-nginx.x86_64 1.32.3-1.el7
  dependency: /bin/sh
   provider: bash.x86_64 4.2.46-33.el7
  dependency: fcgiwrap
   provider: fcgiwrap.x86_64 1.1.0-9.20181108git99c942c.el7
  dependency: nginx
   provider: nginx.x86_64 1:1.12.2-3.el7
  dependency: php-fpm
   provider: php-fpm.x86_64 5.4.16-46.el7
  dependency: zoneminder-common(x86-64) = 1.32.3-1.el7
   provider: zoneminder-common.x86_64 1.32.3-1.el7
To summarize, one cannot install -nginx package because it will conflict with -httpd package.
It looks like installing zoneminer without specifying either -httpd or -nginx defaults to the -httpd version, which then obviously depends on zoneminder-httpd, and it also pulls in -common.

The -nginx install also includes -common, along with the other nginx-specific files, but it doesn't include -httpd.

So what happens if you skip the 'install zoneminder' step completely and go straight to 'install zoneinder-nginx'? I guess you may need to 'yum autoremove zoneminder' first, but yum may be smart enough to figure things out.


e2a: Reading again, I'm kind of surprised that 'yum install zoneminder-nginx' doesn't work now that zoneminder-httpd and zoneminder have been removed because there should no longer be any conflicts.

kitkat
Posts: 88
Joined: Sun Jan 27, 2019 5:17 pm

Re: zoneminder-nginx conflicts zoneminder-httpd

Post by kitkat » Wed Oct 16, 2019 1:37 pm

This is from a system that has an older version of ZM (1.32.2), so none of the -common, -hhtpd, or -nginx packages are installed but most of the other dependencies from zoneminder-common are, and it looks like it'd work OK...

Code: Select all

$ yum install zoneminder-nginx
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
epel/x86_64/metalink                                                                                                 |  28 kB  00:00:00
 * base: mirror.as29550.net
 * epel: mirror.kinamo.be
 * extras: mirror.as29550.net
 * rpmfusion-free-updates: mirror.ehv.weppel.nl
 * rpmfusion-nonfree-updates: mirror.ehv.weppel.nl
 * updates: mirror.sov.uk.goscomb.net
base                                                                                                                 | 3.6 kB  00:00:00
epel                                                                                                                 | 5.3 kB  00:00:00
extras                                                                                                               | 2.9 kB  00:00:00
rpmfusion-free-updates                                                                                               | 3.7 kB  00:00:00
rpmfusion-nonfree-updates                                                                                            | 3.7 kB  00:00:00
updates                                                                                                              | 2.9 kB  00:00:00
(1/4): rpmfusion-nonfree-updates/x86_64/group_gz                                                                     |  920 B  00:00:00
(2/4): rpmfusion-free-updates/x86_64/group_gz                                                                        | 1.4 kB  00:00:00
(3/4): epel/x86_64/updateinfo                                                                                        | 1.0 MB  00:00:00
(4/4): epel/x86_64/primary_db                                                                                        | 6.9 MB  00:00:01
Resolving Dependencies
--> Running transaction check
---> Package zoneminder-nginx.x86_64 0:1.32.3-1.el7 will be installed
--> Processing Dependency: zoneminder-common(x86-64) = 1.32.3-1.el7 for package: zoneminder-nginx-1.32.3-1.el7.x86_64
--> Processing Dependency: php-fpm for package: zoneminder-nginx-1.32.3-1.el7.x86_64
--> Processing Dependency: nginx for package: zoneminder-nginx-1.32.3-1.el7.x86_64
--> Processing Dependency: fcgiwrap for package: zoneminder-nginx-1.32.3-1.el7.x86_64
--> Running transaction check
---> Package fcgiwrap.x86_64 0:1.1.0-9.20181108git99c942c.el7 will be installed
--> Processing Dependency: libfcgi.so.0()(64bit) for package: fcgiwrap-1.1.0-9.20181108git99c942c.el7.x86_64
---> Package nginx.x86_64 1:1.12.2-3.el7 will be installed
--> Processing Dependency: nginx-all-modules = 1:1.12.2-3.el7 for package: 1:nginx-1.12.2-3.el7.x86_64
--> Processing Dependency: nginx-filesystem = 1:1.12.2-3.el7 for package: 1:nginx-1.12.2-3.el7.x86_64
--> Processing Dependency: nginx-filesystem for package: 1:nginx-1.12.2-3.el7.x86_64
--> Processing Dependency: libprofiler.so.0()(64bit) for package: 1:nginx-1.12.2-3.el7.x86_64
---> Package php-fpm.x86_64 0:5.4.16-46.el7 will be installed
---> Package zoneminder-common.x86_64 0:1.32.3-1.el7 will be installed
--> Running transaction check
---> Package fcgi.x86_64 0:2.4.0-25.el7 will be installed
---> Package gperftools-libs.x86_64 0:2.6.1-1.el7 will be installed
---> Package nginx-all-modules.noarch 1:1.12.2-3.el7 will be installed
--> Processing Dependency: nginx-mod-http-geoip = 1:1.12.2-3.el7 for package: 1:nginx-all-modules-1.12.2-3.el7.noarch
--> Processing Dependency: nginx-mod-http-image-filter = 1:1.12.2-3.el7 for package: 1:nginx-all-modules-1.12.2-3.el7.noarch
--> Processing Dependency: nginx-mod-http-perl = 1:1.12.2-3.el7 for package: 1:nginx-all-modules-1.12.2-3.el7.noarch
--> Processing Dependency: nginx-mod-http-xslt-filter = 1:1.12.2-3.el7 for package: 1:nginx-all-modules-1.12.2-3.el7.noarch
--> Processing Dependency: nginx-mod-mail = 1:1.12.2-3.el7 for package: 1:nginx-all-modules-1.12.2-3.el7.noarch
--> Processing Dependency: nginx-mod-stream = 1:1.12.2-3.el7 for package: 1:nginx-all-modules-1.12.2-3.el7.noarch
---> Package nginx-filesystem.noarch 1:1.12.2-3.el7 will be installed
--> Running transaction check
---> Package nginx-mod-http-geoip.x86_64 1:1.12.2-3.el7 will be installed
---> Package nginx-mod-http-image-filter.x86_64 1:1.12.2-3.el7 will be installed
--> Processing Dependency: gd for package: 1:nginx-mod-http-image-filter-1.12.2-3.el7.x86_64
--> Processing Dependency: libgd.so.2()(64bit) for package: 1:nginx-mod-http-image-filter-1.12.2-3.el7.x86_64
---> Package nginx-mod-http-perl.x86_64 1:1.12.2-3.el7 will be installed
---> Package nginx-mod-http-xslt-filter.x86_64 1:1.12.2-3.el7 will be installed
---> Package nginx-mod-mail.x86_64 1:1.12.2-3.el7 will be installed
---> Package nginx-mod-stream.x86_64 1:1.12.2-3.el7 will be installed
--> Running transaction check
---> Package gd.x86_64 0:2.0.35-26.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

============================================================================================================================================
 Package                                Arch              Version                                   Repository                         Size
============================================================================================================================================
Installing:
 zoneminder-nginx                       x86_64            1.32.3-1.el7                              rpmfusion-free-updates             21 k
Installing for dependencies:
 fcgi                                   x86_64            2.4.0-25.el7                              epel                               47 k
 fcgiwrap                               x86_64            1.1.0-9.20181108git99c942c.el7            epel                               21 k
 gd                                     x86_64            2.0.35-26.el7                             base                              146 k
 gperftools-libs                        x86_64            2.6.1-1.el7                               base                              272 k
 nginx                                  x86_64            1:1.12.2-3.el7                            epel                              531 k
 nginx-all-modules                      noarch            1:1.12.2-3.el7                            epel                               16 k
 nginx-filesystem                       noarch            1:1.12.2-3.el7                            epel                               17 k
 nginx-mod-http-geoip                   x86_64            1:1.12.2-3.el7                            epel                               23 k
 nginx-mod-http-image-filter            x86_64            1:1.12.2-3.el7                            epel                               27 k
 nginx-mod-http-perl                    x86_64            1:1.12.2-3.el7                            epel                               36 k
 nginx-mod-http-xslt-filter             x86_64            1:1.12.2-3.el7                            epel                               26 k
 nginx-mod-mail                         x86_64            1:1.12.2-3.el7                            epel                               54 k
 nginx-mod-stream                       x86_64            1:1.12.2-3.el7                            epel                               76 k
 php-fpm                                x86_64            5.4.16-46.el7                             base                              1.4 M
 zoneminder-common                      x86_64            1.32.3-1.el7                              rpmfusion-free-updates            8.7 M

Transaction Summary
============================================================================================================================================
Install  1 Package (+15 Dependent packages)

Total download size: 11 M
Installed size: 45 M
Is this ok [y/d/N]:
Last edited by kitkat on Wed Oct 16, 2019 1:40 pm, edited 1 time in total.

davama
Posts: 6
Joined: Tue Oct 15, 2019 4:07 pm

Re: zoneminder-nginx conflicts zoneminder-httpd

Post by davama » Wed Oct 16, 2019 1:39 pm

kitkat wrote:
Wed Oct 16, 2019 1:14 pm


So where did your copy of zmc in the first post come from?

Code: Select all

[root@video ~]# zmc -v
1.32.3
Because I installed zoneminder in the first place, so for community support purposes, I was simply showing which version of zoneminder I am having an issue with....
kitkat wrote:
Wed Oct 16, 2019 1:14 pm
So what happens if you skip the 'install zoneminder' step completely and go straight to 'install zoneinder-nginx'? I guess you may need to 'yum autoremove zoneminder' first, but yum may be smart enough to figure things out.
Nothing will happen, as already posted:
davama wrote:
Wed Oct 16, 2019 12:33 pm

Code: Select all

 
[root@video ~]# yum deplist zoneminder-nginx
[...]
package: zoneminder-nginx.x86_64 1.32.3-1.el7
  dependency: /bin/sh
   provider: bash.x86_64 4.2.46-33.el7
  dependency: fcgiwrap
   provider: fcgiwrap.x86_64 1.1.0-9.20181108git99c942c.el7
  dependency: nginx
   provider: nginx.x86_64 1:1.12.2-3.el7
  dependency: php-fpm
   provider: php-fpm.x86_64 5.4.16-46.el7
  dependency: zoneminder-common(x86-64) = 1.32.3-1.el7
   provider: zoneminder-common.x86_64 1.32.3-1.el7
To summarize, one cannot install -nginx package because it will conflict with -httpd package.
Here is the proof:

Code: Select all

[root@video ~]# rpm -qa "zone*"
zoneminder-common-1.32.3-1.el7.x86_64
[root@video ~]# 
[root@video ~]# yum install zoneminder-nginx
[...]
Resolving Dependencies
--> Running transaction check
---> Package zoneminder-nginx.x86_64 0:1.32.3-1.el7 will be installed
--> Processing Dependency: php-fpm for package: zoneminder-nginx-1.32.3-1.el7.x86_64
--> Processing Dependency: nginx for package: zoneminder-nginx-1.32.3-1.el7.x86_64
--> Running transaction check
---> Package nginx.x86_64 1:1.12.2-3.el7 will be installed
--> Processing Dependency: nginx-all-modules = 1:1.12.2-3.el7 for package: 1:nginx-1.12.2-3.el7.x86_64
---> Package php-fpm.x86_64 0:5.4.16-46.el7 will be installed
--> Running transaction check
---> Package nginx-all-modules.noarch 1:1.12.2-3.el7 will be installed
--> Processing Dependency: nginx-mod-http-geoip = 1:1.12.2-3.el7 for package: 1:nginx-all-modules-1.12.2-3.el7.noarch
--> Processing Dependency: nginx-mod-http-image-filter = 1:1.12.2-3.el7 for package: 1:nginx-all-modules-1.12.2-3.el7.noarch
--> Processing Dependency: nginx-mod-http-perl = 1:1.12.2-3.el7 for package: 1:nginx-all-modules-1.12.2-3.el7.noarch
--> Processing Dependency: nginx-mod-http-xslt-filter = 1:1.12.2-3.el7 for package: 1:nginx-all-modules-1.12.2-3.el7.noarch
--> Processing Dependency: nginx-mod-mail = 1:1.12.2-3.el7 for package: 1:nginx-all-modules-1.12.2-3.el7.noarch
--> Processing Dependency: nginx-mod-stream = 1:1.12.2-3.el7 for package: 1:nginx-all-modules-1.12.2-3.el7.noarch
--> Running transaction check
---> Package nginx-mod-http-geoip.x86_64 1:1.12.2-3.el7 will be installed
---> Package nginx-mod-http-image-filter.x86_64 1:1.12.2-3.el7 will be installed
--> Processing Dependency: gd for package: 1:nginx-mod-http-image-filter-1.12.2-3.el7.x86_64
--> Processing Dependency: libgd.so.2()(64bit) for package: 1:nginx-mod-http-image-filter-1.12.2-3.el7.x86_64
---> Package nginx-mod-http-perl.x86_64 1:1.12.2-3.el7 will be installed
---> Package nginx-mod-http-xslt-filter.x86_64 1:1.12.2-3.el7 will be installed
---> Package nginx-mod-mail.x86_64 1:1.12.2-3.el7 will be installed
---> Package nginx-mod-stream.x86_64 1:1.12.2-3.el7 will be installed
--> Running transaction check
---> Package gd.x86_64 0:2.0.35-26.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

====================================================================================================================================================================================================
 Package                                                  Arch                                Version                                     Repository                                           Size
====================================================================================================================================================================================================
Installing:
 zoneminder-nginx                                         x86_64                              1.32.3-1.el7                                rpmfusion-free-updates                               21 k
Installing for dependencies:
 gd                                                       x86_64                              2.0.35-26.el7                               base                                                146 k
 nginx                                                    x86_64                              1:1.12.2-3.el7                              epel                                                531 k
 nginx-all-modules                                        noarch                              1:1.12.2-3.el7                              epel                                                 16 k
 nginx-mod-http-geoip                                     x86_64                              1:1.12.2-3.el7                              epel                                                 23 k
 nginx-mod-http-image-filter                              x86_64                              1:1.12.2-3.el7                              epel                                                 27 k
 nginx-mod-http-perl                                      x86_64                              1:1.12.2-3.el7                              epel                                                 36 k
 nginx-mod-http-xslt-filter                               x86_64                              1:1.12.2-3.el7                              epel                                                 26 k
 nginx-mod-mail                                           x86_64                              1:1.12.2-3.el7                              epel                                                 54 k
 nginx-mod-stream                                         x86_64                              1:1.12.2-3.el7                              epel                                                 76 k
 php-fpm                                                  x86_64                              5.4.16-46.el7                               base                                                1.4 M

Transaction Summary
====================================================================================================================================================================================================
Install  1 Package (+10 Dependent packages)

Total download size: 2.4 M
Installed size: 6.9 M
Is this ok [y/d/N]: n
Thanks

kitkat
Posts: 88
Joined: Sun Jan 27, 2019 5:17 pm

Re: zoneminder-nginx conflicts zoneminder-httpd

Post by kitkat » Wed Oct 16, 2019 1:45 pm

davama wrote:
Wed Oct 16, 2019 1:39 pm
Here is the proof:

Code: Select all

[root@video ~]# rpm -qa "zone*"
zoneminder-common-1.32.3-1.el7.x86_64
[root@video ~]# 
[root@video ~]# yum install zoneminder-nginx
[...]
Resolving Dependencies
--> Running transaction check
---> Package zoneminder-nginx.x86_64 0:1.32.3-1.el7 will be installed
--> Processing Dependency: php-fpm for package: zoneminder-nginx-1.32.3-1.el7.x86_64
--> Processing Dependency: nginx for package: zoneminder-nginx-1.32.3-1.el7.x86_64
--> Running transaction check
---> Package nginx.x86_64 1:1.12.2-3.el7 will be installed
--> Processing Dependency: nginx-all-modules = 1:1.12.2-3.el7 for package: 1:nginx-1.12.2-3.el7.x86_64
---> Package php-fpm.x86_64 0:5.4.16-46.el7 will be installed
--> Running transaction check
---> Package nginx-all-modules.noarch 1:1.12.2-3.el7 will be installed
--> Processing Dependency: nginx-mod-http-geoip = 1:1.12.2-3.el7 for package: 1:nginx-all-modules-1.12.2-3.el7.noarch
--> Processing Dependency: nginx-mod-http-image-filter = 1:1.12.2-3.el7 for package: 1:nginx-all-modules-1.12.2-3.el7.noarch
--> Processing Dependency: nginx-mod-http-perl = 1:1.12.2-3.el7 for package: 1:nginx-all-modules-1.12.2-3.el7.noarch
--> Processing Dependency: nginx-mod-http-xslt-filter = 1:1.12.2-3.el7 for package: 1:nginx-all-modules-1.12.2-3.el7.noarch
--> Processing Dependency: nginx-mod-mail = 1:1.12.2-3.el7 for package: 1:nginx-all-modules-1.12.2-3.el7.noarch
--> Processing Dependency: nginx-mod-stream = 1:1.12.2-3.el7 for package: 1:nginx-all-modules-1.12.2-3.el7.noarch
--> Running transaction check
---> Package nginx-mod-http-geoip.x86_64 1:1.12.2-3.el7 will be installed
---> Package nginx-mod-http-image-filter.x86_64 1:1.12.2-3.el7 will be installed
--> Processing Dependency: gd for package: 1:nginx-mod-http-image-filter-1.12.2-3.el7.x86_64
--> Processing Dependency: libgd.so.2()(64bit) for package: 1:nginx-mod-http-image-filter-1.12.2-3.el7.x86_64
---> Package nginx-mod-http-perl.x86_64 1:1.12.2-3.el7 will be installed
---> Package nginx-mod-http-xslt-filter.x86_64 1:1.12.2-3.el7 will be installed
---> Package nginx-mod-mail.x86_64 1:1.12.2-3.el7 will be installed
---> Package nginx-mod-stream.x86_64 1:1.12.2-3.el7 will be installed
--> Running transaction check
---> Package gd.x86_64 0:2.0.35-26.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

====================================================================================================================================================================================================
 Package                                                  Arch                                Version                                     Repository                                           Size
====================================================================================================================================================================================================
Installing:
 zoneminder-nginx                                         x86_64                              1.32.3-1.el7                                rpmfusion-free-updates                               21 k
Installing for dependencies:
 gd                                                       x86_64                              2.0.35-26.el7                               base                                                146 k
 nginx                                                    x86_64                              1:1.12.2-3.el7                              epel                                                531 k
 nginx-all-modules                                        noarch                              1:1.12.2-3.el7                              epel                                                 16 k
 nginx-mod-http-geoip                                     x86_64                              1:1.12.2-3.el7                              epel                                                 23 k
 nginx-mod-http-image-filter                              x86_64                              1:1.12.2-3.el7                              epel                                                 27 k
 nginx-mod-http-perl                                      x86_64                              1:1.12.2-3.el7                              epel                                                 36 k
 nginx-mod-http-xslt-filter                               x86_64                              1:1.12.2-3.el7                              epel                                                 26 k
 nginx-mod-mail                                           x86_64                              1:1.12.2-3.el7                              epel                                                 54 k
 nginx-mod-stream                                         x86_64                              1:1.12.2-3.el7                              epel                                                 76 k
 php-fpm                                                  x86_64                              5.4.16-46.el7                               base                                                1.4 M

Transaction Summary
====================================================================================================================================================================================================
Install  1 Package (+10 Dependent packages)

Total download size: 2.4 M
Installed size: 6.9 M
Is this ok [y/d/N]: n
Thanks
Isn't that right, though? No conflicts, zoneminder-common already installed, zoneminder-nginx and its dependencies to be installed, with no mention of zoneminder-httpd.

davama
Posts: 6
Joined: Tue Oct 15, 2019 4:07 pm

Re: zoneminder-nginx conflicts zoneminder-httpd

Post by davama » Wed Oct 16, 2019 1:55 pm

kitkat wrote:
Wed Oct 16, 2019 1:45 pm
Isn't that right, though? No conflicts, zoneminder-common already installed, zoneminder-nginx and its dependencies to be installed, with no mention of zoneminder-httpd.
Not to me, but I am a first time user of this software, so idk. I am trying to provide a POC.
Either way, it does not make sense that `zoneminder` cannot be installed along with `-nginx`

Code: Select all

[root@video ~]# rpm -qa "zone*"
zoneminder-nginx-1.32.3-1.el7.x86_64
zoneminder-common-1.32.3-1.el7.x86_64
[root@video ~]# 
[root@video ~]# yum install zoneminder
[...]
Resolving Dependencies
--> Running transaction check
---> Package zoneminder.x86_64 0:1.32.3-1.el7 will be installed
--> Processing Dependency: zoneminder-httpd(x86-64) = 1.32.3-1.el7 for package: zoneminder-1.32.3-1.el7.x86_64
--> Running transaction check
---> Package zoneminder-httpd.x86_64 0:1.32.3-1.el7 will be installed
--> Processing Conflict: zoneminder-nginx-1.32.3-1.el7.x86_64 conflicts zoneminder-httpd
--> Processing Conflict: zoneminder-httpd-1.32.3-1.el7.x86_64 conflicts zoneminder-nginx
--> Finished Dependency Resolution
Error: zoneminder-nginx conflicts with zoneminder-httpd-1.32.3-1.el7.x86_64
Error: zoneminder-httpd conflicts with zoneminder-nginx-1.32.3-1.el7.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

kitkat
Posts: 88
Joined: Sun Jan 27, 2019 5:17 pm

Re: zoneminder-nginx conflicts zoneminder-httpd

Post by kitkat » Wed Oct 16, 2019 2:01 pm

davama wrote:
Wed Oct 16, 2019 1:55 pm

Code: Select all

[root@video ~]# rpm -qa "zone*"
zoneminder-nginx-1.32.3-1.el7.x86_64
zoneminder-common-1.32.3-1.el7.x86_64

[root@video ~]# 
[root@video ~]# yum install zoneminder
[...]
Resolving Dependencies
--> Running transaction check
---> Package zoneminder.x86_64 0:1.32.3-1.el7 will be installed
--> Processing Dependency: zoneminder-httpd(x86-64) = 1.32.3-1.el7 for package: zoneminder-1.32.3-1.el7.x86_64
--> Running transaction check
---> Package zoneminder-httpd.x86_64 0:1.32.3-1.el7 will be installed
--> Processing Conflict: zoneminder-nginx-1.32.3-1.el7.x86_64 conflicts zoneminder-httpd
--> Processing Conflict: zoneminder-httpd-1.32.3-1.el7.x86_64 conflicts zoneminder-nginx
--> Finished Dependency Resolution
Error: zoneminder-nginx conflicts with zoneminder-httpd-1.32.3-1.el7.x86_64
Error: zoneminder-httpd conflicts with zoneminder-nginx-1.32.3-1.el7.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
You're all done - There's no need to install zoneminder when either zoneminder-httpd or zoneminder-nginx are installed.

The 'zoneminder' package is effectively the same as/a shortcut to 'zoneminder-httpd'


e2a: Basically, you should install just one of zoneminder-httpd, zoneminder-nginx, or zoneminder (which, as mentioned, is the same as zoneminder-httpd). zoneminder-common will be installed as a dependency in all cases.

davama
Posts: 6
Joined: Tue Oct 15, 2019 4:07 pm

Re: zoneminder-nginx conflicts zoneminder-httpd

Post by davama » Wed Oct 16, 2019 2:12 pm

No way??

That is very different from what i've seen with other applications (separation from actual application and frontend preference)

Code: Select all

[root@video ~]# yum search zoneminder
[...]
zoneminder-common.x86_64 : Common files for ZoneMinder, not tied to a specific web server
zoneminder-httpd.x86_64 : ZoneMinder configuration for Apache web server
zoneminder-nginx.x86_64 : ZoneMinder configuration for Nginx web server
mythzoneminder.x86_64 : A module for MythTV for camera security and surveillance
zoneminder.x86_64 : A camera monitoring and analysis tool
Interesting...
I'll give it a go.

Thank you very much for your help and patience @kitkat

Marking as solved

kitkat
Posts: 88
Joined: Sun Jan 27, 2019 5:17 pm

Re: [SOLVED] zoneminder-nginx conflicts zoneminder-httpd

Post by kitkat » Wed Oct 16, 2019 2:20 pm

I'm pretty sure that's the way it works.

I suspect that you may still run into problems though, because you'll now probably have both Apache and nginx installed, and they may not play nicely together (or they may, I really don't know).

I would have done a 'yum autoremove zoneminder-httpd' to remove it as well as all its otherwise-unused dependencies.

I'd be tempted to autoremove zm-nginx, install zm-httpd again, autoremove that, and then reinstall zm-nginx.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests