Installing on Kubuntu 13.10

Support and queries relating to third party Live CDs and DVD, VM images and other packaged distributions
pdharg
Posts: 23
Joined: Fri Feb 14, 2014 1:14 pm

Installing on Kubuntu 13.10

Post by pdharg » Tue Feb 18, 2014 1:10 pm

Has anyone got ZoneMinder working on Ubuntu 13.10 64bit.

I followed "Installation from a .deb" but with advice from "Fixing Apache after Ubuntu 13.10 upgrade".

When I access localhost I get a blank page.

Any ideas, please? Thank you.

pdharg
Posts: 23
Joined: Fri Feb 14, 2014 1:14 pm

Re: Installing on Kubuntu 13.10

Post by pdharg » Tue Feb 18, 2014 2:36 pm

Just tried this, but:

Code: Select all

peter@dv-460mt:/var/log$ service zoneminder start
Starting ZoneMinder: failure

peter@dv-460mt:/var/log$
Help please. Thank you.

hans109h
Posts: 16
Joined: Fri Jun 10, 2011 11:58 pm

Re: Installing on Kubuntu 13.10

Post by hans109h » Thu Feb 20, 2014 8:26 pm

Failure isn't very helpful.

locate your zmpkg.pl file and attempt to execute it directly and post back what the standard output is. Also monitor your system log.

Hans

pdharg
Posts: 23
Joined: Fri Feb 14, 2014 1:14 pm

Re: Installing on Kubuntu 13.10

Post by pdharg » Sat Feb 22, 2014 1:36 pm

Thanks Hans, but I just found this, which got me sorted:

"When you try to access the ZM web page you get a blank screen.

The issue is in the php.ini file and is a value called:

short_open_tag = Off

This value needs to be set to On

sudo nano /etc/php5/apache2/php.ini

find the short_open_tag = Off and change it to On

Ctrl +o to save the file Ctrl +x to exit

/etc/init.d/apache2 force-reload

and now you should see the ZM page! "

pdharg
Posts: 23
Joined: Fri Feb 14, 2014 1:14 pm

Re: Installing on Kubuntu 13.10

Post by pdharg » Sun Feb 23, 2014 3:43 pm

Alas, not quite sorted, but I am in the console thus:

ZoneMinder Console - Running - v1.25.0
Logged in as admin, configured for Low Bandwidth

However, when I click "Add New Monitor", NOTHING HAPPENS!

Please Help, Hans, or anybody else, I have spent so long reading documentation and forum posts, but I won't give in! :mrgreen: Thank you.

pdharg
Posts: 23
Joined: Fri Feb 14, 2014 1:14 pm

Re: Installing on Kubuntu 13.10

Post by pdharg » Sun Feb 23, 2014 3:54 pm

23/02/2014 12:19:55 dv-460mt zmpkg[20450] INF [Command: status]
23/02/2014 12:19:55 dv-460mt zmpkg[20461] INF [Command: stop]
23/02/2014 12:19:55 dv-460mt zmdc[11606] INF ['zmaudit.pl -c' stopping at 14/02/23 12:19:55]
23/02/2014 12:19:55 dv-460mt zmdc[11606] INF [Can't find child with pid of '11607']
23/02/2014 12:19:55 dv-460mt zmdc[11606] INF ['zmaudit.pl -c' exited, signal 14]
23/02/2014 12:19:55 dv-460mt zmdc[11606] INF ['zmfilter.pl ' stopping at 14/02/23 12:19:55]
23/02/2014 12:19:55 dv-460mt zmdc[11606] INF ['zmfilter.pl ' exited, signal 14]
23/02/2014 12:19:55 dv-460mt zmdc[11606] INF ['zmwatch.pl ' stopping at 14/02/23 12:19:55]
23/02/2014 12:19:55 dv-460mt zmdc[11606] INF ['zmwatch.pl ' exited, signal 14]
23/02/2014 12:20:05 dv-460mt zmdc[11606] INF [Server shutdown at 14/02/23 12:20:05]
23/02/2014 12:20:06 dv-460mt zmpkg[20511] INF [Command: start]
23/02/2014 12:20:06 dv-460mt zmdc[20528] INF [Server starting at 14/02/23 12:20:06]
23/02/2014 12:20:09 dv-460mt zmdc[20528] INF ['zmfilter.pl' starting at 14/02/23 12:20:09, pid = 20552]
23/02/2014 12:20:09 dv-460mt zmdc[20552] INF ['zmfilter.pl' started at 14/02/23 12:20:09]
23/02/2014 12:20:09 dv-460mt zmdc[20528] INF ['zmaudit.pl -c' starting at 14/02/23 12:20:09, pid = 20557]
23/02/2014 12:20:09 dv-460mt zmdc[20557] INF ['zmaudit.pl -c' started at 14/02/23 12:20:09]
23/02/2014 12:20:09 dv-460mt zmfilter[20552] INF [Scanning for events]
23/02/2014 12:20:09 dv-460mt zmdc[20528] INF ['zmwatch.pl' starting at 14/02/23 12:20:09, pid = 20562]
23/02/2014 12:20:09 dv-460mt zmdc[20562] INF ['zmwatch.pl' started at 14/02/23 12:20:09]
23/02/2014 12:20:09 dv-460mt zmwatch[20562] INF [Watchdog starting]
23/02/2014 12:20:09 dv-460mt zmwatch[20562] INF [Watchdog pausing for 30 seconds]
23/02/2014 12:45:40 dv-460mt zmu[20757] INF [Authenticated user 'admin']
23/02/2014 12:45:40 dv-460mt zmu[20757] ERR [Failed to enumerate standard 0: Inappropriate ioctl for device]
23/02/2014 13:17:40 dv-460mt zmpkg[20955] INF [Command: status]
23/02/2014 13:18:07 dv-460mt zmpkg[20970] INF [Command: stop]
23/02/2014 13:18:07 dv-460mt zmdc[20528] INF ['zmfilter.pl ' stopping at 14/02/23 13:18:07]
23/02/2014 13:18:07 dv-460mt zmdc[20528] INF [Can't find child with pid of '20529']
23/02/2014 13:18:07 dv-460mt zmdc[20528] INF ['zmfilter.pl ' exited, signal 14]
23/02/2014 13:18:07 dv-460mt zmdc[20528] INF ['zmaudit.pl -c' stopping at 14/02/23 13:18:07]
23/02/2014 13:18:07 dv-460mt zmdc[20528] INF ['zmaudit.pl -c' exited, signal 14]
23/02/2014 13:18:07 dv-460mt zmdc[20528] INF ['zmwatch.pl ' stopping at 14/02/23 13:18:07]
23/02/2014 13:18:07 dv-460mt zmdc[20528] INF ['zmwatch.pl ' exited, signal 14]
23/02/2014 13:18:17 dv-460mt zmdc[20528] INF [Server shutdown at 14/02/23 13:18:17]
23/02/2014 13:18:17 dv-460mt zmfix[21005] DB1 [LogOpts: level=DB1/DB1, screen=OFF, database=INF, logfile=DB1->/tmp/zm/zm_debug.log.21005, syslog=DB9]
23/02/2014 13:18:17 dv-460mt zmpkg[21007] INF [Command: start]
23/02/2014 13:18:17 dv-460mt zmfix[21019] DB1 [LogOpts: level=DB1/DB1, screen=OFF, database=INF, logfile=DB1->/tmp/zm/zm_debug.log.21019, syslog=DB9]
23/02/2014 13:18:18 dv-460mt zmdc[21024] INF [Server starting at 14/02/23 13:18:18]
23/02/2014 13:18:21 dv-460mt zmdc[21024] INF ['zmfilter.pl' starting at 14/02/23 13:18:21, pid = 21048]
23/02/2014 13:18:21 dv-460mt zmdc[21048] INF ['zmfilter.pl' started at 14/02/23 13:18:21]
23/02/2014 13:18:21 dv-460mt zmdc[21024] INF ['zmaudit.pl -c' starting at 14/02/23 13:18:21, pid = 21053]
23/02/2014 13:18:21 dv-460mt zmdc[21053] INF ['zmaudit.pl -c' started at 14/02/23 13:18:21]
23/02/2014 13:18:21 dv-460mt zmfilter[21048] INF [Scanning for events]
23/02/2014 13:18:21 dv-460mt zmdc[21024] INF ['zmwatch.pl' starting at 14/02/23 13:18:21, pid = 21058]
23/02/2014 13:18:21 dv-460mt zmdc[21058] INF ['zmwatch.pl' started at 14/02/23 13:18:21]
23/02/2014 13:18:21 dv-460mt zmwatch[21058] INF [Watchdog starting]
23/02/2014 13:18:21 dv-460mt zmwatch[21058] INF [Watchdog pausing for 30 seconds]

pdharg
Posts: 23
Joined: Fri Feb 14, 2014 1:14 pm

Re: Installing on Kubuntu 13.10

Post by pdharg » Mon Feb 24, 2014 10:05 pm

140224 18:41:38 [Warning] Using unique option prefix myisam-recover instead of myisam-recover-options is deprecated and will be removed in a future release. Please use the full name instead.
140224 18:41:38 [Note] Plugin 'FEDERATED' is disabled.
140224 18:41:38 InnoDB: The InnoDB memory heap is disabled
140224 18:41:38 InnoDB: Mutexes and rw_locks use GCC atomic builtins
140224 18:41:38 InnoDB: Compressed tables use zlib 1.2.8
140224 18:41:38 InnoDB: Using Linux native AIO
140224 18:41:38 InnoDB: Initializing buffer pool, size = 128.0M
140224 18:41:38 InnoDB: Completed initialization of buffer pool
140224 18:41:38 InnoDB: highest supported file format is Barracuda.
140224 18:41:38 InnoDB: Waiting for the background threads to start
140224 18:41:39 InnoDB: 5.5.35 started; log sequence number 1595705
140224 18:41:39 [Note] Server hostname (bind-address): '127.0.0.1'; port: 3306
140224 18:41:39 [Note] - '127.0.0.1' resolves to '127.0.0.1';
140224 18:41:39 [Note] Server socket created on IP: '127.0.0.1'.
140224 18:41:40 [Note] Event Scheduler: Loaded 0 events
140224 18:41:40 [Note] /usr/sbin/mysqld: ready for connections.
Version: '5.5.35-0ubuntu0.13.10.2' socket: '/var/run/mysqld/mysqld.sock' port: 3306 (Ubuntu)
140224 18:41:41 [ERROR] /usr/sbin/mysqld: Table './zm/Config' is marked as crashed and should be repaired
140224 18:41:41 [Warning] Checking table: './zm/Config'
140224 18:41:41 [ERROR] /usr/sbin/mysqld: Table './zm/Logs' is marked as crashed and should be repaired
140224 18:41:41 [Warning] Checking table: './zm/Logs'


*** PLEASE HELP, THANK YOU ***

pdharg
Posts: 23
Joined: Fri Feb 14, 2014 1:14 pm

Re: Installing on Kubuntu 13.10

Post by pdharg » Tue Feb 25, 2014 4:38 pm

Please could someone help me?

When I click "Add New Monitor", NOTHING HAPPENS!

Have found this in mysql log but I do not know how to repair tables or how to do anything in mysql:

Code: Select all

140224 18:41:41 [ERROR] /usr/sbin/mysqld: Table './zm/Config' is marked as crashed and should be repaired
140224 18:41:41 [Warning] Checking table: './zm/Config'
140224 18:41:41 [ERROR] /usr/sbin/mysqld: Table './zm/Logs' is marked as crashed and should be repaired
140224 18:41:41 [Warning] Checking table: './zm/Logs'
Can I delete the database then reinstall it, maybe? If so how would I do this? Where is the ZM database?

Any help or suggestions would be very much appreciated. Thank you.

PacoLM
Posts: 970
Joined: Wed Dec 02, 2009 9:55 pm
Location: Spain

Re: Installing on Kubuntu 13.10

Post by PacoLM » Wed Feb 26, 2014 7:19 am

I will do:

Code: Select all

apt-get purge zoneminder
apt-get install zoneminder
Seems a bad installation.

PacoLM

mini-ITX system (4 IPCams - Ubuntu20.04 - ZM1.34.15)
TelegramBot

pdharg
Posts: 23
Joined: Fri Feb 14, 2014 1:14 pm

Re: Installing on Kubuntu 13.10

Post by pdharg » Wed Feb 26, 2014 11:56 am

Thanks for the tip PacoLM. I`ve done the following:

Code: Select all

apt-get purge zoneminder
apt-get install zoneminder
But still when I click "Add New Monitor", NOTHING HAPPENS!

Any ideas what I should try next, anybody? Thank you.

PacoLM
Posts: 970
Joined: Wed Dec 02, 2009 9:55 pm
Location: Spain

Re: Installing on Kubuntu 13.10

Post by PacoLM » Thu Feb 27, 2014 7:11 am

Your cambozola installation is not working, search how to install it and this will fix your problem (hopefully).

mini-ITX system (4 IPCams - Ubuntu20.04 - ZM1.34.15)
TelegramBot

pdharg
Posts: 23
Joined: Fri Feb 14, 2014 1:14 pm

Re: Installing on Kubuntu 13.10

Post by pdharg » Fri Feb 28, 2014 5:40 pm

Thanks PacoLM, here is what I have just done:

Code: Select all

sudo cd /usr/src && wget http://www.andywilcock.com/code/cambozola/cambozola-latest.tar.gz

Code: Select all

sudo tar -xzvf cambozola-latest.tar.gz

Code: Select all

sudo cp cambozola-0.935/dist/cambozola.jar /usr/share/zoneminder

Code: Select all

sudo service zoneminder restart

Code: Select all

sudo apache2ctl restart
But still, when I click "Add New Monitor", NOTHING HAPPENS!

More help please. Thanks.

Peter.

pdharg
Posts: 23
Joined: Fri Feb 14, 2014 1:14 pm

Re: Installing on Kubuntu 13.10

Post by pdharg » Mon Mar 03, 2014 5:48 pm

I am using Firefox 27.0.1

When I click "Add New Monitor", NOTHING HAPPENS!

But, in the javascript console I get:
TypeError: window.addEvent is not a function
Anyone know Why? Please help, thanks.

Peter.

davetib
Posts: 2
Joined: Fri Mar 07, 2014 7:52 pm

Re: Installing on Kubuntu 13.10

Post by davetib » Fri Mar 07, 2014 7:59 pm

I never could get my cameras working with Kubuntu 13.10. they would just show up as a blank screen. So I went ahead and just migrated to 14.10 Beta. I noticed a couple things right away. First, my system felt a little "zippier". Mabye that's just wishful thinking, but it sure aint slower.

Second, and most important - ZoneMinder is working better than ever! No camera dropouts on my IP cameras, which I did get frequently on Kubuntu 13.04 and ZoneMinde 1.25.

So ZoneMinder 1.26.5 on Kubuntu 14.10 64 bit.... This solution worked well for me, but if you have a system that you really can't slide into beta, then this may not be something you're willing to try. Kubuntu 14.10 should be stable in late April I think.

pdharg
Posts: 23
Joined: Fri Feb 14, 2014 1:14 pm

Re: Installing on Kubuntu 13.10

Post by pdharg » Sun Mar 09, 2014 11:12 am

Thank you davetib, please confirm, are you sure about 14.10, can I assume you mean 14.04?

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest