VMware Server MUI appears to conflict with ZoneMinder

Support and queries relating to all previous versions of ZoneMinder
Post Reply
JamesX
Posts: 6
Joined: Sat Sep 16, 2006 6:09 pm

VMware Server MUI appears to conflict with ZoneMinder

Post by JamesX » Fri Sep 29, 2006 12:00 pm

Hi :D

I've installed VMware Server 1.01 onto my 32bit AMD Athlon XP system that's running a newly installed Ubuntu 6.06 LTS desktop installation.

The OS was freshly installed and I installed VMware server immediately after installing ZoneMinder 1.22.2 which was the first application installed after booting it up for the first time.

ZoneMinder 1.22.2 ran fine for many days as I wanted to ensure it worked flawlessy before installing anything else, however after installing the VMware Server 1.01 MUI it causes my ZoneMinder 1.22.2 webpage to report that ZoneMinder has stopped and I'm unable to start the service again - this seems to happen after a whole night of them running fine.

I have to reboot the machine to get ZoneMinder up again, however after rebooting the VMWare Server MUI stops responding.

My ZoneMinder appears to continue working perfectly fine from this point on, and if I perform a re-install of the VMware Server MUI it too works fine side by side with ZoneMinder for many hours, if not the whole night, but the next day ZoneMinder stops and is non-startable until a reboot occurs...which then causes the MUI to dissappear.

I know there's an issue with the MUI and Ubuntu that has something to do with a specific directory being virtual and so after a reboot part of the MUI ceases to be present or something - and I'm confident I can resolve this issue later however before I look into that I'm at a loss as to why the MUI appears to conflict with ZoneMinder after a period of operating together.

I'm sure it must be something to do with the webserver as the VMWare Server appears to be fully functional as I can login to it using the Console Application, I think the MUI is somehow interfering with ZoneMinder via Apache or something Apache uses - however I think the MUI installs another instance of Apache and so it should not affect ZoneMinder which runs on the other instance of Apache.

Sorry if this doesn't make sense as I'm a Linux Newbie defecting from Microsoft and have literaly just started using Ubuntu.

If anyone can help with this it would be a real life saver as I think with my present experience with Linux it may take me a decade or two to resolve :P

Cheers, JamesX...

davekelly1979
Posts: 3
Joined: Sun Oct 01, 2006 9:57 pm

Zoneminder + Ubuntu 6.06 + time = webserver hang....

Post by davekelly1979 » Sun Oct 01, 2006 10:20 pm

I think there may be a problem with using the perl modules, ubuntu 6.06, ZM and apache together. VMWare might not come into play here. My Ubuntu server 6.06 server seems to run ZM just fine. But after a period of time (maybe a day or two), when I try to check the webserver, my browser just hangs (and never dies or resolves a page). I SSH into the Ubuntu server box and try to restart apache (/etc/init.d/apache2 restart), but it fails. Here's what I get in the terminal:

* Forcing reload of apache 2.0 web server... apache2: Could not determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
apache2: Could not determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
(98)Address already in use: make_sock: could not bind to address [::]:80
no listening sockets available, shutting down
Unable to open logs
[fail]


While I'd like to resolve the weird 127.0.1.1 error, I don't think that is a big issue here. After some Googling, I found that I can determine what is using port 80 by issuing the following comand: sudo netstat -tulpn| grep :80
and I get:

tcp6 0 0 :::80 :::* LISTEN 9103/perl

The process ID changes every time, obviously. I cannot get Apache to restart until I kill the perl process. sudo kill (process ID #)

After that, I can restart apache, and access the webpage. However, at that point I notice ZM is in the stop state! :(

I can click the link and start ZM. But, I don't know if it was stopped because I killed perl, or if it was stopped when apache stopped running. I think that ZM is still running (from the initial 'check" of the webpage, before farting around with apache) even though I cannot access the webpage because I still get some events. However, it doesn't give me warm fuzzys that I have to go check that everything is running smoothly.

I am stumped as to why it hangs and I have to jump through hoops (or reboot the box) to keep everyting running properly. Any assistance would be appreciated. Hopefully this helps to rule out VMWare as a possible problem in your case as well.

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests