User Authentication Problem with Plain,none relay_mode

Support and queries relating to all previous versions of ZoneMinder
Post Reply
User avatar
tgutwin
Posts: 24
Joined: Thu Jan 12, 2006 4:02 am
Location: North Vancouver, Canada
Contact:

User Authentication Problem with Plain,none relay_mode

Post by tgutwin » Fri Jan 13, 2006 5:46 am

I am finding that in the monitor watch page the monitor area shows a broken image icon with camera view in both stream and stills.

I tracked it to the user authentication settings.
It breaks when
ZM_OPT_USE_AUTH is on
AND
ZM_AUTH_RELAY = plain or none
It works fine with no auth or with hashed auth

I enumerated a bunch of the options and list breakage.

Code: Select all

ZM_OPT_USE_AUTH    ZM_AUTH_TYPE    ZM_AUTH_RELAY  ZM_AUTH_HASH_SECRET     Broken
      NO              builtin        plain              empty               NO
      YES             builtin        plain              empty              [b]YES[/b]
      YES             builtin        hashed             empty              NO
      YES             builtin        hashed             "fred"             NO
      YES             builtin        none               empty             [b]YES[/b]
The user I was logged in with had full edit access including system edit.
I tried to change the monitorIds setting but a MySQL error wouldn't let me try
to see if that was the issue. (see the previous post for the MySQL Error)

tom

User avatar
zoneminder
Site Admin
Posts: 5220
Joined: Wed Jul 09, 2003 2:07 pm
Location: Bristol, UK
Contact:

Post by zoneminder » Fri Jan 13, 2006 12:54 pm

I have found (and fixed) a problem with the 'none' relay authentication method however plain works ok for me. You do usually have to log out and back in again when you change methods though.
Phil

nachbar
Posts: 5
Joined: Tue May 15, 2007 4:03 am

Post by nachbar » Sun May 20, 2007 7:57 pm

I am having exactly the opposite problem: I get the broken image link ONLY if I select hashed! This occurs whether or not I enter a secret or leave the secret blank. No problem if I use no authentication, no problem if I use authentication but set relay as plain or none.

jamescollings
Posts: 59
Joined: Wed Nov 22, 2006 11:26 am
Location: Bucks, UK

Post by jamescollings » Mon Jun 04, 2007 7:55 am

Exactly the same here:

I am running 1.22.3 on Ubuntu Feisty. The problem is the same no matter whether I am using firefox or IE, and is the same both local to the box and over the network.

i suspect something is broken with the authentication??
No Auth and PLAN Auth are both fine.

I don't know if this will help diagnose the problem... but the FPS shows as 0.00 when the image is broken (still and/or stream), whereas it shows (correctly) as 8fps when things are working.

User avatar
Lee Sharp
Posts: 1069
Joined: Sat Mar 31, 2007 9:18 pm
Location: Houston, TX

Post by Lee Sharp » Tue Jun 05, 2007 2:53 pm

[aol]Me too![/aol]

With no authentication, everything works. Turn on authentication and admin sees no pics at all. Not with monitor, montage or recorded events. This is with the settings builtin, hashed, no secret, and IP address included in the hash. When I removed the IP address, and changed hash to plain, it worked. I am on Ubuntu using Peter's latest .deb for install.

Did I mention that this is odd?

wilso027
Posts: 90
Joined: Wed Feb 21, 2007 10:38 pm

Post by wilso027 » Fri Jun 29, 2007 2:40 am

I just got the same thing with fiesty also. Changed to plain and it works fine. Hopefully I'll get some time tommorow or this weekend and see if there is anything new with fiesty that is causing this.

Allan

User avatar
Lee Sharp
Posts: 1069
Joined: Sat Mar 31, 2007 9:18 pm
Location: Houston, TX

Post by Lee Sharp » Fri Jun 29, 2007 5:33 am

For me it was a problem on both edgy and feisty. Same behavior.

Hugolp
Posts: 17
Joined: Sun Apr 08, 2007 10:03 pm

Post by Hugolp » Tue Jul 03, 2007 8:55 am

I am using the deb from the wiki and I am having the same issue.

Hugo

corey205
Posts: 4
Joined: Tue Apr 10, 2007 11:33 am

Post by corey205 » Mon Sep 17, 2007 12:15 pm

I have the same problem. I'm using fiesty.

However with my set up it only works when ZM_AUTH_RELAY = "None".

Hashed and plain are broken regardless of any other setting.

Did anyone ever find anything to address this.

What's the impact of leaving the ZM_AUTH_RELAY setting at "None"?

m1ke
Posts: 53
Joined: Thu Nov 08, 2007 1:37 pm
Location: Surrey

Post by m1ke » Thu Nov 08, 2007 7:56 pm

I have the same problem as well.
Can only view the cameras by turning off authentication or by setting ZM_AUTH_RELAY to 'none'

Does everyone have this issue or is it only under certain circumstances ?

I'm using 1.22.3 on Ubuntu 6.06 (dapper). I installed the 1.22.3 .deb by Peter Howard.

Also as below are there any issues with leaving ZM_AUTH_RELAY at 'None'?

Thanks in advance,

Mike.

m1ke
Posts: 53
Joined: Thu Nov 08, 2007 1:37 pm
Location: Surrey

Post by m1ke » Thu Nov 08, 2007 8:44 pm

OK, after a lot of searching found quite a lot of stuff on this. Namely:

http://www.zoneminder.com/forums/viewto ... 7f2c9c3f15

which states that it all comes down to this: http://www.mail-archive.com/ubuntu-bugs ... 18717.html

Therefore I gather the only real solution is to build & reinstall ZM from source.

I think I've answered my own question here, but if anyone has any further info that would be great too!

Mike.

PeterHoward
Posts: 319
Joined: Thu Jul 20, 2006 1:07 am
Location: Australia
Contact:

Post by PeterHoward » Fri Nov 09, 2007 3:59 am

m1ke wrote:OK, after a lot of searching found quite a lot of stuff on this. Namely:

http://www.zoneminder.com/forums/viewto ... 7f2c9c3f15

which states that it all comes down to this: http://www.mail-archive.com/ubuntu-bugs ... 18717.html
Gee, it would be nice if that bug had found its way back to me . . . :? As most people know I've been out of action on the packaging front due to hardware issues for the past couple of months. The good news . . . on Wednesday I finally ordered the parts to get my server going again. If that's what the problem is, I should be able to get that resolved fairly quickly (finally).

Post Reply

Who is online

Users browsing this forum: No registered users and 27 guests