Page 1 of 2

broken images

Posted: Mon Oct 31, 2005 2:10 pm
by boombari
hi to all,

in my attachment there is a grab of a cam with zm 1.21.3 ...

..what is the problem ? :(


Posted: Mon Oct 31, 2005 4:26 pm
by jameswilson
appears your card is misconfigured/not recognised properly. You will need to get your card working properly first. For the experts on here you need to give various outputs from different commands but i dont understand them. I need pictures of the card lol. Do you have one

Posted: Mon Oct 31, 2005 5:25 pm
by boombari
i have BT878A with 1 chip and 4 input ...i don't have a picture of the board ! :(

Posted: Mon Oct 31, 2005 5:26 pm
by jameswilson
i have 3 different cards with this chip. What you need is the bttv card number 77 is a popular one maybe you could try it

edit modprobe.conf
add line
options bttv card=77

save and reboot

Posted: Mon Oct 31, 2005 5:37 pm
by boombari
i'm on debian sarge ..and i don't have modprobe.conf ! :( is it normal ?

Posted: Mon Oct 31, 2005 5:40 pm
by jameswilson
i think you should have but im no expert

Posted: Tue Nov 01, 2005 10:16 am
by boombari
nobody can help me ? :(

Posted: Tue Nov 01, 2005 11:09 am
by jameswilson
where have you looked for your modprobe file. Its the file that tells linux how to configure its hardware. I assume if you definetly havnt got one if you created a file and added the correct line that would do but im 99% sure you should have one as its a linux thing not a distro thing. I have used centos, mandrake, pclos and fedora and they all have a modprobe file

Posted: Tue Nov 01, 2005 12:30 pm
by conor

You need to read the sticky post at the top of this section of the forum and apply that to give more detail to help the rest of us to debug your problem.

We presume that you are working with a version 2.6 kernel where the bttv driver is built as a module. However if you did not issue a modprobe command and you have some form of a picture then it could be built in!

In that case change the bttv driver to be a module (see under Video4linux in drivers section of make menuconfig) and try as James suggested modprobe bttv card=77 before starting zoneminder to test it.

Give the bit at the end of the dmesg output that the modprobe should produce. This will allow us to assess if it has worked and maybe your card is of a type that might be automatically recognised.

In gentoo which I use, modules can be automatically started by referencing in the kernel-2.6 file in /etc/modules.autoload.d where options can be given. However always test a module by using modprobe first before having the confidence to load it get it loaded automatically at startup in that file.

The other thing when you get a display like yours is that the type of signal is not correctly defined within zm. Are you in a PAL or NTSC region.

Conor Downey

Posted: Wed Nov 02, 2005 11:05 am
by boombari
no, i'm using 2.4 kernel version :(

and i don't have /etc/modules.autoload.d file :(

i try to type modprobe bttv card=77 before start zm ...but the problem is the same ...i'm in a PAL region ...and i set:

Device Number (/dev/video?) 0
Device Channel 0
Device Format (0=PAL,1=NTSC etc) 0

can i try to change PCI slot ?

Posted: Wed Nov 02, 2005 3:16 pm
by boombari
i'm solved the problem .. :)

i simply upgrade my kernel from 2.4 to 2.6 :D ...and the images now is perfect ! :D

now, i have only one problem with cambozola, ...i have copied cambozola.jar in zm directory, but at screen i view only che cambozola copyright, no images ...

Posted: Wed Nov 02, 2005 3:57 pm
by jameswilson
do stills work?

Posted: Fri Nov 04, 2005 10:14 am
by boombari
ok, now cambozola works fine ...the problem was on the client !

but sometimes i can't view nothing because the line of the camere where i click, is red ... where is the log to see the errors ?

if i set tu Black and White palette works, but no in RGB Palette ! :(

Posted: Fri Nov 04, 2005 10:16 am
by jameswilson
in the messages log mate

Posted: Fri Nov 04, 2005 10:58 am
by boombari
no errors in /var/log/messages :(