Transliteration problem?? When starting ZM service

Support and queries relating to all previous versions of ZoneMinder
Post Reply
lpallard
Posts: 85
Joined: Fri Mar 05, 2010 10:59 pm

Transliteration problem?? When starting ZM service

Post by lpallard » Sat Mar 20, 2010 7:44 pm

Hi! since my last post I managed to bring the issue to a different level... Now, my camera works perfectly with my machine, xawtv works pefectly, mysql is installed, running ans properly configured 9at least I think) but I cant start the ZM service.

Upon entering "/etc/rc.d/rc.zm start" I get:

Starting ZoneMinder: Use of uninitialized value in transliteration (tr///) at /usr/lib/perl5/site_perl/5.10.0/ZoneMinder/Config.pm line 82, <CONFIG> line 51.
Can't use an undefined value as a symbol reference at /usr/lib/perl5/site_perl/5.10.0/ZoneMinder/Config.pm line 83, <CONFIG> line 51.
BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.10.0/ZoneMinder/Config.pm line 100, <CONFIG> line 51.
Compilation failed in require at /usr/lib/perl5/site_perl/5.10.0/ZoneMinder.pm line 33, <CONFIG> line 51.
BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.10.0/ZoneMinder.pm line 33, <CONFIG> line 51.
Compilation failed in require at /usr/bin/zmpkg.pl line 46, <CONFIG> line 51.
BEGIN failed--compilation aborted at /usr/bin/zmpkg.pl line 46, <CONFIG> line 51.
[FAILED]

Weird! Any clues whats going on???? Here's my zm.conf (in /etc/):

# Current version of ZoneMinder
ZM_VERSION=1.24.2

# Path to build directory, used mostly for finding DB upgrade scripts
#ZM_PATH_BUILD=/root/ZoneMinder-1.24.2
ZM_PATH_BUILD=

# Build time, used to record when to trigger various checks
ZM_TIME_BUILD=1269124263

# Path to ZoneMinder binaries
ZM_PATH_BIN=/usr/bin

# Path to ZoneMinder libraries (none at present, for future use)
ZM_PATH_LIB=/usr/lib

# Path to ZoneMinder configuration (this file only at present)
ZM_PATH_CONF=/etc

# Path to ZoneMinder web files
ZM_PATH_WEB=/var/www/htdocs

# Path to ZoneMinder cgi files
ZM_PATH_CGI=/srv/httpd/cgi-bin

# Username and group that web daemon (httpd/apache) runs as
ZM_WEB_USER=apache
ZM_WEB_GROUP=apache

# ZoneMinder database hostname or ip address
ZM_DB_HOST=localhost

# ZoneMinder database name
ZM_DB_NAME=zm

# ZoneMinder database user
ZM_DB_USER=zmuser

# ZoneMinder database password
ZM_DB_PASS=zmlocal123

thanks for the help! I'll post back the results.

lpallard
Posts: 85
Joined: Fri Mar 05, 2010 10:59 pm

Post by lpallard » Sun Mar 21, 2010 12:39 am

Well I guess I self troubleshooted my problem... I simply reinstalled ffmpeg as well as zoneminder with the slackware 13 scripts ... I realized that at first, I installed the versions for slack 12.2... no wonder why it didnt worked.

Now I can start zoneminder without a single glitch, but still I cant access the web interface.. seems that apache and the ZM service cant talk together. Any clue?

I tried to verify the configuration, but cant find anything wrong. Dont take that for granted, im still learning...

Could it be a faulty address in some config files? In the apache logs, I can see:

[Sun Mar 21 00:35:09 2010] [error] [client 192.168.0.100] File does not exist: /srv/httpd/htdocs/zm
[Sun Mar 21 00:35:09 2010] [error] [client 192.168.0.100] File does not exist: /srv/httpd/htdocs/favicon.ico
[Sun Mar 21 00:35:14 2010] [error] [client 192.168.0.100] script '/srv/httpd/htdocs/zm.php' not found or unable to stat

majordidge
Posts: 1
Joined: Thu Apr 08, 2010 11:58 am

Post by majordidge » Fri Apr 09, 2010 11:07 am

Hi Lpallard,

I am experiencing the same problem and am wondering if you have got it sorted?

Cheers,

MD.

lpallard
Posts: 85
Joined: Fri Mar 05, 2010 10:59 pm

Post by lpallard » Fri Apr 09, 2010 12:30 pm

majordidge,

At least I'm not the only one in the world to have that problem! I hope your problem is that you cant acces the web interface?

Basically, I created a different thread on Linuxquestions regarding this issue... From the guys over there, the problem seems to come from the fact that Apache is not processing the .php file correctly. In fact, the .php file is in the good folder (as given in my zm.conf file) but apache cant process it as a php script. I tried to fool around the server's config, changing the address of the alias I created, and basically, there is 3 different scenarios:

pointing to the folder where index.php resides: my web browser displays the content of the folder just like a FTP ... not useful for me...

pointing to the .php file itself: my browser ask me if I want to download the file (index.php)... not much better (liek if the was of unknown type)

pointing to the folder where the .php file resides BUT conmpleting the address in my brower's address bar by ..."/index.php" => my browser opens the .php file like a text file, I can see the lines of code in it... not better than before...

So to wrap up, I believe the Apache server is not parsing (or whatever it's called) the .php scripts the way it should be so the web browsers are not displaying properly.

I will retry again, I did not had a chance to play around for almost 2 weeks now, but tonight or tomorrow I'll try more stuff and post back my findings!

User avatar
kingofkya
Posts: 1112
Joined: Mon Mar 26, 2007 6:07 am
Location: Las Vegas, Nevada

Post by kingofkya » Sat Apr 10, 2010 2:06 am

If this is a debian or ubuntu system all you need to do is move the php.conf form mods-available to mods-enabled.

its under /etc/apache

otherwise add to http.conf or apache.conf

AddType application/x-httpd-php .php .phtml .php3
AddType application/x-httpd-php-source .phps

Post Reply

Who is online

Users browsing this forum: No registered users and 17 guests