audio not saving with record

Forum for questions and support relating to the 1.34.x releases only.
Post Reply
Posts: 1
Joined: Sun Aug 16, 2020 8:53 pm

audio not saving with record

Post by jnd421 » Sun Aug 16, 2020 9:52 pm


I'm trying to get ZM to work with a Bosch DINION IP camera. I'm using rtsp [rtsp://user:passwd@]. This link works for both video and audio with VLC. With ZM the video works fine, but when I turn on audio I get the following errors repeated around 10 times a second.

2020-08-16 14:26:34 zmc_m8 26902 WAR Malformed AAC bitstream detected: use the audio bitstream filter 'aac_adtstoasc' to fix it ('-bsf:a aac_adtstoasc' option with ffmpeg) zm_ffmpeg.cpp 70
2020-08-16 14:26:34 zmc_m8 26902 ERR Error writing packet: Operation not permitted zm_videostore.cpp 1039

I tried adding -bsf:a aac_adtstoasc under Source:Options or Storage:Optional Encoder Parameters, but it didn't seem to change anything, but at this point I admit I'm somewhat flailing in the dark.

Is there a way to add this option to ffmpeg? Or is there a better way to go about this?

I'm running ZM 1.34.16 on Debian 10.5. ZM was installed thru apt-get following the instructions in the ZM docs.


User avatar
Posts: 1345
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto

Re: audio not saving with record

Post by iconnor » Mon Aug 17, 2020 12:13 am


Havn't seen that one before.

We may not be passing the Encoder Params to the audio codec... I will double check that.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests