ZM 1.34 on Debian 10

Forum for questions and support relating to the 1.34.x releases only.
Post Reply
jimkoh
Posts: 50
Joined: Mon Nov 20, 2017 1:13 am

ZM 1.34 on Debian 10

Post by jimkoh » Mon Aug 10, 2020 5:16 pm

I upgraded my server to Debian 10 and wiped ZM. When I try to install following the wiki, I get a bunch of errors about unmet dependencies. A lot of them say they have no installation candidate?

Jim

jimkoh
Posts: 50
Joined: Mon Nov 20, 2017 1:13 am

Re: ZM 1.34 on Debian 10

Post by jimkoh » Wed Aug 12, 2020 3:55 pm

This is what I get when I try to install ZM..

Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
libapt-pkg-perl : Depends: perl-base (>= 5.30.0-9) but 5.28.1-6+deb10u1 is to be installed
Depends: perlapi-5.30.0 but it is not installable
libauthen-pam-perl : Depends: perlapi-5.30.0 but it is not installable
libcpanel-json-xs-perl : Depends: perlapi-5.30.0 but it is not installable
libdbd-mysql-perl : Depends: perlapi-5.30.0 but it is not installable
libdbi-perl : Depends: perlapi-5.30.0 but it is not installable
libdevice-serialport-perl : Depends: perlapi-5.30.0 but it is not installable
libfcgi-perl : Depends: perlapi-5.30.0 but it is not installable
libfile-fcntllock-perl : Depends: perlapi-5.30.0 but it is not installable
libhtml-parser-perl : Depends: perlapi-5.30.0 but it is not installable
libio-pty-perl : Depends: perlapi-5.30.0 but it is not installable
liblocale-gettext-perl : PreDepends: perl-base (>= 5.30.0-8) but 5.28.1-6+deb10u1 is to be installed
PreDepends: perlapi-5.30.0 but it is not installable
libnet-dbus-perl : Depends: perlapi-5.30.0 but it is not installable
libnet-ssleay-perl : Depends: perlapi-5.30.0 but it is not installable
libterm-readkey-perl : Depends: perlapi-5.30.0 but it is not installable
libtext-charwidth-perl : Depends: perl-base (>= 5.30.0-8) but 5.28.1-6+deb10u1 is to be installed
Depends: perlapi-5.30.0 but it is not installable
libtext-iconv-perl : Depends: perl-base (>= 5.30.0-8) but 5.28.1-6+deb10u1 is to be installed
Depends: perlapi-5.30.0 but it is not installable
libxml-parser-perl : Depends: perlapi-5.30.0 but it is not installable
perl : Depends: perl-base (= 5.30.0-10) but 5.28.1-6+deb10u1 is to be installed
perl-modules-5.30 : Depends: perl-base (>= 5.30.0-1) but 5.28.1-6+deb10u1 is to be installed
zoneminder : Depends: libjwt-gnutls0 (>= 1.9.0) but it is not going to be installed
Depends: libmp4v2-2 but it is not going to be installed
Depends: libvlc5 (>= 2.1.0) but it is not going to be installed
Depends: libx264-155 but it is not going to be installed
Depends: libjs-mootools (>= 1.4.5~debian1) but it is not going to be installed
Depends: libdate-manip-perl but it is not going to be installed
Depends: libmime-lite-perl but it is not going to be installed
Depends: libmime-tools-perl but it is not going to be installed
Depends: libphp-serialization-perl but it is not going to be installed
Depends: libnet-sftp-foreign-perl but it is not going to be installed
Depends: libimage-info-perl but it is not going to be installed
Depends: libjson-maybexs-perl but it is not going to be installed
Depends: libsys-mmap-perl but it is not going to be installed
Depends: liburi-encode-perl but it is not going to be installed
Depends: libdatetime-perl but it is not going to be installed
Depends: libsoap-wsdl-perl but it is not going to be installed
Depends: libio-socket-multicast-perl but it is not going to be installed
Depends: libsys-cpu-perl but it is not going to be installed
Depends: libsys-meminfo-perl but it is not going to be installed
Depends: libdata-uuid-perl
Depends: libnumber-bytes-human-perl but it is not going to be installed
Depends: libfile-slurp-perl but it is not going to be installed
Depends: libcrypt-eksblowfish-perl but it is not going to be installed
Depends: libdata-entropy-perl but it is not going to be installed
Recommends: apache2 (>= 2.4.6-4~) but it is not going to be installed or
nginx or
httpd
Recommends: libapache2-mod-php5 but it is not installable or
libapache2-mod-php or
php5-fpm but it is not installable or
php-fpm
Recommends: zoneminder-doc (>= 1.34.16-buster1) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

User avatar
Bluemax
Posts: 105
Joined: Wed Jun 12, 2019 5:15 pm

Re: ZM 1.34 on Debian 10

Post by Bluemax » Wed Aug 12, 2020 4:49 pm

You did try that apt fix?

jimkoh
Posts: 50
Joined: Mon Nov 20, 2017 1:13 am

Re: ZM 1.34 on Debian 10

Post by jimkoh » Wed Aug 12, 2020 5:55 pm

Yes, and this is what it wants to uninstall:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
apache2-data apache2-utils cpp-8 emacsen-common fakeroot galera-3 gcc-8 git-man gsfonts hp-ppd ienglish-common ispell
libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap libconfig-inifiles-perl libexif12 libfakeroot libgcc-8-dev
libgdbm-compat4 libgphoto2-6 libgphoto2-l10n libgphoto2-port12 libieee1284-3 libimagequant0 libmpx2 librust-autocfg-dev
librust-bitflags-dev librust-cc+jobserver-dev librust-cc-dev librust-cfg-if-dev librust-getrandom-dev librust-idna-dev
librust-jobserver-dev librust-libc-dev librust-log-dev librust-matches-dev librust-openssl-probe-dev
librust-percent-encoding-dev librust-unicode-bidi-dev librust-url-dev librust-vcpkg-dev libsane-common libsnmp-base
libwebpdemux2 mariadb-client-core-10.3 mariadb-server-core-10.3 patch perl-openssl-defaults python3-olefile python3-pexpect
python3-pil python3-ptyprocess python3-renderpm python3-reportlab python3-reportlab-accel rsync socat
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
dictionaries-common dpkg-dev foomatic-db-engine ghc-doc git hplip ibritish keyboard-configuration libalgorithm-diff-perl
libalgorithm-merge-perl libapt-pkg-perl libarchive-zip-perl libauthen-pam-perl libauthen-sasl-perl libcgi-fast-perl
libcgi-pm-perl libclass-std-fast-perl libclass-std-perl libcpanel-json-xs-perl libdata-dump-perl libdbd-mysql-perl
libdbi-perl libdevice-serialport-perl libdigest-hmac-perl libdpkg-perl libencode-locale-perl liberror-perl libfcgi-perl
libfile-basedir-perl libfile-desktopentry-perl libfile-fcntllock-perl libfile-listing-perl libfile-mimeinfo-perl
libfont-afm-perl libhpmud0 libhtml-form-perl libhtml-format-perl libhtml-parser-perl libhtml-tagset-perl
libhtml-template-perl libhtml-tree-perl libhttp-cookies-perl libhttp-daemon-perl libhttp-date-perl libhttp-message-perl
libhttp-negotiate-perl libio-html-perl libio-pty-perl libio-socket-ssl-perl libio-stringy-perl libipc-system-simple-perl
libjson-any-perl liblocale-gettext-perl liblwp-mediatypes-perl liblwp-protocol-https-perl libmailtools-perl libnet-dbus-perl
libnet-http-perl libnet-smtp-ssl-perl libnet-ssleay-perl libperl5.30 librust-git2+default-dev librust-git2+https-dev
librust-git2+ssh-dev librust-git2+ssh-key-from-memory-dev librust-git2-dev librust-libgit2-sys+https-dev
librust-libgit2-sys+libssh2-sys-dev librust-libgit2-sys-dev librust-libssh2-sys-dev librust-libz-sys-dev
librust-openssl-sys-dev librust-pkg-config-dev libsane libsane-hpaio libsnmp35 libterm-readkey-perl libtext-charwidth-perl
libtext-iconv-perl libtext-wrapi18n-perl libtie-ixhash-perl libtimedate-perl libtry-tiny-perl liburi-perl libwww-perl
libwww-robotrules-perl libx11-protocol-perl libxml-parser-perl libxml-twig-perl libxml-xpathengine-perl mariadb-client-10.3
mariadb-server mariadb-server-10.3 perl perl-modules-5.30 pkg-config printer-driver-hpcups printer-driver-hpijs sane-utils
task-english task-print-service task-ssh-server tasksel tasksel-data update-inetd zoneminder
0 upgraded, 0 newly installed, 106 to remove and 0 not upgraded.
2 not fully installed or removed.

I'm not sure what a lot of these are, but I know I don't want to uninstall printer drivers or mariadb and I don't know how to tell it not to.

burger
Posts: 187
Joined: Mon May 11, 2020 4:32 pm

Re: ZM 1.34 on Debian 10

Post by burger » Thu Aug 13, 2020 3:11 am

Uh, you can always reinstall mariadb/mysql afterwards. As long as you have a db backup (https://wiki.zoneminder.com/MySQL)

You should execute the fix broken install prompt, IMO.
fastest way to test streams:
ffmpeg -i rtsp://<ipaddress>:554/path output.mp4
from terminal, and run through paths on ispydb or in zm hcl

If you are new to cctv, read this:
https://wiki.zoneminder.com/Dummies_Guide

jimkoh
Posts: 50
Joined: Mon Nov 20, 2017 1:13 am

Re: ZM 1.34 on Debian 10

Post by jimkoh » Thu Aug 13, 2020 3:13 pm

This is what I get when I do apt --fix-broken install

Do you want to continue? [Y/n] y
(Reading database ... 98183 files and directories currently installed.)
Removing ibritish (3.4.00-8) ...
Can't locate Text/Iconv.pm in @INC (you may need to install the Text::Iconv module) (@INC contains: /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.28.1 /usr/local/share/perl/5.28.1 /usr/lib/x86_64-linux-gnu/perl5/5.28 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.28 /usr/share/perl/5.28 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base) at /usr/share/perl5/Debian/DictionariesCommon.pm line 7.
BEGIN failed--compilation aborted at /usr/share/perl5/Debian/DictionariesCommon.pm line 7.
Compilation failed in require at /usr/sbin/remove-default-ispell line 4.
BEGIN failed--compilation aborted at /usr/sbin/remove-default-ispell line 4.
dpkg: error processing package ibritish (--remove):
installed ibritish package post-removal script subprocess returned error exit status 2
dpkg: too many errors, stopping
Errors were encountered while processing:
ibritish
Processing was halted because there were too many errors.
E: Sub-process /usr/bin/dpkg returned an error code (1)

User avatar
Bluemax
Posts: 105
Joined: Wed Jun 12, 2019 5:15 pm

Re: ZM 1.34 on Debian 10

Post by Bluemax » Sun Aug 16, 2020 9:53 pm

Install the Text::Iconv module and try again. Other than that i have no idea. This is an individual problem with your system.

jimkoh
Posts: 50
Joined: Mon Nov 20, 2017 1:13 am

Re: ZM 1.34 on Debian 10

Post by jimkoh » Mon Aug 17, 2020 4:59 pm

I installed ZM on my main machine which is also running Debian 10 to see if I could get working. It gives me this error:

sudo systemctl status zoneminder
● zoneminder.service - ZoneMinder CCTV recording and surveillance system
Loaded: loaded (/lib/systemd/system/zoneminder.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Mon 2020-08-17 09:53:49 PDT; 32s ago
Docs: http://zoneminder.readthedocs.org/en/latest/
Process: 854 ExecStart=/usr/bin/zmpkg.pl start (code=exited, status=255/EXCEPTION)

Aug 17 09:53:49 debian zmpkg.pl[854]: DBI connect('database=zm;host=localhost','zmuser',...) failed: Access denie
Aug 17 09:53:49 debian zmpkg.pl[854]: Can't connect to db at /usr/share/perl5/ZoneMinder/Config.pm line 166.
Aug 17 09:53:49 debian zmpkg.pl[854]: BEGIN failed--compilation aborted at /usr/share/perl5/ZoneMinder/Config.pm
Aug 17 09:53:49 debian zmpkg.pl[854]: Compilation failed in require at /usr/share/perl5/ZoneMinder.pm line 33.
Aug 17 09:53:49 debian zmpkg.pl[854]: BEGIN failed--compilation aborted at /usr/share/perl5/ZoneMinder.pm line 33
Aug 17 09:53:49 debian zmpkg.pl[854]: Compilation failed in require at /usr/bin/zmpkg.pl line 34.
Aug 17 09:53:49 debian zmpkg.pl[854]: BEGIN failed--compilation aborted at /usr/bin/zmpkg.pl line 34.
Aug 17 09:53:49 debian systemd[1]: zoneminder.service: Control process exited, code=exited, status=255/EXCEPTION
Aug 17 09:53:49 debian systemd[1]: zoneminder.service: Failed with result 'exit-code'.
Aug 17 09:53:49 debian systemd[1]: Failed to start ZoneMinder CCTV recording and surveillance system.

burger
Posts: 187
Joined: Mon May 11, 2020 4:32 pm

Re: ZM 1.34 on Debian 10

Post by burger » Tue Aug 18, 2020 6:58 pm

jimkoh wrote:
Mon Aug 17, 2020 4:59 pm
Aug 17 09:53:49 debian zmpkg.pl[854]: DBI connect('database=zm;host=localhost','zmuser',...) failed: Access denie
Says right in the logs. "DB Connect failed". Is your DB username and password correct? (/etc/zm/zm.conf)
fastest way to test streams:
ffmpeg -i rtsp://<ipaddress>:554/path output.mp4
from terminal, and run through paths on ispydb or in zm hcl

If you are new to cctv, read this:
https://wiki.zoneminder.com/Dummies_Guide

jimkoh
Posts: 50
Joined: Mon Nov 20, 2017 1:13 am

Re: ZM 1.34 on Debian 10

Post by jimkoh » Wed Aug 19, 2020 6:40 pm

I got zm working on my desktop. The problem is it's not version 1.34. How do I upgrade when clicking the version number gives me this: You are running the most recent version of ZoneMinder, v1.32.3. No update is necessary.

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests