zoneminder and zmninja 3rd attempt

Forum for questions and support relating to the 1.34.x releases only.
Post Reply
Dutchie
Posts: 1
Joined: Sat Apr 04, 2020 2:02 am

zoneminder and zmninja 3rd attempt

Post by Dutchie » Sat Apr 04, 2020 2:22 am

Hello all,

Brand new to ZM and love ZM and the potential it has. However I have been playing/battling the zoneminder install for a few days now. I am not sure if this is a zoneminder or a zmninja issue (had both running fine for a few hours but then suddenly went tits up after adding a new monitor)

I have re-installed ZM from scratch according: https://wiki.zoneminder.com/Ubuntu_Serv ... e_easy_way

running ubuntu 18.04 up-to-date

The script installed the latest version of zoneminder and API 2.0, BTW very nice script and appreciate the efforts.

Also running under ssl in apache2 with MYSQL

So ZM accessed under https://

When it when down hill. It was an issue {API FAILED} with the API when login into zmNinja. tried serveral things from the forum, however I wiped ZM from the server and reinstalled ZM on the server. Again no issues here. all working fine.
However for some reason zmNinja keeps having an issue with the API.. I setup the AUTH accordingly to what was written in the installation manual.

API is on for USER. in this case admin.

I would appreciate some guidance on where to look and help solve my problem.

EDIT:
Could the problem lay in the self signed ssl certificate.

when running this on my ZM

curl -XPOST -c cookies.txt -d "user=yourusername&pass=yourpassword&stateful=1" https://yourserver/zm/api/host/login.json

it states:
curl: (60) SSL certificate problem: self signed certificate
More details here: https://curl.haxx.se/docs/sslcerts.html

curl failed to verify the legitimacy of the server and therefore could not
establish a secure connection to it. To learn more about this situation and
how to fix it, please visit the web page mentioned above.

EDIT2:

tried to go with the default ssl-cert-snakoil in default-ssl.conf instead of using my own signed certificate. BTW chrome is difficult with certificates!!
restarted apache2.

EDIT3: I feel so stupid. for some reason I was noticing that the API was not behind the ip but behind ip/zm/api that solved the failed api access....

Consider that API issue solved.

Thnx

Dutchie

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests