No interface access after upgrade 1.30.4 to 1.34.5

Forum for questions and support relating to the 1.34.x releases only.
Post Reply
extremesurf
Posts: 3
Joined: Wed Mar 18, 2020 8:52 pm

No interface access after upgrade 1.30.4 to 1.34.5

Post by extremesurf » Wed Mar 18, 2020 9:08 pm

I have had a Zoneminder system running for years without any issues, and today I decided to upgrade it from 1.30.4 to 1.34.5. It runs on CentOS 7, so I had to remove the zmrepo and add the new RPM Fusion repo to do the yum update. All updates ran successfully, no errors. After I did that I made a backup of the database and ran zmupdate.pl to upgrade the database, and it went through and updated to the latest version without any errors or issues. Manually started Zoneminder, and I can see that it is loaded and running with 'systemctl status zoneminder.service' and it appears to be recording and monitoring.

My problems:

1.) For some reason I cannot load /zm/ in the web browser though, just says "The requested URL /zm/index.php was not found on this server.". If I load just the IP address in my browser I get the Apache HTTP Server test page so I know that httpd is working.

2.) I assume this is related to problem #1, but I also cannot load it on zmNinja on my phone, cameras all just show up blank

Any suggestions to help me get things functioning again? Thanks in advance!

extremesurf
Posts: 3
Joined: Wed Mar 18, 2020 8:52 pm

Re: No interface access after upgrade 1.30.4 to 1.34.5

Post by extremesurf » Thu Mar 19, 2020 7:47 pm

Got the web browser stuff fixed and accessible by adding a couple of lines to the fstab to load the proper link on boot up. Now the interface works perfectly but the video feeds show broken images.
Last edited by extremesurf on Fri Mar 20, 2020 9:13 pm, edited 2 times in total.

extremesurf
Posts: 3
Joined: Wed Mar 18, 2020 8:52 pm

Re: No interface access after upgrade 1.30.4 to 1.34.5

Post by extremesurf » Thu Mar 19, 2020 11:27 pm

Got it fixed. Had to edit /etc/zm/conf.d/zmcustom.conf and add the following lines:

Code: Select all

ZM_PATH_ZMS=/cgi-bin-zm/nph-zms
ZM_PATH_CGI=/usr/libexec/zoneminder/cgi-bin
Last edited by extremesurf on Fri Mar 20, 2020 10:29 pm, edited 4 times in total.

User avatar
Bluemax
Posts: 77
Joined: Wed Jun 12, 2019 5:15 pm

Re: No interface access after upgrade 1.30.4 to 1.34.5

Post by Bluemax » Fri Mar 20, 2020 1:41 am

Your cgi backend might be corrupt as well. Maybe its easier to setup from scratch again.

rockedge
Posts: 1154
Joined: Fri Apr 04, 2014 1:46 pm
Location: Connecticut,USA
Contact:

Re: No interface access after upgrade 1.30.4 to 1.34.5

Post by rockedge » Mon Mar 23, 2020 1:32 am

Using /etc/zm/conf.d/zmcustom.conf is the correct solution in this case. I also use https://zmserver/cgi-bin instead of https://zmserver/zm/cgi-bin and I am using 'webuser' instead of 'www-data' so using the configuration file, which remains static and unaffected by updates and upgrades of ZM, is the easy way if modifying zoneminder to fit in alternative installations

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests