upgrade from 1.32.3 failed

Forum for questions and support relating to the 1.34.x releases only.
Post Reply
sabretoothedhamster
Posts: 23
Joined: Fri Mar 22, 2019 1:21 pm

upgrade from 1.32.3 failed

Post by sabretoothedhamster » Sun Feb 09, 2020 1:45 am

Hello everyone!

I am asking for some help since my upgrade of 1.32.3 to 1.34.2 shut my zoneminder down. The upgrade procedure itself did not report any troubles, yet after the upgrade it does not start:

Code: Select all

zmpkg[2080]: INF [Sanity checking States table...]                                                                                  
zmpkg[2080]: INF [Command: start]                                                                                                   
zmdc[2234]: INF [Server starting at 20/02/09 04:20:55]                                                                              
set-cpufreq[968]: Setting powersave scheduler for all CPUs                                                                          
zmdc[2234]: INF [Socket should be open at /var/run/zm/zmdc.sock]                                                                    
zmpkg[2080]: INF [Single server configuration detected. Starting up services.]                                                      
zmdc[2381]: INF ['zmc -m 1' started at 20/02/09 04:20:57]                                                                           
zmdc[2234]: INF ['zmc -m 1' starting at 20/02/09 04:20:57, pid = 2381]                                                              
zmdc[2234]: INF ['zma -m 1' starting at 20/02/09 04:20:57, pid = 2387]                                                              
zmdc[2387]: INF ['zma -m 1' started at 20/02/09 04:20:57]                                                                           
zmc_m1[2381]: ERR [zmc_m1] [Can't run query: Unknown column 'DecoderHWAccelName' in 'field list']                                   
zmc_m1[2381]: ERR [zmc_m1] [Can't use query result: ]                                                                               
zmc_m1[2381]: ERR [zmc_m1] [No monitors found]                                                                                      
zmdc[2234]: ERR ['zmc -m 1' exited abnormally, exit status 255]                                                                     
zma_m1[2387]: ERR [zma_m1] [Can't run query: Unknown column 'DecoderHWAccelName' in 'field list']                                   
zma_m1[2387]: ERR [zma_m1] [Can't use query result: ]                                                                               
kernel: [   15.732309] show_signal_msg: 11 callbacks suppressed                                                                     
kernel: [   15.732313] zma[2387]: segfault at 24d8 ip 00005617366c15e4 sp 00007ffdc423f660 error 4 in zma[56173660c000+18b000]      
What can I do with that?


P.S. It is (not) running on
DISTRIB_DESCRIPTION="Ubuntu 18.04.4 LTS"
Linux 4.15.0-76-generic #86-Ubuntu SMP Fri Jan 17 17:24:28 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

bbunge
Posts: 2698
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: upgrade from 1.32.3 failed

Post by bbunge » Sun Feb 09, 2020 2:08 am

What database server are you running?
Apache2 or NGINX?
How did you do the upgrade? Did you stop Zoneminder first?
Have you tried restarting the PC?

sabretoothedhamster
Posts: 23
Joined: Fri Mar 22, 2019 1:21 pm

Re: upgrade from 1.32.3 failed

Post by sabretoothedhamster » Sun Feb 09, 2020 12:23 pm

~$ mysql --version
mysql Ver 14.14 Distrib 5.7.29, for Linux (x86_64) using EditLine wrapper

~$ apache2 -v
Server version: Apache/2.4.29 (Ubuntu)
Server built: 2019-09-16T12:58:48

Updated by
$ sudo add-apt-repository ppa:iconnor/zoneminder-1.34
$ sudo apt-get install --only-upgrade zoneminder

zoneminder was stopped during upgrade

Since that I have done both reboot and full 'apt-get upgrade' without noticeable effect...

User avatar
iconnor
Posts: 1325
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: upgrade from 1.32.3 failed

Post by iconnor » Sun Feb 09, 2020 4:34 pm

I suspect you will have further issues, but this one you should be able to solve by doing:
mysql -u zmuser -p zm < /usr/share/zoneminder/db/zm_update-1.33.11.sql

You may have to manually apply the rest as well ymmv.

Maybe try sudo zmupdate.pl

sabretoothedhamster
Posts: 23
Joined: Fri Mar 22, 2019 1:21 pm

Re: upgrade from 1.32.3 failed

Post by sabretoothedhamster » Mon Feb 10, 2020 10:39 am

Thank you, Isaac! Your advice really helped. Althoug zmupdate.pl reported "Database already at version 1.34.2, update skipped." it appeared that all (or most) of the updates from /usr/share/zoneminder/db/zm_update* were not actually applied.

I have ran all respective updates manually and then zm started ok.

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests