Rendering issues after upgrading from 1.30.4 to 1.32.3

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
Posts: 3
Joined: Wed Oct 26, 2016 11:16 pm

Rendering issues after upgrading from 1.30.4 to 1.32.3

Post by klui » Fri Oct 11, 2019 5:46 am

I posted this on the ZoneMinder subreddit, too.

I just upgraded Zoneminder from 1.30.4 to 1.32.3 under Ubuntu 16.04.6. There are a lot of rendering problems and the major change is whenever I click on a video cam name from the console, I don't get a new window. I run this under mRemoteNG and I can't force it to open a new window, only send to system browser.

In the console, clicking "Add" does nothing. If I have a camera selected via the checkbox on the far right, "Edit," "Delete," and "Select" don't register as a click. My window size under mRemoteNG won't allow me to see the checkboxes and even if I resize the text using Ctrl-{scrollwheel}, they don't come into view, and there's no horizontal scrollbar.

I tried to use the dark css but they don't seem to work either.

What can I do to fix? Here are some screenshots of the rendering issues.

I just upgraded using

Code: Select all

add-apt-repository ppa:iconnor/zoneminder-1.32
apt-get update && apt-get dist-upgrade
I also rebooted the system but no change.


Posts: 88
Joined: Sun Jan 27, 2019 5:17 pm

Re: Rendering issues after upgrading from 1.30.4 to 1.32.3

Post by kitkat » Sun Oct 13, 2019 5:18 pm

There are a couple of things to check and possibly configure after an upgrade, including updating the database.

See /usr/share/doc/zoneminder-1.32.3/README

This is for 1.32.2 on CentOS...


1. Conf.d folder support has been added to ZoneMinder. Any custom
changes previously made to zm.conf must now be made in one or more custom
config files, created under the conf.d folder. Do this now. See
/etc/zm/conf.d/README for details. Once you recreate any custom config changes
under the conf.d folder, they will remain in place indefinitely.

2. Verify permissions of the zmuser account.

Over time, the database account permissions required for normal operation
have increased. Verify the zmuser database account has been granted all
permission to the ZoneMinder database:

mysql -uroot -p -e "show grants for zmuser@localhost;"

See step 2 of the Installation section to add missing permissions.

3. Verify the ZoneMinder Apache configuration file in the folder
/etc/zm/www. You will have a file called "zoneminder.conf" and there
may also be a file called "zoneminder.conf.rpmnew". If an rpmnew file
exists, inspect it and merge anything new in that file with zoneminder.conf.
Verify the SSL REquirements meet your needs. Read README.https if necessary.

The contents of this file must be merged into your Apache configuration.
See step 6 of the installation section if you have not already done this
during a previous upgrade.

4. Upgrade the database before starting ZoneMinder.

Most upgrades can be performed by executing the following command:


Recent versions of ZoneMinder don't require any parameters added to the
zmupdate command. However, if ZoneMinder complains, you may need to call
zmupdate in the following manner:

sudo --user=root --pass=<mysql_root_pwd> --version=<from version>

5. Now restart the web server then start zoneminder:

sudo systemctl restart httpd
sudo systemctl start zoneminder

Posts: 3
Joined: Wed Oct 26, 2016 11:16 pm

Re: Rendering issues after upgrading from 1.30.4 to 1.32.3

Post by klui » Mon Oct 14, 2019 12:32 am

Hey thanks for the reply.

I found out the problem several days and forgot about it but encouraged to see your reply.

During the upgrade I did get a merge request but that was for config.php--I think--which I chose to keep my locally modified copy. There weren't a lot of differences. Besides the slow database update process, I wasn't told of anything gone wrong.

During troubleshooting, I changed all file/directory ownership in /usr/share/zoneminder to www-data:www-data but that didn't help.

There was just something preventing important JavaScript from running and I threw in the towel and prepared for a reinstall. Prior to that I needed to get all the configurations from the webUI and database. After I gathered everything I noted the system configurations such as ssmtp, snmp, etc. Something didn't look right for webserver configuration because there were 2 available Zoneminder configurations. One was what I was using on 1.30.4 and the other was named zoneminder.conf.dpkg-dist. Enabling the dpkg-dist fixed the problem! The important bits are /usr/share/zoneminder/www/api and subdirectories need the RewriteEngine enabled while on my old configuration there was just the one AllOverwrite All directive; and allowances for /var/cache/zoneminder/cache.

First followup question is: What should be the ownership of subdirectories and files within /usr/share/zoneminder? root:root?

Second followup is: Is there any way to tell ZoneMinder to pop open a new window if I click on {Camera} Name link (far left) on the Console? Although Montage Review is very nice, after leaving it up for a while, mRemoteNG runs out of memory so I just click on 1 camera. Before I can click on 2 or 3 cameras and they would come up in popup windows and could continue for days.


Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest