Classic Skin/Storage

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
jimkoh
Posts: 50
Joined: Mon Nov 20, 2017 1:13 am

Classic Skin/Storage

Post by jimkoh » Thu Jul 25, 2019 5:27 pm

Hello
I'm using ver 132.3 and Debian 10. Clicking the 'classic' radio buttons for both skin and default css doesn't change anything. How can I get the classic skin back? Coming from ver 1.30.4 the current one is far less intuitive.

I also installed a new hard drive just for ZM. Under the storage link I put in the path /mnt/*** and left everything else at the default settings. Now I constantly get the error message "the video could not be loaded either because the server or network failed or because the format is not supported." However the console shows all cameras capturing and events show in the graph. All cameras are set to Mocord except one that's set to Monitor. A separate desktop widget shows video from all cameras and links turn red as expected when events occur, so I know the cameras are working.

I also can not find any mention of the Option - Storage in the wiki

kitkat
Posts: 88
Joined: Sun Jan 27, 2019 5:17 pm

Re: Classic Skin/Storage

Post by kitkat » Fri Jul 26, 2019 10:40 am

jimkoh wrote:
Thu Jul 25, 2019 5:27 pm
Hello
Clicking the 'classic' radio buttons for both skin and default css doesn't change anything. How can I get the classic skin back?
You may also need to select them in the drop-downs on 'Options' -> 'Display' page.
I also installed a new hard drive just for ZM. Under the storage link I put in the path /mnt/*** and left everything else at the default settings. Now I constantly get the error message "the video could not be loaded either because the server or network failed or because the format is not supported."
If it's not a timezone problem with php.ini (there often seem to be two entries), or an ownership/permissions issue, then you could try mounting the new drive directly over the Zoneminder folder, or bind-mounting it.

Copy the current ZM data to the new drive...

Code: Select all

cp -pR /var/lib/zoneminder /mnt/***/
Check the ownership and permissions...

Code: Select all

ls -l /mnt/***
ls -l /mnt/****/zoneminder
If the directories don't have the Read and eXecute bits set for all users (rwxr-xr-x) then change them...

Code: Select all

chmod 755 /mnt/***/zoneminder /mnt/***/zoneminder/*
And then mount it...

Code: Select all

mount /dev/sdx1 /var/lib/zoneminder/
OR
mount --bind /mnt/***/zoneminder /var/lib/zoneminder

jimkoh
Posts: 50
Joined: Mon Nov 20, 2017 1:13 am

Re: Classic Skin/Storage

Post by jimkoh » Fri Jul 26, 2019 11:42 am

The attached screen shots show my current settings. The classic skin setting still has no effect. The output from ls -l is
drwxr-xr-x 2 root root 4096 Jul 26 04:07 zoneminder. Where do I check and see if there's a timezone problem?
hard drive.jpeg
hard drive.jpeg (19.65 KiB) Viewed 3718 times
Classic2.jpeg
Classic2.jpeg (33.21 KiB) Viewed 3718 times
Classic.jpeg
Classic.jpeg (24.21 KiB) Viewed 3718 times

kitkat
Posts: 88
Joined: Sun Jan 27, 2019 5:17 pm

Re: Classic Skin/Storage

Post by kitkat » Fri Jul 26, 2019 3:55 pm

jimkoh wrote:
Fri Jul 26, 2019 11:42 am
The output from ls -l is
drwxr-xr-x 2 root root 4096 Jul 26 04:07 zoneminder.
This could be an ownership issue - That folder should belong to the www-data/apache user (depends on the distro).

For CentOS and similar derivatives, try...

Code: Select all

chown -R apache:apache /mnt/surveillance/zoneminder
For Ubuntu and related systems, 'apache' should be 'www-data' (I think).

You should also make sure that /mnt and /mnt/surveillance have the eXecute bit set...

Code: Select all

chmod +x /mnt /mnt/surveillance
Where do I check and see if there's a timezone problem?

Code: Select all

grep date.timezone /etc/php.ini
If that returns more than one line, and if more than one of them doesn't start with a # character or a semi-colon, then you should edit the file and remove all but one.

Your php.ini may be in a different place, again depending on your Linux distro.

jimkoh
Posts: 50
Joined: Mon Nov 20, 2017 1:13 am

Re: Classic Skin/Storage

Post by jimkoh » Fri Jul 26, 2019 6:55 pm

I made the changes you suggested. In the ZM log I get this error repeatedly 2019-07-26 11:48:37 web_php 17723 FAT Can't create frame images from video because there is no video file for this event at (/mnt/surveillance/zoneminder/3/2019-07-26/1223/1223-video.mp4 /usr/share/zoneminder/www/views/image.php 167

kitkat
Posts: 88
Joined: Sun Jan 27, 2019 5:17 pm

Re: Classic Skin/Storage

Post by kitkat » Sun Jul 28, 2019 8:10 pm

jimkoh wrote:
Fri Jul 26, 2019 6:55 pm
there is no video file for this event at (/mnt/surveillance/zoneminder/3/2019-07-26/1223/1223-video.mp4
Does this file (and the directory) actually exist?

Code: Select all

ls -l /mnt/surveillance/zoneminder/3/2019-07-26/1223/1223-video.mp4

jimkoh
Posts: 50
Joined: Mon Nov 20, 2017 1:13 am

Re: Classic Skin/Storage

Post by jimkoh » Sun Jul 28, 2019 9:37 pm

Everything seems to be working fine now except the Classic Skin. Changing those settings still has no effect.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests