Page 1 of 1

SOLVED: Image Quality Issues

Posted: Tue Jul 16, 2019 11:11 pm
by foxtrot1014
I had an installation of zoneminder running and everything was fine. It was time to upgrade though, so installed Ubuntu 18.04 Bionic Beaver and a fresh installation of 1.32. Everything's a clean install, and despite setting everything the same I'm having problems. The first one was solved, but it lead to a second one.

My old setup used remote source RTSP at 4K resolution and the system was fine. I set everything up identically this time, but received a 404 error in the log instead of a video. That problem was solved by using ffmpeg as the source.

Now I have a problem with image quality. I absolutely can't run at 4K without losing 3/4 of the image if anything besides rainbowy gray and green screens even shows up. 1080P is about 80% effective (see images). There's some regular distortion and pixelation, plus occasionally things get really weird. If I run 4K, load is at around 1.5 max, and about 1 max for 1080P.

What might be the most common causes of this problem?

Re: Image Quality Issues

Posted: Wed Jul 17, 2019 2:11 pm
by iconnor
We have seen this using udp instead of tcp.

Monitor->Source->Method: TCP

Re: Image Quality Issues

Posted: Fri Jul 19, 2019 5:50 pm
by foxtrot1014
That seems to have fixed it, thanks!

Between this, losing the old remote mrl source and other problems, It's been a two week long nightmare since I decided to "simply" update everything to U 18.04/ZM 1.32.x. Finally it's all back to functional (and working a bit better than before I might add).