Page 1 of 1

Distroted video over time - RESOLVED

Posted: Wed Jun 05, 2019 1:16 pm
by tapstah
Okay. I believe I have gone through all of the online docs with no luck, and I searched the forum but didn't find something precisely inline.

Zoneminder 1.32.3
os: Ubuntu 18.04.2
Camera: Hosafe H2MD4A

Screen shots included.

Having a persistent problem with just the hosafe cameras. I have other camera types that run fine, so it shouldn't be install specific, I don't think.

This camera works great, love the camera, plan on getting more but I need to sort out this issue first. When the camera has been running on mocord for longer than 15 hours it starts to get distorted, as in the image attached (see when running fine vs when not). It used to be this would happen within an hour, I changed the fps settings and the problem now takes several hours.

Any ideas where to start? Let me know if there is anything needed. Thanks in advance folks.
Screenshot_2019-06-05 ZM - Garage (2) - Feed.jpg
Screenshot_2019-06-05 ZM - Garage (2) - Feed.jpg (921.22 KiB) Viewed 2280 times

Re: Distroted video over time

Posted: Wed Jun 05, 2019 1:16 pm
by tapstah
more photos...

Re: Distroted video over time

Posted: Wed Jun 05, 2019 1:17 pm
by tapstah
more...

Re: Distroted video over time

Posted: Wed Jun 05, 2019 10:53 pm
by kitkat
Have you tried using H.264 Passthrough as the Video Writer, instead of X.264 Encode?

Re: Distroted video over time

Posted: Thu Jun 06, 2019 12:47 pm
by tapstah
kitkat wrote:
Wed Jun 05, 2019 10:53 pm
Have you tried using H.264 Passthrough as the Video Writer, instead of X.264 Encode?
No, I haven't. Just switched the setting now. I'll report back how it performs!

Re: Distorted video over time

Posted: Thu Jun 06, 2019 7:31 pm
by snake
You shouldn't have Max FPS set on ZM for FFMPEG, generally. See the help icon next to it. Leave that blank.

If that doesn't solve it, search around these forums. Some people have had screen tearing and artifacts solved with a variety of solution such as:

Force TCP or UDP mode on camera.
Lower camera FPS (on camera not on ZM)
Increase key frame rate
Try libVLC instead of FFMPEG
Increase CAPTURES_PER_FRAME to 2 or 3
Lower resolution of camera

Re: Distroted video over time

Posted: Tue Jun 11, 2019 9:51 pm
by iconnor
Double down on the no MaxFPS/AlarmMaxFPS. Those were needed for 1.30 but cause problems for 1.32. They starve ffmpeg for cpu.
You are already using TCP, so that's fine.
increasing key frame rate should cause it to correct faster
CAPTURES_PER_FRAME is not applicable to FFMPEG

I have seen this too on my crappy cameras, and I have resolved it, so do not despair. I think it is likely the MaxFPS/AlarmMaxFPS

There is a lot of great work in our master branch which may help. Feel free to upgrade to it. We are basically in feature freeze and just fixing bugs/updating docs before 1.34. it is safe to upgrade.

Re: Distroted video over time

Posted: Mon Jun 17, 2019 1:24 pm
by tapstah
All great replys. Sorry it took so long to reply - I was waiting to see if the issue was resolved. Kitkat's solution of x.264 Passthrough was the answer. I had already been tweaking with all of the other options for some time and it only made incremental improvements but the passthrough solved it. Thanks a ton!