Errors 404 and missing pages

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
xefil
Posts: 15
Joined: Wed Jul 19, 2017 1:30 pm

Errors 404 and missing pages

Post by xefil » Tue Feb 05, 2019 3:39 pm

Hello,

I'm having strange behaviour on my 1.32.3. Some pages are missing and i.e. the log page is without css and cannot see any log. Browsing the DB, it gets popupated, but opening this url:

http://<my_server_ip>/zm/index.php?view=log

I see the drop-down windows empty and in the apache logs, many 404 missing pages:

Code: Select all

192.168.1.50 - - [05/Feb/2019:16:37:30 +0100] "GET /zm/cache/skins_classic_css_base_skin-classic-1544278956.css HTTP/1.1" 404 551 "http://192.168.1.40/zm/index.php?view=log" "Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.81 Safari/537.36"
192.168.1.50 - - [05/Feb/2019:16:37:30 +0100] "GET /zm/cache/skins_classic_css_classic_skin-classic-1544278956.css HTTP/1.1" 404 555 "http://192.168.1.40/zm/index.php?view=log" "Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.81 Safari/537.36"
192.168.1.50 - - [05/Feb/2019:16:37:30 +0100] "GET /zm/cache/skins_classic_js_jquery-ui-1.12.1_jquery-ui.theme.min-classic-1544278956.css HTTP/1.1" 404 577 "http://192.168.1.40/zm/index.php?view=log" "Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.81 Safari/537.36"
192.168.1.50 - - [05/Feb/2019:16:37:30 +0100] "GET /zm/cache/skins_classic_js_dateTimePicker_jquery-ui-timepicker-addon-classic-1544278956.css HTTP/1.1" 404 583 "http://192.168.1.40/zm/index.php?view=log" "Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.81 Safari/537.36"
192.168.1.50 - - [05/Feb/2019:16:37:30 +0100] "GET /zm/cache/skins_classic_css_base_views_log-classic-1544278956.css HTTP/1.1" 404 557 "http://192.168.1.40/zm/index.php?view=log" "Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.81 Safari/537.36"
192.168.1.50 - - [05/Feb/2019:16:37:30 +0100] "GET /zm/cache/js_Server-classic-1544278956.js HTTP/1.1" 404 532 "http://192.168.1.40/zm/index.php?view=log" "Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.81 Safari/537.36"
192.168.1.50 - - [05/Feb/2019:16:37:30 +0100] "GET /zm/cache/skins_classic_css_classic_views_log-classic-1544278956.css HTTP/1.1" 404 560 "http://192.168.1.40/zm/index.php?view=log" "Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.81 Safari/537.36"
192.168.1.50 - - [05/Feb/2019:16:37:30 +0100] "GET /zm/cache/skins_classic_js_jquery-ui-1.12.1_jquery-ui.structure.min-classic-1544278956.css HTTP/1.1" 404 582 "http://192.168.1.40/zm/index.php?view=log" "Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.81 Safari/537.36"
192.168.1.50 - - [05/Feb/2019:16:37:30 +0100] "GET /zm/cache/skins_classic_js_skin-classic-1544278956.js HTTP/1.1" 404 544 "http://192.168.1.40/zm/index.php?view=log" "Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.81 Safari/537.36"
192.168.1.50 - - [05/Feb/2019:16:37:30 +0100] "GET /zm/cache/skins_classic_js_classic-classic-1544278956.js HTTP/1.1" 404 547 "http://192.168.1.40/zm/index.php?view=log" "Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.81 Safari/537.36"
192.168.1.50 - - [05/Feb/2019:16:37:30 +0100] "GET /zm/cache/skins_classic_views_js_log-classic-1544278956.js HTTP/1.1" 404 549 "http://192.168.1.40/zm/index.php?view=log" "Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.81 Safari/537.36"
192.168.1.50 - - [05/Feb/2019:16:37:30 +0100] "GET /zm/cache/js_Server-classic-1544278956.js HTTP/1.1" 404 532 "http://192.168.1.40/zm/index.php?view=log" "Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.81 Safari/537.36"
192.168.1.50 - - [05/Feb/2019:16:37:30 +0100] "GET /zm/cache/skins_classic_js_classic-classic-1544278956.js HTTP/1.1" 404 547 "http://192.168.1.40/zm/index.php?view=log" "Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.81 Safari/537.36"
192.168.1.50 - - [05/Feb/2019:16:37:31 +0100] "GET /zm/cache/skins_classic_js_skin-classic-1544278956.js HTTP/1.1" 404 544 "http://192.168.1.40/zm/index.php?view=log" "Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.81 Safari/537.36"
192.168.1.50 - - [05/Feb/2019:16:37:31 +0100] "GET /zm/cache/skins_classic_views_js_log-classic-1544278956.js HTTP/1.1" 404 549 "http://192.168.1.40/zm/index.php?view=log" "Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.81 Safari/537.36"
Ideas how to solve?

I'm on:

Code: Select all

# cat /etc/os-release                                      
PRETTY_NAME="Debian GNU/Linux buster/sid"
NAME="Debian GNU/Linux"
ID=debian
HOME_URL="https://www.debian.org/"
SUPPORT_URL="https://www.debian.org/support"
BUG_REPORT_URL="https://bugs.debian.org/"
thanks, Simon

Pedulla
Posts: 133
Joined: Thu Nov 27, 2014 11:16 am
Location: Portland, Or

Re: Errors 404 and missing pages

Post by Pedulla » Tue Feb 05, 2019 11:45 pm

Others have reported issues with straight Debian missing some dependencies.

Ubuntu 18.04 works great from the easy install.
https://wiki.zoneminder.com/Ubuntu_Serv ... e_easy_way

or LEMP stack
https://wiki.zoneminder.com/Ubuntu_Serv ... .2C_PHP.29

xefil
Posts: 15
Joined: Wed Jul 19, 2017 1:30 pm

Re: Errors 404 and missing pages

Post by xefil » Wed Feb 06, 2019 7:51 am

Hello,

Thanks for pointing to the doc. I know that there works well.
I was tring to fix my installation which was updated to Buster Debian.
Seems only the cache folder has something wrong, so I was wondering if it's possible to correct it without reinstall all.

Thanks, Simon

xefil
Posts: 15
Joined: Wed Jul 19, 2017 1:30 pm

Re: Errors 404 and missing pages

Post by xefil » Wed Feb 06, 2019 8:24 am

Hello,

Found the issue.
I've no idea why, but the files not found in 404 were placed in this folder "/var/cache/zoneminder" instead of this folder "/var/cache/zoneminder/cache" where the other resides.
Moving them in the right folder, the page layout start to work again.
Maybe that could help someone else in the future.

Thanks!

Simon

User avatar
snake
Posts: 181
Joined: Sat May 21, 2016 2:20 am

Re: Errors 404 and missing pages

Post by snake » Wed Feb 06, 2019 11:15 pm

I have installed new ZM 1.32+ on Debian Stretch & Devuan Ascii, and there were no issues.

Sounds like it's related to only Debian Buster.

xefil
Posts: 15
Joined: Wed Jul 19, 2017 1:30 pm

Re: Errors 404 and missing pages

Post by xefil » Thu Feb 07, 2019 8:06 am

Maybe, even if the update to Buster was after the installation of 1.32, but I've tested sometime some manual compilations, so the reasons could be different ;-)

Cheers, Simon

rockedge
Posts: 1097
Joined: Fri Apr 04, 2014 1:46 pm
Location: Connecticut,USA
Contact:

Re: Errors 404 and missing pages

Post by rockedge » Thu Feb 07, 2019 2:51 pm

I noticed that setting up ZM in Puppy Linux (Ubuntu binaries) that the issue with the css symlinks appearing in /var/cache/zoneminder instead of /var/cache/zoneminder/cache appears as well...easy fix to just change the Alias or symlink target. But in the beginning this threw me off as well.

xefil
Posts: 15
Joined: Wed Jul 19, 2017 1:30 pm

Re: Errors 404 and missing pages

Post by xefil » Thu Feb 07, 2019 3:43 pm

rockedge wrote:
Thu Feb 07, 2019 2:51 pm
I noticed that setting up ZM in Puppy Linux (Ubuntu binaries) that the issue with the css symlinks appearing in /var/cache/zoneminder instead of /var/cache/zoneminder/cache appears as well...easy fix to just change the Alias or symlink target. But in the beginning this threw me off as well.
Me too... then, looking in the apache logs and searching the missing files, the mistery was solved ;-)

Simon

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests