Events not show outside lan

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
francelo
Posts: 1
Joined: Wed Jan 30, 2019 11:26 am

Events not show outside lan

Post by francelo » Wed Jan 30, 2019 11:29 am

Hello,

My ZM server is configured with IP 192.168.2.240/24, on port 80, on the internal network everything works perfectly.

I have external internet network pointed to the server entrance door 82 nat 80. The living system works perfectly but the events do not. Message says format is not supported. I can not understand where the error is since it works perfectly internally.

Server: Ubuntu Server
ZM: 1.32.3

Thanks

tokenwizard
Posts: 1
Joined: Fri Sep 20, 2019 8:26 pm

Re: Events not show outside lan

Post by tokenwizard » Fri Sep 20, 2019 8:42 pm

I think I may be having a similar issue.

My Basic setup (thanks to CG-NAT)
Zoneminder running on Ubuntu Server 18.04 at 192.168.7.133 local IP
For the "Server" in the ZM Config, it defaulted to 192.168.7.133 so I left that.
From that same device I have a reverse ssh tunnel forwarding port 80 through serveo.net so I can access my ZM instance form outside my home network.

On my local network, everything works fine; capturing motion, viewing Montage, and playing back Events.

Outside of my local network, it ALMOST works fine. I can access the console and modify settings, but the Montage View and the Event Viewer are not working. It seems that the live streams for Montage and the Media Source URLs for the Events all point to the "FULL" path with the local IP:

Code: Select all

http://192.168.7.133/zm/cgi-bin/nph-zms?width=0%25&height=100%25&scale=100&mode=jpeg&maxfps=10&monitor=4&user=<redacted>&connkey=<redacted>&rand=<redacted>
In my experience, most websites use relative links for media sources and links internal to the server, rather than full paths. Is there a reason this is set up this way? If the ZM Web Application Root is /zm, can it not just pull the media from /zm/cgi-bin/nph-zms....... instead of the full URL with the server IP? Is there a setting somewhere I'm missing?

I have already added a line to my /etc/hosts on my Ubuntu/ZM Server that points 192.168.7.133 to camserver-zm hostname and then tried plugging in camserver-zm for the Server Config in ZM, and everything still works locally but not from outside my LAN.

This makes it really difficult to make any use of this application from outside my network, with CG-NAT that I have no way around. I can update my "Server Config" and change it from 192.168.7.133 to the url of my reverse SSH tunnel, and then it does indeed work, but that makes it reach out over that tunnel even when accessing locally, too, which is not ideal to say the least..

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests