No Event Capture [Solved]

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
firefly2
Posts: 2
Joined: Sat Jan 19, 2019 10:54 pm

No Event Capture [Solved]

Post by firefly2 » Tue Jan 22, 2019 10:58 pm

Clean install on Lubutu 18.10 zm 1.32.3, 8 GB ram and 240 GB ssd. Have older Lubutu system running 1.30.4, which s working properly. Installed using standard Ubuntu install https://zoneminder.readthedocs.io/en/st ... buntu.html skipping steps 3 and 5. New system does not capture any events although camera and zones are set up. Getting many log warnings and errors such as

2019-01-22 13:15:31.540071 web_php 32251 ERR Setting to disabled /usr/share/zoneminder/www/includes/functions.php 459
2019-01-22 13:17:31.489740 zmdc 31678 WAR Can't find process with command of 'zma -m 1' zmdc.pl
2019-01-22 13:17:55.603042 zmc_m1 32443 ERR Unable to get response, disconnecting zm_remote_camera_http.cpp 1096
2019-01-22 13:17:55.599455 zmc_m1 32443 ERR Unrecognised content type 'text/html' zm_remote_camera_http.cpp 858
2019-01-22 13:38:18.970798 web_php 1839 ERR Socket /var/run/zm/zms-785831s.sock does not exist. This file is created by zms, and since it does not exist, either zms did not run, or zms exited early. Please check your zms logs and ensure that CGI is enabled in apache and check that the PATH_ZMS is set correctly. Make sure that ZM is actually recording. If you are trying to view a live stream and the capture process (zmc) is not running then zms will exit. Please go to http://zoneminder.readthedocs.io/en/lat ... window-etc for more information. /usr/share/zoneminder/www/includes/functions.php 2048
2019-01-22 13:38:18.750749 zms_m1 2279 ERR Unable to connect to zmc process for monitor 1 zms.cpp 254
2019-01-22 13:38:18.746732 zms_m1 2279 ERR Unable to connect to monitor id 1 for streaming zm_stream.cpp 48

When set to Monitor or Motion Detect the camera video looks okay. The zm console page has EDIT,DELETE, and SELECT greyed out and only Total and Archived show a zero entry. Have been using older system for years, no issues. Not sure where to go with so many errors/warnings, that are all likely related.
Last edited by firefly2 on Sat Jan 26, 2019 10:31 pm, edited 1 time in total.

Prapovednik
Posts: 6
Joined: Tue Jan 22, 2019 2:40 pm

Re: No Event Capture

Post by Prapovednik » Wed Jan 23, 2019 1:04 pm

I have moved from Debian and have exactly the same issue. Anybody help?

Prapovednik
Posts: 6
Joined: Tue Jan 22, 2019 2:40 pm

Re: No Event Capture

Post by Prapovednik » Wed Jan 23, 2019 6:01 pm

I have solved my issue: my cams were set fps 1/8 (to save more space). Directly connected or with VLC they worked fine, despite of with zoneminder. Problem was solved when I increased fps to 2 or 4 (I didnt tested further values). My cams are Hikvision, and all worked great with previous zm build 1.28.
So, try to increase fps or change another settings of your camera.

firefly2
Posts: 2
Joined: Sat Jan 19, 2019 10:54 pm

Re: No Event Capture

Post by firefly2 » Sat Jan 26, 2019 10:29 pm

Solved. Steps 3 and 5 were still required for my install on Lubuntu 18.10 https://zoneminder.readthedocs.io/en/st ... buntu.html . After doing those steps and restarting Mysql the default zone worked. After setting up my zones detection stopped again. Had to make zones larger and change some zone settings and it started working again. Decreasing frame rate did not seem to help, only getting an occassional warning in the logs "WAR Can't find process with command of 'zma -m 1' zmdc.p" but I can live with that for now.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests