Rebuilt Pi 4 4G w/1T SSD

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
fatboy
Posts: 46
Joined: Wed Jul 02, 2008 11:42 am
Location: Country of Texas

Rebuilt Pi 4 4G w/1T SSD

Post by fatboy » Sun Mar 22, 2020 3:36 pm

https://storage.jamesachambers.com/benchmark/13008

Installed raspbian buster lite, decided I needed Pixel, Chromium, VLC

Followed this:

https://wiki.zoneminder.com/Raspberry_Pi_4_-_Raspbian

Have a handful of Zeros (5fps) running h264_v4l2_rtspserver. Have a Debian Xen VM running (same v1.32.3) great with same Zeros.

I can't get a feed on the Pi, not even with VLC (it's hard wired to the LAN just like my VM).

After 10+ years w/zoneminder (including Pi 4 w/stretch that sorta worked ok) I'm at a loss. Must be missing something, just not coming to me.

I build Linux boxes all day long, never have I had so much hair loss pulling it out (well, usually).

I've got 6 folks ready to buy Pi 4's and zeros configured for their security in these trying times.

This should just work as usual???

Anyone have success lately doing same?

User avatar
snake
Posts: 305
Joined: Sat May 21, 2016 2:20 am

Re: Rebuilt Pi 4 4G w/1T SSD

Post by snake » Sun Mar 22, 2020 6:45 pm

Post logs.

You will have slowdown running X / chromium on the Pi. I would advise against doing that. Are you able to get one camera working? Try one first. Don't setup all of them at once.

You have posted other similar posts, where I think you managed to get it working with GPU_MEM set to 512 on the Pi 4. After reviewing that and this post, I would recommend you upgrade the Pi to 1.34. It has a number of fixes, and may be better for your application. Not everyone needs to upgrade (1.32 will work for a lot of people), but 1.34 is better, and if it isn't too much trouble, you should use that. By default, it isn't in the Raspbian repos, though, so many people will end up with 1.32.3

Keep in mind, that you have delved into the DIY area of cameras with the Pi Zero. This is a choice that means that you will have to debug any problems that arise. Generally, the recomended cameras are Axis or Hikvision - these are tested options that will be likely to work without any issues. As soon as you decide to use a Pi Zero with a camera accessory, you are in less supported territory. I would advise using actual cameras when / if possible. If you must use the Pi Zero, and the connection is spotty, then you must be willing to support the device. Such is the nature of the RPI / Arduino / DIY ecosystem.

fatboy
Posts: 46
Joined: Wed Jul 02, 2008 11:42 am
Location: Country of Texas

Re: Rebuilt Pi 4 4G w/1T SSD

Post by fatboy » Mon Mar 23, 2020 3:29 pm

Upgrading now.

Thanks @snake

fatboy
Posts: 46
Joined: Wed Jul 02, 2008 11:42 am
Location: Country of Texas

Re: Rebuilt Pi 4 4G w/1T SSD

Post by fatboy » Mon Mar 23, 2020 10:20 pm

No go on the upgrade after complete removal of ZM and dependencies first. The Zeros stream to laptops and ZMXENVM 1.32.3 fine.

I turned debugging, so I may end up with a post or 2 on ZM 1.34.x

Install of OS went fine, haven't checked ulimits etc, will do next w/debug

Thanks again.

fatboy
Posts: 46
Joined: Wed Jul 02, 2008 11:42 am
Location: Country of Texas

Re: Rebuilt Pi 4 4G w/1T SSD

Post by fatboy » Thu Mar 26, 2020 4:51 pm

Update:

Installed 2019-09-26-raspbian-buster-lite.img (did not apt update/upgrade)

Setup:

zoneminder1.32.3

cpan Number::Bytes::Human

vi /usr/bin/zmpkg.pl
changed to read:
runCommand('zmdc.pl start zmaudit.pl -c -f');

rsync sdcard rootfs to SSD partition2

edit /boot/cmdline.txt with SSD PARTUUID-2

Log, 4 Zeros and one PiB running RTSP, all green (monitor only 5Fps 1024x768)

Some errors to chase, but working (in debug and log all errors)

Next up:
apt update/upgrade

rebuild with latest raspbian-buster-lite (depending on upgrade)

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests