apt problem with zmrepo

Forum for questions and support relating to the 1.31.x releases only.
Post Reply
DerGraf
Posts: 31
Joined: Fri Aug 17, 2018 7:33 pm

apt problem with zmrepo

Post by DerGraf » Sun Sep 02, 2018 11:49 am

I used ZM 1.31.45 from zmrepo for Debian Strech amd64. Thanks again for building.

In my /etc/apt/sources.list is the deb-multimedia.org as well. I need that for different packages.

Now on "apt update" and "apt upgrade" ZM will downgrade to 1.30.4 from deb-multimedia.org. So i cant upgrade my system. I think it is the result of that warning:

Code: Select all

root@debian:~# apt-get update
Ign:8 https://zmrepo.zoneminder.com/debian/master stretch/ InRelease
OK:9 https://zmrepo.zoneminder.com/debian/master stretch/ Release
Ign:11 https://zmrepo.zoneminder.com/debian/master stretch/ Release.gpg
W: The repository 'https://zmrepo.zoneminder.com/debian/master stretch/ Release' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
Importing of the GPG signature public key has done.

Need some help. Thanks.

bbunge
Posts: 2618
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: apt problem with zmrepo

Post by bbunge » Sun Sep 02, 2018 12:02 pm

You should be able to hold Zoneminder. I do that in Ubuntu.

DerGraf
Posts: 31
Joined: Fri Aug 17, 2018 7:33 pm

Re: apt problem with zmrepo

Post by DerGraf » Sun Sep 02, 2018 12:13 pm

bbunge wrote:
Sun Sep 02, 2018 12:02 pm
You should be able to hold Zoneminder. I do that in Ubuntu.
Is there a command for holding a package?

Edit: apt command for holding zoneminder is "apt-mark hold zoneminder". More than easy :oops:

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests