event email notification for alarms

Forum for questions and support relating to the 1.31.x releases only.
Post Reply
mlaustin66
Posts: 3
Joined: Sat May 05, 2018 2:51 am

event email notification for alarms

Post by mlaustin66 » Sat May 05, 2018 2:56 am

Hi All,

I'm new to Zoneminder. I'm running it in a docker on unraid, and I have email successfully setup (forced and alarm and had it emailed to me). My understanding is that you need to setup events through filters for email notification of an alarm being triggered. What are the specific parameters to use in the various settings? I can't find anything specific on this. I want to be able to get an email when a zone alarm goes off, pretty simple.

Also, I'm guessing when you click the execute button the filter is active. But how do you see a list of filters running in case you wanted to cancel one? I read about zmfilter.pl keeping the list, but how do you invoke it to see what is there?

Any help would be appreciated.

Mark

User avatar
snake
Posts: 337
Joined: Sat May 21, 2016 2:20 am

Re: event email notification for alarms

Post by snake » Sat May 05, 2018 12:51 pm

mlaustin66 wrote:
Sat May 05, 2018 2:56 am
What are the specific parameters to use in the various settings? I can't find anything specific on this. I want to be able to get an email when a zone alarm goes off, pretty simple.
See: https://wiki.zoneminder.com/SMS_Notifications
That should get you started.
mlaustin66 wrote:
Sat May 05, 2018 2:56 am
Also, I'm guessing when you click the execute button the filter is active. But how do you see a list of filters running in case you wanted to cancel one?
Filters have an asterisk after them in the drop down if they are running in the background 24/7.

rockedge
Posts: 1156
Joined: Fri Apr 04, 2014 1:46 pm
Location: Connecticut,USA
Contact:

Re: event email notification for alarms

Post by rockedge » Sat May 05, 2018 3:29 pm

lower left on the Filter management page select :

Code: Select all

Run filter in background
this will run that filter continuously in the background... Execute is the manual way to run the filter and Submit will run the filter but NOT execute the action selected.

mlaustin66
Posts: 3
Joined: Sat May 05, 2018 2:51 am

Re: event email notification for alarms

Post by mlaustin66 » Sun May 06, 2018 3:02 am

Ok thanks for everyone's help. So I am able to see how to create a filter, and save and run it in the background. But I'm having trouble with notifications. If I pull up the event list and click on show event filter from the top, I can execute the email to me. But on actual events, I am not getting email. Mine is setup as you see in the attachment. Is there something wrong with this setup to trigger and email upon the monitored area being triggered?
Attachments
Screen Shot 2018-05-05 at 10.00.20 PM.png
Screen Shot 2018-05-05 at 10.00.20 PM.png (139 KiB) Viewed 2518 times

SkippyDo
Posts: 196
Joined: Mon Nov 20, 2017 6:49 pm

Re: event email notification for alarms

Post by SkippyDo » Mon May 07, 2018 7:37 pm

What do your logs say? (filter the logs using ""zmfilter") Hard to tell if it's the e-mail mechanics or your filter's logic.

The filter logic seems to have some issues. It is a bit narrow in scope in that it's only accepting a match of only a single alarmed frame. Perhaps make this "greater than or equal to" would help. Also, the Date/Time match is likely NOT going to work as the filter's run time is going to lag the event's trigger time: I use "greater than or equal to" "5 minutes ago" to manage any lagging (others can mess around to see what works best).

rockedge
Posts: 1156
Joined: Fri Apr 04, 2014 1:46 pm
Location: Connecticut,USA
Contact:

Re: event email notification for alarms

Post by rockedge » Mon May 07, 2018 11:55 pm

I use this as a simple email filter ->
ZM-Screenshot-1-900px.png
ZM-Screenshot-1-900px.png (62.66 KiB) Viewed 2481 times

mlaustin66
Posts: 3
Joined: Sat May 05, 2018 2:51 am

Re: event email notification for alarms

Post by mlaustin66 » Sat May 12, 2018 2:26 am

Thanks all. This setup seems to work. I thought I was saving the filer with the correct settings, but I guess not. This setup seems to work.
Attachments
Screen Shot 2018-05-11 at 9.24.50 PM.png
Screen Shot 2018-05-11 at 9.24.50 PM.png (161.4 KiB) Viewed 2412 times

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest