Cannot display events in Chrome

Forum for questions and support relating to the 1.30.x releases only.
Post Reply
ckilner
Posts: 14
Joined: Sun Feb 10, 2019 12:05 pm

Cannot display events in Chrome

Post by ckilner » Sun Feb 10, 2019 12:19 pm

I have an new installation of Zoneminder 1.30.4 on a new build of Ubuntu 18.10. I view live stream and video using zmNinja on my phone and that works fine so the events are all there and playable.
When I try to view video using Chrome on my laptop and with WEB_H_CAN_STREAM=auto the status says "waiting for <my_domain_name>..." and it stays like that forever. The same if I try to view a previous event.

If I set WEB_H_CAN_STREAM=no then I can view live stream OK but I can't view events. The event screen headings and the video playback controls are displayed but no video between them.

I've tried this on another PC in a different location and it's still the same.

I'm stumped.

bbunge
Posts: 2315
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Cannot display events in Chrome

Post by bbunge » Sun Feb 10, 2019 1:06 pm

Did you use these instructions?
https://wiki.zoneminder.com/Ubuntu_Serv ... der_1.30.4

You may need to:
IMPORTANT FINAL STEP: Open Zoneminder in a web browser (http://server-ip/zm). Click on Options - Paths and change PATH_ZMS to /zm/cgi-bin/nph-zms

Or just use Firefox.

ckilner
Posts: 14
Joined: Sun Feb 10, 2019 12:05 pm

Re: Cannot display events in Chrome

Post by ckilner » Sun Feb 10, 2019 1:33 pm

Thanks for the suggestions.

Yes, used those instructions.
PATH_ZMS was already set to /zm/cgi-bin/nph-zms

I've just tried Firefox and that does the same, i.e. no event video plays.

bbunge
Posts: 2315
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Cannot display events in Chrome

Post by bbunge » Sun Feb 10, 2019 4:00 pm

Setting up 18.10 on my test machine. Stay tuned...

bbunge
Posts: 2315
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Cannot display events in Chrome

Post by bbunge » Sun Feb 10, 2019 5:53 pm

One omission to the install instructions:
After:
Add the following to the end of the file

[mysqld]
sql_mode = NO_ENGINE_SUBSTITUTION

CTRL + o CTRL +x


Added:
Restart MySQL

systemctl restart mysql

Otherwise my local and ip test cameras worked.

Again it is important to use the correct resolution in the Zoneminder settings. I use VLC (Tools, Media Information, Codec) to check camera Display Resolution.

ckilner
Posts: 14
Joined: Sun Feb 10, 2019 12:05 pm

Re: Cannot display events in Chrome

Post by ckilner » Mon Feb 11, 2019 6:13 pm

Thanks. Checked the settings and all OK.
However....I have found out what the cause is but not worked out what the solution is.
I'm running Bitdefender Internet security and that's what's causing the problem. If I turn it off, Zoneminder still fails. If I uninstall Bitdefender then Zoneminder works fine. Something in Bitdefender is messing things up so I need to work on that to find out what.
It's good to know that Zoneminder is working fine though, so cheers for the help with that.

ckilner
Posts: 14
Joined: Sun Feb 10, 2019 12:05 pm

Re: Cannot display events in Chrome

Post by ckilner » Mon Mar 11, 2019 5:36 pm

A quick update. It seems Bitdefender is the culprit. The presence of C:\Program Files\Bitdefender\Bitdefender Security\httpproxy.dll causes Zoneminder event playback to take several minutes to start.
To work round this I booted into Safe Mode, removed the httpproxy.dll file and then rebooted. Zoneminder displays the events instantly once the httpproxy.dll has been removed. The problem is that Bitdefender reloads this file each time is does an update so I've blocked the file in the Firewall which stops it getting reloaded.
BitDefender support are aware of this and have promised a fix but I'm not holding my breath.

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests