Can't create frame capture images from video because there is no video file

Forum for questions and support relating to the 1.30.x releases only.
Post Reply
KenwoodFox
Posts: 1
Joined: Tue Jan 29, 2019 2:16 am

Can't create frame capture images from video because there is no video file

Post by KenwoodFox » Tue Jan 29, 2019 2:22 am

Hey team, I've installed zone minder on FreeNAS using the plugin manager FreeNAS includes, my default directory has been mapped using the mount point config to send the video data to another dataset, and zoneminder seems fine writing data and retrieving data, problem is that I'm unable to use any of the logging tools, as I receive this error

Code: Select all

2019-01-29 00:59:47	web_php		82398	ERR	Event claims to have a video file, but it does not seem to exist at /var/db/zoneminder/events/1/2019-01-29/3/3-video.mp4	includes/Event.php	395
2019-01-29 00:59:47	web_php		82398	ERR	No data found for Event 3 frame 101	skins/classic/views/frame.php	65
2019-01-29 00:59:47	web_php		82398	FAT	Can't create frame capture images from video because there is no video file for this event at /var/db/zoneminder/events/1/2019-01-28/4/	views/image.php	187
2019-01-29 00:59:47	web_php		82398	FAT	Can't create frame capture images from video because there is no video file for this event at /var/db/zoneminder/events/1/2019-01-28/4/	views/image.php	187
2019-01-29 00:59:46	web_php		81125	FAT	Can't create frame images from video for this event (3-video.mp4	views/image.php	179
2019-01-29 00:59:45	web_php		81125	ERR	Event claims to have a video file, but it does not seem to exist at /var/db/zoneminder/events/1/2019-01-29/3/3-video.mp4	includes/Event.php	395
2019-01-29 00:59:45	web_php		81125	ERR	No data found for Event 3 frame 100
Even though the video file in question exists, or at least, there are mp4s of 1kb in its place. Any help would be very appreciated.
Extra note: the ownership of the extra dataset mount point is www

bbunge
Posts: 2364
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Can't create frame capture images from video because there is no video file

Post by bbunge » Wed Jan 30, 2019 7:02 pm

Did you enable OPT_FFMPEG and set PATH_FFMPEG?

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests