SOLVED: Blue Screen Is Best I Get

Forum for questions and support relating to the 1.30.x releases only.
Post Reply
foxtrot1014
Posts: 22
Joined: Sun Sep 10, 2017 8:12 pm

SOLVED: Blue Screen Is Best I Get

Post by foxtrot1014 » Sun Oct 29, 2017 11:24 pm

Hello all,

Relatively new to zoneminder and using a linux server (Ubuntu specifically).

I had some troubles getting zoneminder up and running, but with some help from kind folks here, I'm now at the point where I have a working zoneminder server that I can remotely access and a working security camera, but I can't get the two to work together.

My camera is one I purchased off of ebay from a company called HJT--an inexpensive Chinese brand, but after a few months of using the camera with their software, I'd give it a good review.

The camera supports RTSP, ONVIF, and HTTP, but no matter what combination of settings I use when adding it as a new monitor, the best I can get is a blue screen with ZM's time stamp in the top left. This is achieved by setting using HTTP on port 80. If I try using RTSP on 554, I just get white.

I can access a video feed form an app called ONVIFER on my phone, and it says it's successfully connecting using RTSP on 554 and ONVIF on 80.

Any suggestions?

I've literally tried every combination of settings that seem relevant to me. Some of them cause the source to turn red in ZM's main console. Most give me a white screen, but only when I use HTTP do I get a blue screen.

Any help is appreciated!

Thank you
Last edited by foxtrot1014 on Mon Nov 27, 2017 4:30 am, edited 1 time in total.

vskatusa
Posts: 33
Joined: Sat Jan 02, 2016 4:02 pm

Re: Blue Screen Is Best I Get

Post by vskatusa » Sun Oct 29, 2017 11:36 pm

Suggestions....
(1) reduce the frame rate in the camera (not zm) to say 5 frames and in zm maybe set it to 10 frames
(2) Does the network stream work in VLC [ media --> open network stream -- input the url] -- usually rtsp://{username}:{pswd}@{ip:port}//Streaming/Channels/1
If the above stream does not work try the forums for "your" type and model what stream URL others are using and go from there.

foxtrot1014
Posts: 22
Joined: Sun Sep 10, 2017 8:12 pm

Re: Blue Screen Is Best I Get

Post by foxtrot1014 » Mon Oct 30, 2017 12:04 am

vskatusa wrote:
Sun Oct 29, 2017 11:36 pm
Suggestions....
(1) reduce the frame rate in the camera (not zm) to say 5 frames and in zm maybe set it to 10 frames
(2) Does the network stream work in VLC [ media --> open network stream -- input the url] -- usually rtsp://{username}:{pswd}@{ip:port}//Streaming/Channels/1
If the above stream does not work try the forums for "your" type and model what stream URL others are using and go from there.
The frame rate was already pretty low, but I reduced it further, this alone didn't do anything.

I tried opening the stream in VLC as recommended, and things got interesting.

I opened the stream "rtsp://foxtrot:_______@10.0.0.41:554//Streaming/Channels/1" and the low-res sub stream opened. I opened the same thing, but Channels/0 and the main stream opened, but was glitchy gray in most places except where there was motion, but a stream nonetheless.

What I took from this was that I might need to add //Streaming/Channels/0 or 1 to Remote Host Path under the Source tab. This didn't end up giving me a stream, but if I set it to 1 and didn't change the resolution settings, then the IP address under the source column of the main console turned red.

I've attached some images of the settings and what I'm getting for low res.

Image
Image
Image

foxtrot1014
Posts: 22
Joined: Sun Sep 10, 2017 8:12 pm

Re: Blue Screen Is Best I Get

Post by foxtrot1014 » Mon Oct 30, 2017 12:31 am

And I've searched the forums here for anything relating to my camera's make (HJT) or it's software TH38M-ONVIF-P2P V2.5.2.26 and found nothing.

foxtrot1014
Posts: 22
Joined: Sun Sep 10, 2017 8:12 pm

Solved: Blue Screen Is Best I Get

Post by foxtrot1014 » Mon Nov 27, 2017 4:30 am

I'm not sure what specifically I changed, I think it may have been checking the final RTSP Response Media URL box in combination of everything else. Below are images of the settings I needed to get ZM to work with my "HJT" brand camera. If you have an HJT branded camera or the software shows up has TH38M ONVIF P2P V2.5.... this may work for you as well.

The Remote Host Path for the primary feed is //Streaming/Channels/0
and for the secondary (low-res) feed it's //Streaming/Channels/1, just make sure the resolution settings are correct.
These are also what you need to connect to the camera using VLC (rtsp://<username>:<password>@<camera's IP>:554//Streaming/Channels/0
), though I had issues with streaming UHD video (appears to be on VLCs end).

Image
Image

Image

bbunge
Posts: 2704
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: SOLVED: Blue Screen Is Best I Get

Post by bbunge » Mon Nov 27, 2017 8:17 pm

Now set the Reference and Alarm image blend to the same value, use ffmpeg and set the Target colorspace to 32 bit. Use the same string as VLC.

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests