8CH DVR PCI CX23880

Forum for questions and support relating to the 1.30.x releases only.
Post Reply
nokia001
Posts: 14
Joined: Tue Sep 06, 2011 8:40 pm

8CH DVR PCI CX23880

Post by nokia001 » Sun Feb 12, 2017 5:07 pm

Hi,

i updated my Server last week. Now i have a problem.
My 8CH DVR Card with Philips Semiconductors SAA7130 works greate.
But the 8ch DVR Card " Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder" won't work.

DMESG:

Code: Select all

[ 4117.988376] cx88[0]: subsystem: c180:c980, board: Shenzhen Tungsten Ages Tech TE-DTV-250 / Swann OEM [card=55,autodetected], frontend(s): 0
[ 4118.171537] cx88[0]/0: found at 0000:05:00.0, rev: 5, irq: 18, latency: 32, mmio: 0xfa000000
[ 4118.171645] cx88[0]/0: registered device video8 [v4l2]
[ 4118.171873] cx88[0]/0: registered device vbi8
[ 4118.171993] cx88[1]: subsystem: c180:c980, board: Shenzhen Tungsten Ages Tech TE-DTV-250 / Swann OEM [card=55,autodetected], frontend(s): 0
[ 4118.354935] cx88[1]/0: found at 0000:05:01.0, rev: 5, irq: 19, latency: 32, mmio: 0xf8000000
[ 4118.355047] cx88[1]/0: registered device video9 [v4l2]
[ 4118.355064] cx88[1]/0: registered device vbi9
[ 4118.355193] cx88[2]: subsystem: c180:c980, board: Shenzhen Tungsten Ages Tech TE-DTV-250 / Swann OEM [card=55,autodetected], frontend(s): 0
[ 4118.538966] cx88[2]/0: found at 0000:05:02.0, rev: 5, irq: 16, latency: 32, mmio: 0xf6000000
[ 4118.539063] cx88[2]/0: registered device video10 [v4l2]
[ 4118.539084] cx88[2]/0: registered device vbi10
[ 4118.539204] cx88[3]: subsystem: c180:c980, board: Shenzhen Tungsten Ages Tech TE-DTV-250 / Swann OEM [card=55,autodetected], frontend(s): 0
[ 4118.722981] cx88[3]/0: found at 0000:05:03.0, rev: 5, irq: 17, latency: 32, mmio: 0xf4000000
[ 4118.723082] cx88[3]/0: registered device video11 [v4l2]
[ 4118.723099] cx88[3]/0: registered device vbi11
[ 4118.723221] cx88[4]: subsystem: c180:c980, board: Shenzhen Tungsten Ages Tech TE-DTV-250 / Swann OEM [card=55,autodetected], frontend(s): 0
[ 4118.907253] cx88[4]/0: found at 0000:05:04.0, rev: 5, irq: 18, latency: 32, mmio: 0xf2000000
[ 4118.907361] cx88[4]/0: registered device video12 [v4l2]
[ 4118.907378] cx88[4]/0: registered device vbi12
[ 4118.907569] cx88[5]: subsystem: c180:c980, board: Shenzhen Tungsten Ages Tech TE-DTV-250 / Swann OEM [card=55,autodetected], frontend(s): 0
[ 4119.103394] cx88[5]/0: found at 0000:05:05.0, rev: 5, irq: 19, latency: 32, mmio: 0xf0000000
[ 4119.103501] cx88[5]/0: registered device video13 [v4l2]
[ 4119.103728] cx88[5]/0: registered device vbi13
[ 4119.104205] cx88[6]: subsystem: c180:c980, board: Shenzhen Tungsten Ages Tech TE-DTV-250 / Swann OEM [card=55,autodetected], frontend(s): 0
[ 4119.291077] cx88[6]/0: found at 0000:05:06.0, rev: 5, irq: 16, latency: 32, mmio: 0xee000000
[ 4119.291182] cx88[6]/0: registered device video14 [v4l2]
[ 4119.291199] cx88[6]/0: registered device vbi14
[ 4119.291321] cx88[7]: subsystem: c180:c980, board: Shenzhen Tungsten Ages Tech TE-DTV-250 / Swann OEM [card=55,autodetected], frontend(s): 0
[ 4119.475053] cx88[7]/0: found at 0000:05:07.0, rev: 5, irq: 17, latency: 32, mmio: 0xec000000
[ 4119.475154] cx88[7]/0: registered device video15 [v4l2]
[ 4119.475171] cx88[7]/0: registered device vbi15

Zoneminder syslog:

Code: Select all

 zmdc[6223]: INF [Starting pending process, zmc -d /dev/video14]
Feb 12 18:01:24 Videoserver zmdc[6223]: INF ['zmc -d /dev/video14' starting at 17/02/12 18:01:24, pid = 6383]
Feb 12 18:01:24 Videoserver zmdc[6383]: INF ['zmc -d /dev/video14' started at 17/02/12 18:01:24]
Feb 12 18:01:24 Videoserver zmc_dvideo14[6383]: INF [Starting Capture version 1.30.0]
Feb 12 18:01:24 Videoserver zmc_dvideo14[6383]: FAT [Failed to set video standard 256: Device or resource busy]
Feb 12 18:01:24 Videoserver zmdc[6223]: ERR ['zmc -d /dev/video14' exited abnormally, exit status 255]
Zoneminder settings:
DevicePath: /dev/video14
DeviceChannel: 0,1,2 (all tested)
Device Format: PAL
Capture Palette: YUYV
Width: 640
Height: 480


With ZM 1.25 and Kernel Gentoo 3.0.6 all worked.
Now 1.30 and Kernel Gentoo 4.9.6 only the SAA7130 worked.

Please help.
Thx

bbunge
Posts: 2708
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: 8CH DVR PCI CX23880

Post by bbunge » Sun Feb 12, 2017 5:45 pm

It is likely the newer Linux kernel does not support the old cards. Not Zoneminder's fault.

User avatar
iconnor
Posts: 1380
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: 8CH DVR PCI CX23880

Post by iconnor » Sun Feb 12, 2017 7:44 pm

yeah nothing has really changed with zm in terms of local capture cards. It is more likely the kernel's fault. Should be fixable though.

PaoloV
Posts: 1
Joined: Tue Oct 24, 2017 8:03 am

Re: 8CH DVR PCI CX23880

Post by PaoloV » Fri Nov 10, 2017 12:03 am

I got the same board: c180:c980, board: Shenzhen Tungsten Ages Tech TE-DTV-250 / Swann OEM [card=55,autodetected]

Did you solved?

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest