button play pause and fps status... in live view do not work Zm 1.30 from source [SOLVED]

Forum for questions and support relating to the 1.30.x releases only.
Post Reply
christophe_y2k
Posts: 102
Joined: Mon Oct 12, 2009 8:47 am
Location: EUROPE-FRANCE-MANDELIEU

button play pause and fps status... in live view do not work Zm 1.30 from source [SOLVED]

Post by christophe_y2k » Mon Aug 29, 2016 12:19 pm

Hi all !
On fresh install of Zm 1.30 from source under Linux Gentoo Server, have this bug?
On live view the buton play pause rewind ... do not work, when i click nothing change
and the fps do not show anything "Etat: - fps"

If you have an idea...

Thank.
PS: This version seem to be ... more responsive and faster and that cool

EDIT 30/08/2016
I solved the play pause button and fps with some dependence missing not asked by cmake, i look under the gentoo zoneminder build package ...

Code: Select all

# emerge --ask --quiet dev-vcs/git
# emerge --ask --quiet dev-perl/Date-Manip
# emerge --ask --quiet dev-perl/Archive-Zip
# emerge --ask --quiet dev-perl/DBD-mysql
# emerge --ask --quiet dev-perl/DBI
# emerge --ask --quiet dev-perl/Sys-Mmap
# emerge --ask --quiet dev-perl/URI-Encode
# emerge --ask --quiet dev-perl/libwww-perl
# emerge --ask --quiet virtual/httpd-php
# emerge --ask --quiet virtual/jpeg
# emerge --ask --quiet virtual/mysql
# emerge --ask --quiet virtual/perl-ExtUtils-MakeMaker
# emerge --ask --quiet virtual/perl-Getopt-Long
# emerge --ask --quiet virtual/perl-Sys-Syslog
# emerge --ask --quiet virtual/perl-Time-HiRes
# emerge --ask --quiet dev-libs/libpcre
# emerge --ask --quiet dev-libs/openssl
# emerge --ask --quiet dev-libs/libgcrypt
# emerge --ask --quiet media-libs/libv4l
# emerge --ask --quiet media-libs/libjpeg-turbo
# emerge --ask --quiet dev-perl/Device-SerialPort
# emerge --ask --quiet dev-perl/MIME-Lite
# emerge --ask --quiet dev-perl/MIME-tools
# emerge --ask --quiet dev-perl/PHP-Serialization
# emerge --ask --quiet virtual/perl-Archive-Tar
# emerge --ask --quiet virtual/perl-libnet
# emerge --ask --quiet virtual/perl-Module-Load
# emerge --ask --quiet net-libs/gnutls
# emerge --ask --quiet dev-util/cmake
# emerge --ask --quiet sys-devel/make
# emerge --ask --quiet sys-auth/polkit
# emerge --ask --quiet net-misc/curl
# emerge --ask --quiet net-libs/gnutls
# emerge --ask --quiet sys-apps/findutils
# emerge --ask --quiet sys-libs/zlib

Add "jpeg" et "ffmpeg" dans le fichier /etc/portage/make.conf:
# nano /etc/portage/make.conf
<--->
USE="... jpeg ... ffmpeg ..."
<--->

# echo 'media-video/ffmpeg -samba jpeg2k libv4l mp3 pic ssh v4l x264 x265' >> /etc/portage/package.use/ffmpeg
# emerge --ask --verbose --quiet media-video/ffmpeg
# emerge --ask --quiet virtual/ffmpeg 

# echo 'media-video/vlc -samba jpeg2k libv4l live mp3 pic ssh v4l x264 x265' >> /etc/portage/package.use/vlc
# echo '=x11-libs/gdk-pixbuf-2.32.3 X' >> /etc/portage/package.use/gdk-pixbuf
# echo '>=sys-libs/zlib-1.2.8-r1 minizip' >> /etc/portage/package.use/zlib
# echo '>=x11-libs/cairo-1.14.6 X' >> /etc/portage/package.use/cairo
# echo 'media-libs/libcanberra alsa' >> /etc/portage/package.use/libcanberra
# echo 'x11-libs/gtk+ X'  >> /etc/portage/package.use/gtk+
# emerge --ask --quiet media-video/vlc

# emerge --sync --quiet
# emerge --ask --verbose --quiet --update --deep --newuse --with-bdeps=y @world
# etc-update
# emerge --ask --depclean
# revdep-rebuild
<--->
PHP :
-----
# echo 'dev-lang/php -threads apache2 cgi curl inifile pdo mysql mysqli sockets' >> /etc/portage/package.use/php
# emerge --ask --quiet dev-lang/php
# nano /etc/conf.d/apache2
<--->
APACHE2_OPTS="-D DEFAULT_VHOST -D INFO -D SSL -D SSL_DEFAULT_VHOST -D LANGUAGE -D PHP"
<--->

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests