Can't login after enable password to login!!

Forum for questions and support relating to the 1.30.x releases only.
Post Reply
david1234
Posts: 11
Joined: Wed Jun 26, 2019 12:24 pm

Can't login after enable password to login!!

Post by david1234 » Sun Dec 01, 2019 4:18 pm

Hello ,
up until now my zonminder was in a private network - so I didn't needed a login.
I have did evertyhing it say here

Code: Select all

https://bkjaya.wordpress.com/2018/08/05/how-to-install-zoneminder-1-30-4-on-raspberry-pi-3-with-raspbian-9-upgraded-from-jessie-to-stretch/

when I enter
localhost/zm
I saw all the cameras.

I have connected the PI into the internet so I can see the cameras from anywhere
and added a new user with all privileges (such as the admin )
after doing this - I can't loggin to the zm .
I have reboot the PI - still nothing - I only get tot he login page .

I thought maybe I wrote the password wrong
so I enter the MariaDB and did it again

Code: Select all

mariadb -u zmuser -p
zmpass
SHOW DATABASES;
use zm;
Select * from Users;
update Users set Password="David@AAA" where Username="David";

Code: Select all

select * from Users;
+----+----------+-------------------------------------------+----------+---------+--------+--------+---------+----------+--------+---------+--------+--------------+------------+
| Id | Username | Password                                  | Language | Enabled | Stream | Events | Control | Monitors | Groups | Devices | System | MaxBandwidth | MonitorIds |
+----+----------+-------------------------------------------+----------+---------+--------+--------+---------+----------+--------+---------+--------+--------------+------------+
|  1 | admin    | *C765AEB753A079DA40856E23FBF22D95E64B92F7 |          |       1 | View   | Edit   | Edit    | Edit     | Edit   | Edit    | Edit   |              |            |
|  2 | David    | David@123!                                |          |       1 | View   | Edit   | Edit    | Edit     | Edit   | Edit    | Edit   | high         |            |
+----+----------+-------------------------------------------+----------+---------+--------+--------+---------+----------+--------+---------+--------+--------------+------------+

no problem there ,
reboot the PI
and still I can't enter .

what is wrong , and how can I fix this?
Please answer back


*****
only after I remove the password

Code: Select all

MariaDB [zm]> update Users set Password="" where Username="David";
I was able to connect

so what is worng?
how do I make a user and a password that allow me to connect?

Thanks ,

User avatar
snake
Posts: 254
Joined: Sat May 21, 2016 2:20 am

Re: Can't login after enable password to login!!

Post by snake » Sun Dec 01, 2019 6:01 pm

Don't follow random blog instructions for ZM. This author could've posted to the wiki, but he decided to copy it and post to his own wordpress. If he puts ads on his site, he could be making money off of bbhunge's hard work in maintaining the wiki. Not nice.

Use the install guides in the wiki or the official docs.

If you have Raspbian 8 or 9, you will be using 1.30. I'd recommend you go with Raspbian 10, so you can use 1.32.3. Here's a guide for Raspbian 10: https://wiki.zoneminder.com/Raspberry_Pi_4_-_Raspbian
Best results will be with passthrough. H264 encode doesn't work on 1.32.3, and its the default, so change it on the settings when you add a camera.


As for your original problem, I believe passwords have to be encrypted in mysql (if you are going to add them via a query). The easy way to add a user in ZM is to use the apache web gui.
Last edited by snake on Tue Dec 03, 2019 5:58 pm, edited 1 time in total.

david1234
Posts: 11
Joined: Wed Jun 26, 2019 12:24 pm

Re: Can't login after enable password to login!!

Post by david1234 » Tue Dec 03, 2019 1:09 pm

I did with the gui - but maybe I press the wrong letter .

I found the problem was that as you said , the password needed to be encrypted
so in the DB I just use this command

Code: Select all

MariaDB [zm]> update Users set Password=PASSWORD"NewPassword" where Username="David";
Thanks ,


Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests