Unable to view Event Stills, only Streams

Forum for questions and support relating to the 1.29.x releases only.
Post Reply
dsdee
Posts: 29
Joined: Thu May 04, 2006 4:21 pm
Location: Denver, CO

Unable to view Event Stills, only Streams

Post by dsdee » Mon Mar 14, 2016 2:11 am

Instead of upgrading my old system, I built out a new CentOS7 machine, and used the ZMRepo yum repository to install Zoneminder.

For the most part, it is working with no problems, captures events that I can view the stream, view live events... But I just can't view via the "Stills" link on the stream view. The browser box goes white as soon as I press "Stills" and nothing appears.

If I go into Frames, I can view the JPEG's by clicking sequentially, but obviously that's not the way to do things... It did work fine in my old setup.

One thing I have a question about is that the "DIR_EVENTS" config option in the "Paths" tab came defaulted to 'events' . The help text there indicates "should be in the web root" but yet the ZMREPO setup placed it out under /var/lib/zoneminder/www/events --Since I don't think this "in the web root" requirement is being enforced by PHP, HTTPD, or SELINUX (Permissive mode is active), I don't think that's relevant... plus, I do see the images being written to that folder AND they're view-able through the "Frames" menu link...

Nothing is showing in the HTTPD Error log, syslog, Zoneminder Logs when this is happening.

Any hints on why the Stills wouldn't be view-able?

Thanks,

User avatar
knight-of-ni
Posts: 2336
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: Unable to view Event Stills, only Streams

Post by knight-of-ni » Mon Mar 14, 2016 12:49 pm

dsdee wrote: Any hints on why the Stills wouldn't be view-able?
Interesting. I've been using ZoneMinder for many years and have never seen that link. If I want to see the stills, I get to it by clicking on the "frames" column.

In any case, to get the stills to appear, click anywhere inside the horizontal gray bar at the bottom. It doesn't seem like this is how it should work, but since I've never looked at the code that does this, I'm not sure yet what is going on.
dsdee wrote: One thing I have a question about is that the "DIR_EVENTS" config option in the "Paths" tab came defaulted to 'events' . The help text there indicates "should be in the web root" but yet the ZMREPO setup placed it out under /var/lib/zoneminder/www/events --Since I don't think this "in the web root" requirement is being enforced by PHP, HTTPD, or SELINUX (Permissive mode is active), I don't think that's relevant... plus, I do see the images being written to that folder AND they're view-able through the "Frames" menu link...
The help text is absolutely relevant. What you have missed is the symlink which maps /var/lib/zoneminder/www/events into /usr/share/zoneminder/www which is ZoneMinder's webroot. This is not unique to CentOS. Nearly all distros do the same thing, including Debian and Ubuntu.

Since many have fallen into this trap, I will caution you not to ever mess with the underlying event folder on your fileystem, the symlinks, or the folder names under Options. Altering any of them is a sure way to break your system and lose all your events. If you need to map your event folder to a dedicated drive (good idea), there is a wiki article which describes the proper way to do this.
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

dsdee
Posts: 29
Joined: Thu May 04, 2006 4:21 pm
Location: Denver, CO

Re: Unable to view Event Stills, only Streams

Post by dsdee » Mon Mar 14, 2016 1:46 pm

Interesting. Never had to click on that gray bar before... Wondering why it changed between 1.25 and 1.29 . Thanks!

User avatar
knight-of-ni
Posts: 2336
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: Unable to view Event Stills, only Streams

Post by knight-of-ni » Mon Mar 14, 2016 1:52 pm

We will have to look into it.

Other than the fact that one would expect the images to appear immediately, can you go through all the buttons on that screen a describe any difference between what you expected to happen versus what actually happened?
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

dsdee
Posts: 29
Joined: Thu May 04, 2006 4:21 pm
Location: Denver, CO

Re: Unable to view Event Stills, only Streams

Post by dsdee » Mon Mar 14, 2016 2:14 pm

That's the only change major change I've seen.

I'm going to do another rebuild from the ground up in the next day or so just to eliminate my having done something funky during the installation from the whole equation. Will see how it looks after that.

dmitripr
Posts: 17
Joined: Fri May 06, 2016 4:31 am

Re: Unable to view Event Stills, only Streams

Post by dmitripr » Mon May 09, 2016 7:14 pm

knnniggett wrote:We will have to look into it.

Other than the fact that one would expect the images to appear immediately, can you go through all the buttons on that screen a describe any difference between what you expected to happen versus what actually happened?
I have the same issue with ZM 1.29 on Ubuntu 16.04. No stills until I click on the grey bar at the bottom. The other problem is that once you click on the still to enlarge it, you cannot navigate between stills, the [<] and [>] buttons don't work. You have to close the enlarged still and then click on the next one.

wkstill
Posts: 30
Joined: Thu Jul 22, 2004 7:13 pm
Location: CLW,FL
Contact:

Re: Unable to view Event Stills, only Streams

Post by wkstill » Thu Jul 21, 2016 8:14 pm

I just did a fresh install, i am having same issue,


Distributor ID: Ubuntu
Description: Ubuntu 16.04 LTS
Release: 16.04
Codename: xenial

no errors in log or apache access/error logs.

I do see this error, but i don't think its related.

Undefined index: EventId in /usr/share/zoneminder/www/skins/classic/views/frame.php on line 78
Undefined index: MinAlarmPixels in /usr/share/zoneminder/www/includes/actions.php on line 377

SteveGilvarry
Posts: 445
Joined: Sun Jun 29, 2014 1:12 pm
Location: Melbourne, AU

Re: Unable to view Event Stills, only Streams

Post by SteveGilvarry » Wed Jul 27, 2016 2:17 am

Interestingly I just did an install on Ubuntu 16.04, I did have an issue with stills view initially. But I had just swapped this machine off of the feature-h264 branch and realised that the js was being cached, mine started working after a forced reload.
I will try a fresh install to see if I can replicate.
Production Zoneminder 1.35.x
Random Selection of Cameras (Dahua and Hikvision)
More Dev VM's than I care to count.

haus
Posts: 195
Joined: Thu Oct 11, 2007 5:10 am

Re: Unable to view Event Stills, only Streams

Post by haus » Mon Aug 01, 2016 5:49 am

Same issue here on a fresh 16.04 & 1.29 install (thanks, LVM, for ruining my weekend).

When I click the gray bar at the bottom, there's a div called "eventThumbs" that gets filled in (ajax?) with the event thumbnails (eventThumb1, eventThumb2, etc.). I never had to click anything to show these before. It looks like a scripting issue but I haven't yet had time to look into it. It's almost like there's a javascript/jquery call that should be firing when the eventStills div has the "hidden" class removed, but instead it's not loading until the gray bar is clicked.

Henri
Posts: 23
Joined: Mon May 16, 2011 7:39 pm

Re: Unable to view Event Stills, only Streams

Post by Henri » Sun Nov 13, 2016 8:00 pm

I have the same problem, what do i need to change to get this working again.

bbunge
Posts: 2709
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Unable to view Event Stills, only Streams

Post by bbunge » Mon Nov 14, 2016 2:25 am

Henri wrote:I have the same problem, what do i need to change to get this working again.
Please tell us about your system and what instructions you used to install.

bb

Henri
Posts: 23
Joined: Mon May 16, 2011 7:39 pm

Re: Unable to view Event Stills, only Streams

Post by Henri » Mon Nov 14, 2016 2:30 pm

I'm running ZM 1.29 on Ubuntu 16.04 installed with apt-get from Ubuntu, everything is working beside the stills function in the event screen.
If i select stills the first screen is blanc until the gray bar is clicked on the bottom of the screen.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests