Ubuntu ZM 1.29.0 in PPA Master

Forum for questions and support relating to the 1.29.x releases only.
Post Reply
bbunge
Posts: 2608
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Ubuntu ZM 1.29.0 in PPA Master

Post by bbunge » Tue Jan 05, 2016 1:33 pm

Development versions of ZM 1.29.0 for Ubuntu 14.04, 15.04 and 15.10 are in the Master PPA

https://launchpad.net/~iconnor/+archive ... der-master

As always, these are for testing and not recommended for production use. And, everything may not work!
Please report your success or problems with Ubuntu in this thread

Note: If you are doing an upgrade make sure you upgrade the database and database permissions!!!

Thanks!

bb
Last edited by bbunge on Wed Jan 06, 2016 1:13 am, edited 1 time in total.

bbunge
Posts: 2608
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Ubuntu ZM 1.29.0 in PPA Master

Post by bbunge » Tue Jan 05, 2016 4:34 pm

Temporary install instructions for Ubuntu are located at:

Ubuntu 14.04: https://wiki.zoneminder.com/Common_Issu ... untu_14.04

Ubuntu 15.x: https://wiki.zoneminder.com/Common_Issu ... 4_or_15.10

I have also tested the upgrade in Ubuntu 15.10 located at:
https://wiki.zoneminder.com/Common_Issu ... PA_version

Family business will preclude further testing for a week or so...

bb

codabiz
Posts: 52
Joined: Sun Jan 04, 2009 10:16 am
Location: London, UK

Re: Ubuntu ZM 1.29.0 in PPA Master

Post by codabiz » Tue Jan 05, 2016 5:31 pm

OS: Ubuntu Server 14.04.3 LTS

Upgrade from 1.28.109 Master to 1.29.0 Master seemed to succeed. However on restarting ZM I got:
'Version mismatch, system is version 1.29.0, database is 1.28.109'

Solved: command ~ sudo zmupdate.pl

Database successfully upgraded to 1.29.0

Many thanks for the great work on the ZM project.

bbunge
Posts: 2608
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Ubuntu ZM 1.29.0 in PPA Master

Post by bbunge » Tue Jan 05, 2016 7:48 pm

See:

https://wiki.zoneminder.com/Common_Issu ... PA_version

You will need to upgrade the database permissions, too.

McFuzz
Posts: 181
Joined: Tue Aug 28, 2012 7:03 am

Re: Ubuntu ZM 1.29.0 in PPA Master

Post by McFuzz » Fri Jan 08, 2016 8:27 am

Crap! I didn't notice it was pushed to the master and upgraded from 1.28.109 to 1.29.0...

Is there an easy way to downgrade or just bite the bullet and stick with it for the time being?

That said - don't see any real issues for now.

bbunge
Posts: 2608
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Ubuntu ZM 1.29.0 in PPA Master

Post by bbunge » Fri Jan 08, 2016 12:26 pm

McFuzz wrote:Crap! I didn't notice it was pushed to the master and upgraded from 1.28.109 to 1.29.0...

Is there an easy way to downgrade or just bite the bullet and stick with it for the time being?

That said - don't see any real issues for now.
As the lady said, "Where's the beef?" You were running a PPA Master version and upgraded to a PPA Master version....

bb

McFuzz
Posts: 181
Joined: Tue Aug 28, 2012 7:03 am

Re: Ubuntu ZM 1.29.0 in PPA Master

Post by McFuzz » Fri Jan 08, 2016 7:35 pm

bbunge wrote:
McFuzz wrote:Crap! I didn't notice it was pushed to the master and upgraded from 1.28.109 to 1.29.0...

Is there an easy way to downgrade or just bite the bullet and stick with it for the time being?

That said - don't see any real issues for now.
As the lady said, "Where's the beef?" You were running a PPA Master version and upgraded to a PPA Master version....

bb

I know I know - glad it was my own box and not my clients lol. I put his on a hold for everything zoneminder related :p

summetj
Posts: 11
Joined: Sat Jan 01, 2011 12:48 pm

Re: Ubuntu ZM 1.29.0 in PPA Master

Post by summetj » Tue Jan 12, 2016 1:43 pm

My Ubuntu box updated to 1.29.0 from the PPA.

I ran the zmupdate.pl script successfully, and I reapplied the permissions grant select,insert,update,delete,create,alter,lock tables,index on zm.* to 'zmuser'@localhost identified by 'zmpass';

Now I'm getting errors such as:
ERR [Bogus number of lines return from query, 0 returned for query SELECT Id FROM Servers WHERE Name='192.168.2.16'.]
Jan 12 08:41:36 igor undef[29547]: FAT [Can't get ServerId for Server 192.168.2.16]

(the IP address is correct).

What should I check/fix for this?
Thanks,
Jay

GDixon
Posts: 9
Joined: Sun Jan 31, 2016 11:40 pm

Re: Ubuntu ZM 1.29.0 in PPA Master (solved)

Post by GDixon » Wed Feb 03, 2016 3:20 am

I installed ubuntu server 15.10 32 bit no problem and followed the new install with the 1.29 ppa

followed all the steps but got hung at the install of zoneminder

here is the response / error i got back

Yes I tried a second and third time to install.

Code: Select all

apt-get install zoneminder
Reading package lists... Done
Building dependency tree       
Reading state information... Done
zoneminder is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] 
Setting up zoneminder (1.29.0-wily-2016012801) ...
DBD::mysql::st execute failed: SELECT command denied to user 'zmuser'@'localhost' for table 'Config' at /usr/share/perl5/ZoneMinder/Config.pm line 99.
Can't execute: SELECT command denied to user 'zmuser'@'localhost' for table 'Config' at /usr/share/perl5/ZoneMinder/Config.pm line 119.
BEGIN failed--compilation aborted at /usr/share/perl5/ZoneMinder/Config.pm line 119.
Compilation failed in require at /usr/bin/zmupdate.pl line 71.
BEGIN failed--compilation aborted at /usr/bin/zmupdate.pl line 71.
dpkg: error processing package zoneminder (--configure):
 subprocess installed post-installation script returned error exit status 255
Errors were encountered while processing:
 zoneminder
E: Sub-process /usr/bin/dpkg returned an error code (1)
any clues tips or help to remedy this?

Greg

EDIT: solved with a reboot and starting from the top to try again. Re booted again and it now works. time to add cameras and see whats what :)

bbunge
Posts: 2608
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Ubuntu ZM 1.29.0 in PPA Master

Post by bbunge » Wed Feb 03, 2016 1:24 pm

Here is a link to the WIKI where there are current instructions for installing the master snapshot from the PPA:

https://wiki.zoneminder.com/Common_Issu ... 4_or_15.10

https://wiki.zoneminder.com/Common_Issu ... untu_14.04

You did not say what instructions you were using...

GDixon
Posts: 9
Joined: Sun Jan 31, 2016 11:40 pm

Re: Ubuntu ZM 1.29.0 in PPA Master

Post by GDixon » Wed Feb 03, 2016 6:34 pm

Sorry,

I was using the ones here and what I think I did wrong was after doing the update upgrde and then dist upgrade i rebooted instead of just following through. The second time i went back i followed through and didn't reboot until all steps were followed.

https://wiki.zoneminder.com/Common_Issu ... 4_or_15.10

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests