zmNinja - Android push notifications not working

Discussion topics related to mobile applications for ZoneMinder
technesurge
Posts: 8
Joined: Sat Feb 01, 2020 3:51 pm

zmNinja - Android push notifications not working

Post by technesurge » Sat Feb 01, 2020 6:35 pm

Hello,

My problem is I don't get push notifications from zmNinja on my Android phone.

It appears the event server is working properly because I can log into the server with wscat and see that it is producing events. I can see the traffic flowing between the event server and Android phone on Wireshark.

However, I DO NOT receive the expected "Raw incoming message" for pushing the token:

2018-12-20,08:32:43 Raw incoming message: {"event":"push","data":{"type":"token","platform":"ios","token":"cVuLzCBsEn4:APA91bHYuO3hVJqTIMsm0IRNQEYAUa<deleted>GYBwNdwRfKyZV0","monlist":"1,2,4,5,6,7,11","intlist":"45,60,0,0,0,45,45","state":"enabled"}}

Also, the tokens.txt file is always empty and never receives a token.

Then the server just rolls on like nothing is wrong and I do not get any errors from the server or zmNinja and I can continue to see events getting transmitted from my server to my phone on Wireshark.

Any suggestions?
Thank you

User avatar
asker
Posts: 1305
Joined: Sun Mar 01, 2015 12:12 pm

Re: zmNinja - Android push notifications not working

Post by asker » Sat Feb 01, 2020 8:23 pm

This is generally the case when zmNinja cannot reach the event server (ES url may be wrong, you might have specified WSS when its WS or vice versa, or the ES IP is unreachable from the phone)

The way it works:

1. zmninja registers with Google's push server and gets a unique token
2. It needs to pass this token to the ES (over web sockets) at least once so the ES knows it needs to send it to this token
3. ES pushes

If 2 doesn't happen due to the reasons above, you won't get push
--
My collection of ZoneMinder learnings:
https://wiki.zoneminder.com/Various_ZM_thoughts

technesurge
Posts: 8
Joined: Sat Feb 01, 2020 3:51 pm

Re: zmNinja - Android push notifications not working

Post by technesurge » Sat Feb 01, 2020 11:08 pm

Thank you for response.

I think I am connecting to the ES because I see:
Feb 1, 2020 05:16:34 PM INFO EventSever: openHandshake: Websocket open, sending Auth
and then it appears as though it gets disconnected after the 20 second timeout because it never registered the push token.

I think the attached logs show the problem more clearly.

Your thoughts?


Thank you
Attachments
zmNinjaLog.txt
(21.25 KiB) Downloaded 135 times
zmeventnotification.log
(31.17 KiB) Downloaded 119 times

technesurge
Posts: 8
Joined: Sat Feb 01, 2020 3:51 pm

Re: zmNinja - Android push notifications not working

Post by technesurge » Sun Feb 02, 2020 10:36 pm

I installed wscat on my phone and verified that it can reach my event server (and I can feed it a fake token).
I can get a token and see it in zmNinjaLog.txt.
I see in the zmeventnotification.log that it "got a websocket connection..." and "Correct authentication..."
Immediately afterwards: "Websocket remotely disconnected"

Similarly, zmNinjaLog.txt reported:
INFO EventSever: Clearing error/close cbk, disconnecting and deleting Event Server socket...
DEBUG EventSever: Closing native websocket as websocket =

I believe that means: I can connect, to the event server, but I get disconnected before I can pass the token.
Also I can't find any source file with the phrase "Clearing error/close cbk" and not much on Google either.
Any thoughts?

User avatar
asker
Posts: 1305
Joined: Sun Mar 01, 2015 12:12 pm

Re: zmNinja - Android push notifications not working

Post by asker » Sun Feb 02, 2020 11:27 pm

So looking through your logs:

Step 1: You saved ES data. When you save, the code disconnects first. That is ok.

Code: Select all

Feb 1, 2020 05:16:57 PM DEBUG Saving Event Server data
Feb 1, 2020 05:16:57 PM DEBUG obfuscate: original:5099 obfuscated:1311 scheme:lzs
Feb 1, 2020 05:16:57 PM INFO EventSever: Clearing error/close cbk, disconnecting and deleting Event Server socket...
Feb 1, 2020 05:16:57 PM DEBUG EventSever: Closing native websocket as websocket = 9d614ff6-d910-49ed-9a7c-76c0cba45e4c
Step 2: Right after that the ES reconnects with the saved data. Looks good.

Code: Select all

Feb 1, 2020 05:16:57 PM INFO EventSever: Initializing Websocket with URL ws://e.d.f.g:9000
Feb 1, 2020 05:16:57 PM DEBUG EventSever: Using native websockets...

Step 3: The Android app connects to the ES and establishes a valid connection. Looks good. They even exchange authentication data

Code: Select all

Feb 1, 2020 05:16:58 PM DEBUG EventSever: WebSocket open called with:{"webSocketId":"eb4f36c7-cf01-46bc-842d-59ad3eb34369","code":101}
Feb 1, 2020 05:16:58 PM INFO EventSever: openHandshake: Websocket open, sending Auth
Feb 1, 2020 05:16:58 PM DEBUG EventSever: sendMessage: received->{"event":"auth","data":{"user":"localuser",<password removed>,"monlist":"5,8,7,11,10,12","intlist":"0,0,0,0,0,0"}}
Feb 1, 2020 05:16:58 PM DEBUG EventServer: ok to send message

Step 4: The Android app then registers with Google FCM to get a unique token, but I don't see any response .NOT GOOD.

Code: Select all

Feb 1, 2020 05:16:58 PM DEBUG EventSever: Initializing FCM push
Feb 1, 2020 05:16:58 PM INFO EventSever: Setting up push registration
The response you should see is:

Code: Select all

EventSever: Push Notification registration ID received: <some long token>
This response comes from Google FCM and unless the app gets it, it can't send the token to the ES. Do you see it later in the logs? If not, we have a problem.

Thoughts:
1. I assume you bought zmNinja from the play store (or compiled it yourself) and the phone you are using it in has Google Play services? If not, push may not work (In the past some folks told me about using it on devices that don't have Google Play services and they use some 3rd party shim - I have no idea how that works, and I don't support it)

2. Assuming point 1 above is not an issue, completely delete the app and re-install
--
My collection of ZoneMinder learnings:
https://wiki.zoneminder.com/Various_ZM_thoughts

technesurge
Posts: 8
Joined: Sat Feb 01, 2020 3:51 pm

Re: zmNinja - Android push notifications not working

Post by technesurge » Mon Feb 03, 2020 12:46 am

Thank you for your time, I appreciate it.

No, I have never seen and did not see anything like "Push Notification registration ID received: <some long token>"
I compiled zmNinja myself, and I am using it on a normal phone with Google Play services.

I reinstalled zmNinja and attached the logs - same problem.
Attachments
zmNinjaLog.txt
(19.64 KiB) Downloaded 118 times
zmeventnotification.log
(15.15 KiB) Downloaded 125 times
console.log
(52.96 KiB) Downloaded 112 times

User avatar
asker
Posts: 1305
Joined: Sun Mar 01, 2015 12:12 pm

Re: zmNinja - Android push notifications not working

Post by asker » Mon Feb 03, 2020 1:32 am

You should debug and make sure the push plugin is not showing any error in ADB logs.
--
My collection of ZoneMinder learnings:
https://wiki.zoneminder.com/Various_ZM_thoughts

technesurge
Posts: 8
Joined: Sat Feb 01, 2020 3:51 pm

Re: zmNinja - Android push notifications not working

Post by technesurge » Wed Feb 05, 2020 12:43 am

Ok, thank you for pointing in that direction.

ultimategrandson
Posts: 4
Joined: Thu Feb 13, 2020 11:13 am

Re: zmNinja - Android push notifications not working

Post by ultimategrandson » Mon Feb 24, 2020 3:29 am

I'm having this exact same problem, I installed the app from the store and I get the same logging up until the FCM token is supposed to set. I have tried absolutely everything.

I did have all this working before, I had set it up on a old RaspberryPi and I then bought a new one and freshly installed it on that and it hasn't worked since.

I reset the Google Play Services and Store and completely reinstalled zmNinja, no joy.

I do use WireGuard to access it, but i even tried it without it and still nothing.

If it was an access rights issue with the tokens.txt file would you see an error message?

LE DEBUG:2020-02-24,13:24:41 PARENT: Finished processJobs()
CONSOLE INFO:2020-02-24,13:24:41 PARENT: There are 0 active child forks...
02/24/20 13:24:41.200995 zmeventnotification[13103].INF [main:836] [PARENT: There are 0 active child forks...]
CONSOLE DEBUG:2020-02-24,13:24:41 PARENT: checkEvents() new events found=0
CONSOLE INFO:2020-02-24,13:24:41 PARENT: There are 0 new Events to process
02/24/20 13:24:41.207914 zmeventnotification[13103].INF [main:836] [PARENT: There are 0 new Events to process]
CONSOLE DEBUG:2020-02-24,13:24:41 PARENT: ---------->Tick END<--------------
CONSOLE DEBUG:2020-02-24,13:24:43 PARENT: ---------->onConnect START<--------------
CONSOLE INFO:2020-02-24,13:24:43 PARENT: got a websocket connection from 192.168.1.232 (0) active connections
02/24/20 13:24:43.485375 zmeventnotification[13103].INF [main:836] [PARENT: got a websocket connection from 192.168.1.232 (0) ac tive connections]
CONSOLE DEBUG:2020-02-24,13:24:43 PARENT: ---------->onConnect STOP<--------------
CONSOLE DEBUG:2020-02-24,13:24:43 PARENT: ---------->onConnect:handshake START<--------------
CONSOLE INFO:2020-02-24,13:24:43 PARENT: Websockets: New Connection Handshake requested from 192.168.1.232:54024 state=pending a uth, id=1582512883.49449
02/24/20 13:24:43.495047 zmeventnotification[13103].INF [main:836] [PARENT: Websockets: New Connection Handshake requested from 192.168.1.232:54024 state=pending auth, id=1582512883.49449]
CONSOLE DEBUG:2020-02-24,13:24:43 PARENT: ---------->onConnect:handshake END<--------------
CONSOLE DEBUG:2020-02-24,13:24:43 PARENT: ---------->onConnect msg START<--------------
CONSOLE DEBUG:2020-02-24,13:24:43 PARENT: Raw incoming message: {"event":"auth","data":{"user":"douglas","password":***,"monlist ":"1,4","intlist":"0,0"}}
CONSOLE DEBUG:2020-02-24,13:24:43 PARENT: Comparing using bcrypt $2a$10$0JZhQDRGfltpyRwIlbFWdOUYFsJE7aBc3rHkXBOpbUomkeIix6Oku to $2a$10$0JZhQDRGfltpyRwIlbFWdOUYFsJE7aBc3rHkXBOpbUomkeIix6Oku
CONSOLE INFO:2020-02-24,13:24:43 PARENT: Correct authentication provided by 192.168.1.232
02/24/20 13:24:43.693747 zmeventnotification[13103].INF [main:836] [PARENT: Correct authentication provided by 192.168.1.232]
CONSOLE DEBUG:2020-02-24,13:24:43 PARENT: ---------->onConnect msg STOP<--------------
CONSOLE DEBUG:2020-02-24,13:24:46 PARENT: ---------->Tick START<--------------
CONSOLE DEBUG:2020-02-24,13:24:46 PARENT: After tick: TOTAL: 1, ES_CONTROL: 1, FCM+WEB: 0, FCM: 0, WEB: 1, MQTT:0, invalid WEB: 0, PENDING: 0
CONSOLE DEBUG:2020-02-24,13:24:46 PARENT: Finished processJobs()
CONSOLE INFO:2020-02-24,13:24:46 PARENT: There are 0 active child forks...
02/24/20 13:24:46.198908 zmeventnotification[13103].INF [main:836] [PARENT: There are 0 active child forks...]
CONSOLE DEBUG:2020-02-24,13:24:46 PARENT: checkEvents() new events found=0
CONSOLE INFO:2020-02-24,13:24:46 PARENT: There are 0 new Events to process
02/24/20 13:24:46.210396 zmeventnotification[13103].INF [main:836] [PARENT: There are 0 new Events to process]
CONSOLE DEBUG:2020-02-24,13:24:46 PARENT: ---------->Tick END<--------------
CONSOLE DEBUG:2020-02-24,13:24:51 PARENT: ---------->Tick START<--------------
CONSOLE DEBUG:2020-02-24,13:24:51 PARENT: After tick: TOTAL: 1, ES_CONTROL: 1, FCM+WEB: 0, FCM: 0, WEB: 1, MQTT:0, invalid WEB: 0, PENDING: 0
CONSOLE DEBUG:2020-02-24,13:24:51 PARENT: Finished processJobs()
CONSOLE INFO:2020-02-24,13:24:51 PARENT: There are 0 active child forks...
02/24/20 13:24:51.201634 zmeventnotification[13103].INF [main:836] [PARENT: There are 0 active child forks...]
CONSOLE DEBUG:2020-02-24,13:24:51 PARENT: checkEvents() new events found=0
CONSOLE INFO:2020-02-24,13:24:51 PARENT: There are 0 new Events to process

warcanoid
Posts: 20
Joined: Mon Feb 17, 2020 3:22 pm

Re: zmNinja - Android push notifications not working

Post by warcanoid » Mon Feb 24, 2020 7:46 am

I have a weird problem. I had working notifications, then added new camera, and iphone wont get more any notifications. I get it only on ipad, all notiifcations. I have enable sync with cloud(tried without it), and same settings as on ipad.
Unistalled several times the app, reboted iphone. What more can I do?

technesurge
Posts: 8
Joined: Sat Feb 01, 2020 3:51 pm

Re: zmNinja - Android push notifications not working

Post by technesurge » Mon Feb 24, 2020 1:48 pm

If it was an access rights issue with the tokens.txt file would you see an error message?

Unfortunately I haven't been able to dig any deeper since my last post on this issue. So I can't offer much besides: give read and write permissions to "others" to test if you are having access rights issues.

User avatar
asker
Posts: 1305
Joined: Sun Mar 01, 2015 12:12 pm

Re: zmNinja - Android push notifications not working

Post by asker » Mon Feb 24, 2020 3:15 pm

ultimategrandson wrote:
Mon Feb 24, 2020 3:29 am
I'm having this exact same problem, I installed the app from the store and I get the same logging up until the FCM token is supposed to set. I have tried absolutely everything.
I'm not sure you are facing the same problem.
Please post your zmNinja logs to start so we can make sure the FCM token is being generated.
--
My collection of ZoneMinder learnings:
https://wiki.zoneminder.com/Various_ZM_thoughts

warcanoid
Posts: 20
Joined: Mon Feb 17, 2020 3:22 pm

Re: zmNinja - Android push notifications not working

Post by warcanoid » Mon Feb 24, 2020 8:43 pm

My zmninja log:

Code: Select all

2020-02-24T19:41:07.430Z INFO ******* app .run device ready
Feb 24, 2020 08:41:07 PM INFO Device is ready
Feb 24, 2020 08:41:07 PM INFO You are running on ios
Feb 24, 2020 08:41:07 PM DEBUG Inside configureStorageDB
Feb 24, 2020 08:41:07 PM DEBUG configureStorageDB: trying order:["cordovaSQLiteDriver","asyncStorage","localStorageWrapper"]
Feb 24, 2020 08:41:07 PM INFO configureStorageDB:localforage driver for storage:cordovaSQLiteDriver
Feb 24, 2020 08:41:07 PM DEBUG configureStorageDB:Making sure this storage driver works...
Feb 24, 2020 08:41:07 PM DEBUG configureStorageDB:test get/set worked, this driver is ok...
Feb 24, 2020 08:41:07 PM INFO localforage driver:cordovaSQLiteDriver
Feb 24, 2020 08:41:07 PM INFO CloudSync: Syncing with cloud if enabled...
Feb 24, 2020 08:41:07 PM INFO user profile encrypted, decoding...
Feb 24, 2020 08:41:07 PM DEBUG deobfuscate: before:2449 after:9298 scheme:lzs
Feb 24, 2020 08:41:07 PM INFO Found valid local configuration, overwriting cloud settings...
Feb 24, 2020 08:41:07 PM INFO local data synced with cloud...
Feb 24, 2020 08:41:07 PM INFO Cloudsync operation complete, continuing...
Feb 24, 2020 08:41:07 PM INFO >>>>No data to import....
Feb 24, 2020 08:41:07 PM INFO Updating statusbar
Feb 24, 2020 08:41:07 PM INFO Retrieving language before init is called...
Feb 24, 2020 08:41:07 PM INFO App Version: 1.3.088
Feb 24, 2020 08:41:07 PM INFO No language set, switching to en
Feb 24, 2020 08:41:07 PM INFO Device Language is:en
Feb 24, 2020 08:41:07 PM INFO >>>>Language to be used:en
Feb 24, 2020 08:41:07 PM DEBUG isFirstUse returned: false
Feb 24, 2020 08:41:07 PM DEBUG last state=app.events param=[object Object]
Feb 24, 2020 08:41:07 PM INFO Language file loaded, continuing with rest
Feb 24, 2020 08:41:07 PM INFO ZMData init: checking for stored variables & setting up log file
Feb 24, 2020 08:41:07 PM INFO Checking for new version updates...
Feb 24, 2020 08:41:07 PM INFO Setting up pause and resume handler AFTER language is loaded...
Feb 24, 2020 08:41:07 PM DEBUG current version: 1.3.088 & available version 1.3.089
Feb 24, 2020 08:41:07 PM INFO user profile encrypted, decoding...
Feb 24, 2020 08:41:07 PM DEBUG deobfuscate: before:2449 after:9298 scheme:lzs
Feb 24, 2020 08:41:07 PM INFO Setting NVR init bandwidth to: highbw
Feb 24, 2020 08:41:07 PM INFO NVR init retrieved store loginData
Feb 24, 2020 08:41:07 PM DEBUG Setting cordova header X-ZmNinja to zmNinja_1.3.088
Feb 24, 2020 08:41:07 PM INFO >>>> Disabling strict SSL checking (turn off  in Dev Options if you can't connect)
Feb 24, 2020 08:41:07 PM INFO Inside init-complete in app.js: All init over, going to portal login
Feb 24, 2020 08:41:07 PM DEBUG --> SSL is permissive, will allow any certs. Use at your own risk.
Feb 24, 2020 08:41:07 PM INFO Entering Portal Main
Feb 24, 2020 08:41:07 PM DEBUG Inside Portal login Enter handler
Feb 24, 2020 08:41:07 PM INFO User credentials are provided
Feb 24, 2020 08:41:07 PM INFO not checking for touchID
Feb 24, 2020 08:41:07 PM DEBUG unlock called with check PIN=true
Feb 24, 2020 08:41:07 PM DEBUG PIN code entered is correct, or there is no PIN set
Feb 24, 2020 08:41:07 PM INFO Cancelling zmAutologin timer
Feb 24, 2020 08:41:07 PM DEBUG ------> Not starting login timer for token. We will start a one time timer when we know how soon the access token will live
Feb 24, 2020 08:41:07 PM DEBUG Inside _doLogin()
Feb 24, 2020 08:41:07 PM DEBUG No need for re-captcha checks with tokens
Feb 24, 2020 08:41:07 PM DEBUG Resetting zmCookie...
Feb 24, 2020 08:41:07 PM INFO Detected token login supported
Feb 24, 2020 08:41:07 PM INFO Access token still has 107 minutes left, using it
Feb 24, 2020 08:41:07 PM INFO ----> Setting token re-login after 6420 seconds
Feb 24, 2020 08:41:07 PM DEBUG auth-success broadcast:Successful
Feb 24, 2020 08:41:07 PM DEBUG _doLogoutAndLogin: Clearing cookies
Feb 24, 2020 08:41:07 PM INFO Adding to chain stack: 
Feb 24, 2020 08:41:07 PM INFO Fallback of zmtilen.duckdns.org is 
Feb 24, 2020 08:41:07 PM INFO reached end of chain loop
Feb 24, 2020 08:41:07 PM INFO No need to do a reachability test, as there are no fallbacks
Feb 24, 2020 08:41:07 PM INFO No need for logout!
Feb 24, 2020 08:41:07 PM DEBUG Inside _doLogin()
Feb 24, 2020 08:41:07 PM DEBUG No need for re-captcha checks with tokens
Feb 24, 2020 08:41:07 PM DEBUG Resetting zmCookie...
Feb 24, 2020 08:41:07 PM INFO Detected token login supported
Feb 24, 2020 08:41:07 PM INFO Access token still has 107 minutes left, using it
Feb 24, 2020 08:41:07 PM INFO ----> Setting token re-login after 6420 seconds
Feb 24, 2020 08:41:07 PM DEBUG auth-success broadcast:Successful
Feb 24, 2020 08:41:07 PM DEBUG PortalLogin: auth success
Feb 24, 2020 08:41:07 PM DEBUG getAPIversion called with 
Feb 24, 2020 08:41:07 PM DEBUG returning promise
Feb 24, 2020 08:41:07 PM DEBUG CACHE: NOT found for:cached_api_version reverting to HTTP
Feb 24, 2020 08:41:07 PM DEBUG CACHE: storing key data in cache now, with expiry of 86400
Feb 24, 2020 08:41:07 PM DEBUG snapshot  supported in image.php
Feb 24, 2020 08:41:07 PM DEBUG obfuscate: original:9298 obfuscated:2449 scheme:lzs
Feb 24, 2020 08:41:07 PM DEBUG Setting server version to:1.34.3
Feb 24, 2020 08:41:07 PM DEBUG getAPI version succeeded with 1.34.3
Feb 24, 2020 08:41:07 PM INFO Got API version: 1.34.3
Feb 24, 2020 08:41:07 PM INFO First invocation of TimeZone, asking server
Feb 24, 2020 08:41:07 PM DEBUG returning promise
Feb 24, 2020 08:41:07 PM INFO EventSever: Initializing Websocket with URL wss://192.168.1.20:9001
Feb 24, 2020 08:41:07 PM DEBUG EventSever: Using native websockets...
Feb 24, 2020 08:41:07 PM DEBUG Transitioning state to: app.events with param {}
Feb 24, 2020 08:41:07 PM INFO getMonitors:Loading all monitors
Feb 24, 2020 08:41:07 PM INFO Checking value of ZM_MIN_STREAMING_PORT for the first time
Feb 24, 2020 08:41:07 PM DEBUG returning promise
Feb 24, 2020 08:41:07 PM DEBUG resize/orient: 375(w) * 768(h)
Feb 24, 2020 08:41:07 PM DEBUG CACHE: NOT found for:cached_timezone reverting to HTTP
Feb 24, 2020 08:41:07 PM DEBUG CACHE: NOT found for:cached_multi_port reverting to HTTP
Feb 24, 2020 08:41:07 PM DEBUG Real value of PRIVACY is:0
Feb 24, 2020 08:41:07 PM DEBUG CACHE: storing key data in cache now, with expiry of 86400
Feb 24, 2020 08:41:07 PM DEBUG Timezone API response is:Europe/Berlin
Feb 24, 2020 08:41:07 PM DEBUG EventSever: WebSocket open called with:{"webSocketId":"5CDBC7B7-8A6D-4BF2-B1D9-9FD5D8A491A8","code":1000}
Feb 24, 2020 08:41:07 PM INFO EventSever: openHandshake: Websocket open, sending Auth
Feb 24, 2020 08:41:07 PM DEBUG EventSever: sendMessage: received->{"event":"auth","data":{"user":"admin",<password removed>,"monlist":"1,2,3,4,5","intlist":"0,0,0,0,0"}}
Feb 24, 2020 08:41:07 PM DEBUG EventServer: ok to send message
Feb 24, 2020 08:41:07 PM DEBUG EventSever: Initializing FCM push
Feb 24, 2020 08:41:07 PM INFO EventSever: Setting up push registration
Feb 24, 2020 08:41:07 PM DEBUG CACHE: storing key data in cache now, with expiry of 86400
Feb 24, 2020 08:41:07 PM DEBUG Setting multi-port to:false
Feb 24, 2020 08:41:07 PM INFO ZM_MIN_STREAMING_PORT not configured, disabling
Feb 24, 2020 08:41:07 PM DEBUG ZMS Multiport reported: 0
Feb 24, 2020 08:41:07 PM DEBUG Monitor URL to fetch is:
Feb 24, 2020 08:41:07 PM DEBUG returning promise
Feb 24, 2020 08:41:07 PM DEBUG CACHE: NOT found for:cached_monitors reverting to HTTP
Feb 24, 2020 08:41:08 PM DEBUG CACHE: storing key data in cache now, with expiry of 86400
Feb 24, 2020 08:41:08 PM DEBUG CACHE: encrypting request
Feb 24, 2020 08:41:08 PM DEBUG obfuscate: original:10979 obfuscated:2546 scheme:lzs
Feb 24, 2020 08:41:08 PM DEBUG Before duplicate processing, we have: 5 monitors
Feb 24, 2020 08:41:08 PM DEBUG After duplicate processing, we have: 5 monitors
Feb 24, 2020 08:41:08 PM DEBUG Loading hidden/unhidden status for profile:
Feb 24, 2020 08:41:08 PM DEBUG Inside getMonitors, will also regen connkeys
Feb 24, 2020 08:41:08 PM DEBUG Now trying to get multi-server data, if present
Feb 24, 2020 08:41:08 PM DEBUG returning promise
Feb 24, 2020 08:41:08 PM INFO Monitor load was successful, loaded 5 monitors
Feb 24, 2020 08:41:08 PM DEBUG CACHE: NOT found for:cached_multi_servers reverting to HTTP
Feb 24, 2020 08:41:08 PM DEBUG CACHE: storing key data in cache now, with expiry of 86400
Feb 24, 2020 08:41:08 PM DEBUG CACHE: encrypting request
Feb 24, 2020 08:41:08 PM DEBUG obfuscate: original:23 obfuscated:20 scheme:lzs
Feb 24, 2020 08:41:08 PM INFO multi server list loaded
Feb 24, 2020 08:41:08 PM DEBUG Portal scheme is https, will use https for any multi-server without a protocol
Feb 24, 2020 08:41:08 PM DEBUG default multi-server protocol will be:https://
Feb 24, 2020 08:41:08 PM DEBUG No servers matched, filling defaults...
Feb 24, 2020 08:41:08 PM DEBUG Storing streaming=
Feb 24, 2020 08:41:08 PM DEBUG No servers matched, filling defaults...
Feb 24, 2020 08:41:08 PM DEBUG Storing streaming=https:
Feb 24, 2020 08:41:08 PM DEBUG No servers matched, filling defaults...
Feb 24, 2020 08:41:08 PM DEBUG Storing streaming=https://
Feb 24, 2020 08:41:08 PM DEBUG No servers matched, filling defaults...
Feb 24, 2020 08:41:08 PM DEBUG Storing streaming=https://
Feb 24, 2020 08:41:08 PM DEBUG No servers matched, filling defaults...
Feb 24, 2020 08:41:08 PM DEBUG Storing streaming=https://
Feb 24, 2020 08:41:08 PM DEBUG Loading hidden/unhidden status for profile:
Feb 24, 2020 08:41:08 PM INFO EventCtrl called with: E/MID=0 playEvent =  false
Feb 24, 2020 08:41:08 PM DEBUG >>>height of list/scrub set to 330 and 370
Feb 24, 2020 08:41:08 PM INFO Image padding digits reported as 5
Feb 24, 2020 08:41:08 PM DEBUG EventSever: sendMessage: received->{"event":"push","data":{"type":"badge","badge":0}}
Feb 24, 2020 08:41:08 PM DEBUG EventSever: Connection not yet authenticated, adding message to queue
Feb 24, 2020 08:41:08 PM DEBUG Starting page refresh timer
Feb 24, 2020 08:41:08 PM DEBUG getInitialEvents called
Feb 24, 2020 08:41:08 PM DEBUG EventCtrl: grabbing # of event pages
Feb 24, 2020 08:41:08 PM DEBUG EventCtrl: grabbing events for: id=0 Date/Time:-
Feb 24, 2020 08:41:08 PM DEBUG getEvents:ken=<removed>
Feb 24, 2020 08:41:08 PM DEBUG Setting up carousel watchers
Feb 24, 2020 08:41:08 PM DEBUG We have a total of 7 and are at page=1
Feb 24, 2020 08:41:08 PM DEBUG EventCtrl: success, got 100 events
Feb 24, 2020 08:41:10 PM INFO --------->Setting up network state handlers....
Feb 24, 2020 08:41:10 PM INFO --------->Setting up global key handler...
Feb 24, 2020 08:41:27 PM DEBUG resize/orient: 375(w) * 768(h)
Feb 24, 2020 08:41:27 PM DEBUG Reloading monitors
Feb 24, 2020 08:41:27 PM INFO getMonitors:Force reloading all monitors
Feb 24, 2020 08:41:27 PM INFO sending stored ZM_MIN_STREAMING_PORT 0
Feb 24, 2020 08:41:27 PM DEBUG ZMS Multiport reported: 0
Feb 24, 2020 08:41:27 PM DEBUG Monitor URL to fetch is:htt
Feb 24, 2020 08:41:27 PM DEBUG returning promise
Feb 24, 2020 08:41:27 PM DEBUG CACHE: found for key: cached_monitors with expiry of:86400s
Feb 24, 2020 08:41:27 PM DEBUG CACHE: cached value for key:cached_monitors is good as 19 <86400
Feb 24, 2020 08:41:27 PM DEBUG CACHE: decryption requested
Feb 24, 2020 08:41:27 PM DEBUG deobfuscate: before:2546 after:10979 scheme:lzs
Feb 24, 2020 08:41:27 PM DEBUG Before duplicate processing, we have: 5 monitors
Feb 24, 2020 08:41:27 PM DEBUG After duplicate processing, we have: 5 monitors
Feb 24, 2020 08:41:27 PM DEBUG Loading hidden/unhidden status for profile:
Feb 24, 2020 08:41:27 PM DEBUG Inside getMonitors, will also regen connkeys
Feb 24, 2020 08:41:27 PM DEBUG Now trying to get multi-server data, if present
Feb 24, 2020 08:41:27 PM DEBUG returning promise
Feb 24, 2020 08:41:27 PM INFO Monitor load was successful, loaded 5 monitors
Feb 24, 2020 08:41:27 PM DEBUG CACHE: found for key: cached_multi_servers with expiry of:86400s
Feb 24, 2020 08:41:27 PM DEBUG CACHE: cached value for key:cached_multi_servers is good as 19 <86400
Feb 24, 2020 08:41:27 PM DEBUG CACHE: decryption requested
Feb 24, 2020 08:41:27 PM DEBUG deobfuscate: before:20 after:23 scheme:lzs
Feb 24, 2020 08:41:27 PM INFO multi server list loaded
Feb 24, 2020 08:41:27 PM DEBUG Portal scheme is https, will use https for any multi-server without a protocol
Feb 24, 2020 08:41:27 PM DEBUG default multi-server protocol will be:https://
Feb 24, 2020 08:41:27 PM DEBUG No servers matched, filling defaults...
Feb 24, 2020 08:41:27 PM DEBUG Storing streaming=https://
Feb 24, 2020 08:41:27 PM DEBUG Storing streaming=https://
Feb 24, 2020 08:41:27 PM DEBUG No servers matched, filling defaults...
Feb 24, 2020 08:41:27 PM DEBUG Storing streaming=https://
Feb 24, 2020 08:41:27 PM DEBUG No servers matched, filling defaults...
Feb 24, 2020 08:41:27 PM DEBUG Storing streaming=https://
Feb 24, 2020 08:41:27 PM DEBUG Storing streaming=https://
Feb 24, 2020 08:41:27 PM DEBUG Loading hidden/unhidden status for profile:
Feb 24, 2020 08:41:27 PM DEBUG getInitialEvents called
Feb 24, 2020 08:41:27 PM DEBUG EventCtrl: grabbing # of event pages
Feb 24, 2020 08:41:27 PM DEBUG EventCtrl: grabbing events for: id=0 Date/Time:-
Feb 24, 2020 08:41:27 PM DEBUG getEvents:https://
Feb 24, 2020 08:41:27 PM DEBUG We have a total of 7 and are at page=1
Feb 24, 2020 08:41:27 PM DEBUG EventCtrl: success, got 100 events
Feb 24, 2020 08:41:38 PM DEBUG Reloading monitors
Feb 24, 2020 08:41:38 PM INFO getMonitors:Force reloading all monitors
I have two tokens, one has 1,2,3,4 , another 1,2,3,4,5 . Have added 5 to the first, with no effect

User avatar
asker
Posts: 1305
Joined: Sun Mar 01, 2015 12:12 pm

Re: zmNinja - Android push notifications not working

Post by asker » Mon Feb 24, 2020 9:44 pm

warcanoid wrote:
Mon Feb 24, 2020 8:43 pm

I have two tokens, one has 1,2,3,4 , another 1,2,3,4,5 . Have added 5 to the first, with no effect
Please don't post in a thread that is not related to your issue. In your case, check that 5 is enabled in zmNinja ES settings for that client.
--
My collection of ZoneMinder learnings:
https://wiki.zoneminder.com/Various_ZM_thoughts

warcanoid
Posts: 20
Joined: Mon Feb 17, 2020 3:22 pm

Re: zmNinja - Android push notifications not working

Post by warcanoid » Mon Feb 24, 2020 9:50 pm

Sorry, I did not want to open another thread and mess up the forum. In apps are enabled 1,3,4,5 . I have disabled the 2 monitor. I think token wont refresh? And iphone can not connect to ES? Why can ipad connect? Hmmm

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests