[SOLVED] IPCAM D-Link DCS-4602EV

Forum for questions and support relating to the 1.28.x releases only.
Post Reply
rockandroller
Posts: 50
Joined: Tue Dec 22, 2015 12:44 am

[SOLVED] IPCAM D-Link DCS-4602EV

Post by rockandroller » Thu Jan 28, 2016 9:47 pm

Just installed 1.28 on CentOS7, and all looks fine with the basic install.

Image

Testing first of my two D-link DCS-4602EV cameras ...
The camera views just fine in a web-browser and needs no auth, just plain the url http://192.168.0.1/video1.mjpg comes up fine.

So... in ZM web interface, adding monitor, using most basic default setting for html, it adds but comes up in Orange and when I view it, just shows a blue window for video.

System logs showing long stream of this error message repeating couple times a second...

Code: Select all

Date/Time Component	PID	Level	Message	File	Line
2016-01-28 13:29:03.298190	zmc_m1	3118	ERR	Unable to get response	/builddir/build/BUILD/ZoneMinder-1.28.1/src/zm_remote_camera_http.cpp	1176
2016-01-28 13:29:03.297231	zmc_m1	3118	ERR	Failed authentication:	/builddir/build/BUILD/ZoneMinder-1.28.1/src/zm_remote_camera_http.cpp	763
Tried with all the various methods and protocols, but no improvement.
Is "authentication" referring to the camera stream, or is it a file permission somewhere?

The cameras own web-config interface requires a login, but none is needed to view the actual video stream
(http://192.168.0.1/video1.mjpg works fine in the web browser of the machine that ZM is installed on).

I even attempted changing the HOST setting to the camera's web-config auth of user:password@192.168.0.1 but the ZM interface balked at that, saying "don't add http: to the hostname" - when actually I was not adding http...
Last edited by rockandroller on Thu Jan 28, 2016 10:24 pm, edited 3 times in total.

rockandroller
Posts: 50
Joined: Tue Dec 22, 2015 12:44 am

Re: IPCAM D-Link DCS-4602EV

Post by rockandroller » Thu Jan 28, 2016 9:57 pm

monitor.png
monitor.png (24.94 KiB) Viewed 5599 times
here's a look at current settings... ( and if I choose greyscale, I get a black screen instead of blue... )
Last edited by rockandroller on Fri Jan 29, 2016 12:49 am, edited 2 times in total.

rockandroller
Posts: 50
Joined: Tue Dec 22, 2015 12:44 am

Re: [SOLVED] IPCAM D-Link DCS-4602EV

Post by rockandroller » Thu Jan 28, 2016 10:21 pm

Well, well, well...

turns out that the ZM web-interface wasn't accepting my auth, due to PUNCTUATION in the camera admin password. (oops!)
And apparently, the auth IS needed - but the web interface is rejecting punctuation in the remote host name field

Went into camera controller and changed the camera's admin password to one with only alpha-numerics, and then used "user:passwd@IPaddress" as the remote host name, and now I'm getting the video feed in my Monitor :D

goberreuter
Posts: 2
Joined: Wed Feb 17, 2016 1:23 am

Re: [SOLVED] IPCAM D-Link DCS-4602EV

Post by goberreuter » Wed Feb 17, 2016 1:25 am

Hi rockandroller, can you please tell me how has this camera been working, after you fixed the password issue? I am planning on building ZoneMinder + 8 DCS-4602EV cameras, and am looking for recommendation ;)

rockandroller
Posts: 50
Joined: Tue Dec 22, 2015 12:44 am

Re: [SOLVED] IPCAM D-Link DCS-4602EV

Post by rockandroller » Thu Feb 18, 2016 10:47 pm

Well, I am still in early development phase ( haven't bought the other five cameras, nor installed anything permanently yet. )

But so far, no issues with the two 460EV2s

goberreuter
Posts: 2
Joined: Wed Feb 17, 2016 1:23 am

Re: [SOLVED] IPCAM D-Link DCS-4602EV

Post by goberreuter » Thu Feb 18, 2016 11:56 pm

ok, I think I am going to try it, and check if I am able to get the H.264 stream working. thanks!

User avatar
iconnor
Posts: 1041
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: [SOLVED] IPCAM D-Link DCS-4602EV

Post by iconnor » Tue Feb 23, 2016 1:55 pm

Yes, this is on my todo list, fixing the punctuation in the url field. Glad you got through it.

One thing to note is that 32bit instead of 24bit will likely get you better performance.

rockandroller
Posts: 50
Joined: Tue Dec 22, 2015 12:44 am

Re: [SOLVED] IPCAM D-Link DCS-4602EV

Post by rockandroller » Sat Mar 12, 2016 1:08 am

One bit of DCS-4602EV trivia, I found with the D-link panel video MODE setting on type "H264", I was actually only getting one FPS in my stream.
When I changed mode to JPG, now I get the correct 15FPS ... (as I have it set in the "Maximum Frame Rate")

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests