v1.28.0->v1.28.1 upgrade issues

Forum for questions and support relating to the 1.28.x releases only.
Post Reply
sgn
Posts: 68
Joined: Mon Oct 25, 2004 2:36 pm

v1.28.0->v1.28.1 upgrade issues

Post by sgn » Sun Mar 15, 2015 4:29 pm

The current source tarball (v1.28.1.tar.gz, md5sum e8b27b818e074e5739b2bad8c57671a1) will not upgrade my database to 1.28.1.

/path/bin/zmupdate.pl (from 1.28.1) says my database is already at 1.28.0. There is an update sql in /buildpath/ZoneMinder-1.28.1/db/zm_update-1.28.1.sql:

Code: Select all

ALTER TABLE Monitors MODIFY Device tinytext;
but that alone won't update the version numbers stored in the DB.

The system was built from source at 1.27.1, there were no issues upgrading up to 1.28.0 back then.

sgn
Posts: 68
Joined: Mon Oct 25, 2004 2:36 pm

Re: v1.28.0->v1.28.1 upgrade issues

Post by sgn » Sun Mar 15, 2015 11:46 pm

I was looking at McFuzz's workaround at http://www.zoneminder.com/forums/viewto ... 7&start=15

I noticed how my previous installs (Ubuntu 14.04) have installed Base.pm in /usr/local/zm/share/perl/5.18.2/ZoneMinder whereas my attempt at installing 1.28.1 on an updated Ubuntu 14.04.2 puts Base.pm in /usr/local/zm/share/perl5/ZoneMinder (i am using --prefix=/usr/local/zm during configure)

@INC includes /usr/local/zm/share/perl/5.18.2/ so the old one will be used (and everything will fail is this directory is manually removed), maybe this causes the issue? "make uninstall" from the old build-dir will actually leave the files in /usr/local/zm/share/perl/5.18.2/ZoneMinder (!).

Why won't make install change this?

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests