Kubuntu 14.04 LTS

Forum for questions and support relating to the 1.27.x releases only.
Post Reply
cyclic
Posts: 23
Joined: Mon Jan 26, 2009 7:01 pm
Location: The deep south

Kubuntu 14.04 LTS

Post by cyclic » Sat Jul 05, 2014 9:08 am

Will current release 1.27? run on Kubuntu 14.04 LTS ?
I read that Issac Connor's PPA/Package will not run on >= 13.10 due to mysql depreciations.
cyclic_redundancy_check

cyclic
Posts: 23
Joined: Mon Jan 26, 2009 7:01 pm
Location: The deep south

Re: Kubuntu 14.04 LTS

Post by cyclic » Sat Jul 05, 2014 10:54 am

I should perhaps add, I am a long term happy user of 5 years but was stuck since last rebuild with "official" kubuntu 12.04 package, warts-an-all.
Now, a "non-fsck-able" situation forces a rebuild and 14.04LTS is obvious base - and ZM-1.27+ seems obvious release...
In furture am seeking to take upgrades per new situation, as and when they arrive i.e. no cul-de-sac again.
Cheers
cyclic_redundancy_check

User avatar
iconnor
Posts: 1431
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: Kubuntu 14.04 LTS

Post by iconnor » Mon Jul 07, 2014 1:57 pm

You must use my other ppa ppa:iconnor/zoneminder-master which follows current development pre-release.

cyclic
Posts: 23
Joined: Mon Jan 26, 2009 7:01 pm
Location: The deep south

Re: Kubuntu 14.04 LTS

Post by cyclic » Wed Jul 09, 2014 12:51 pm

If the packages on ppa:iconnor/zoneminder-master are current development pre-release,
please where can I best find an assesment of their status/stability/functionality?
cyclic_redundancy_check

linuxsense
Posts: 374
Joined: Wed Nov 07, 2007 1:59 am
Location: Huntington Beach, California
Contact:

Re: Kubuntu 14.04 LTS

Post by linuxsense » Wed Jul 09, 2014 5:38 pm

I cant speak for the packages, I think his are pretty current, but IMO the development code has been more stable and higher performing than the 1.27 release by a wide margin. I wouldn't worry about using it...good stuff.

cyclic
Posts: 23
Joined: Mon Jan 26, 2009 7:01 pm
Location: The deep south

Re: Kubuntu 14.04 LTS

Post by cyclic » Thu Jul 10, 2014 2:50 pm

OK, I've gone for it. - So far:
Got "E: zoneminder: subprocess installed post-installation script returned error exit status 255"
Found no mysql-server installed - package dependancy issue? - Installed...
Then still no web portal - tried add localhost ZM_SERVER_HOST= in zm.conf - no benefit seen.
Then ln -s /etc/zm/apache.conf /etc/apache2//conf-available/zoneminder.conf ; a2enconf zoneminder ; service apache2 reload - hey presto: web interface.
Still no cams viewable at this time - cannot find the default preconfig option that was so useful.
On a different tack:
I am getting bundles of " Memory map file '/dev/shm/zm.mmap.5' should have been 896 but was instead 0 " (1 ... 5)
I remember that I used to have to play with kernel.shmall & shmmax values - is that still required?
Seen other thread on memory. - I have 4 core + hyper with 64 bit - note package is 386?
cyclic_redundancy_check

linuxsense
Posts: 374
Joined: Wed Nov 07, 2007 1:59 am
Location: Huntington Beach, California
Contact:

Re: Kubuntu 14.04 LTS

Post by linuxsense » Thu Jul 10, 2014 6:32 pm

I am not completely sure from your post, but you got the mySQL issue worked out?

Any particular reason you are not running a x86_64 build? With multiple HD cams you will want to be able to use all the memory you can. Is your host system a 32 or 64 bit version of Kubuntu?

Biggus
Posts: 96
Joined: Mon Nov 18, 2013 9:15 am

Re: Kubuntu 14.04 LTS

Post by Biggus » Tue Jul 15, 2014 5:15 pm

Hi,

I've installed Ubuntu server 14.04 and installed Zoneminder from the ppa:iconnor/zoneminder-master it all works but I get no image when I view my cameras, am I missing something?

Biggus
Posts: 96
Joined: Mon Nov 18, 2013 9:15 am

Re: Kubuntu 14.04 LTS

Post by Biggus » Tue Jul 15, 2014 5:23 pm

socket_sendto( /tmp/zm/zms-820672s.sock ) failed: No such file or directory

cyclic
Posts: 23
Joined: Mon Jan 26, 2009 7:01 pm
Location: The deep south

Re: Kubuntu 14.04 LTS

Post by cyclic » Thu Aug 14, 2014 11:09 am

Was on 14.04 32bit - As unable to install 64 bit due to grub install problem.
Now on 14.04.1 64 bit Server clean install with 1.27.99 from oconnor repository
Nearly worked out of the box - just needed to fiddle with apache config
which seems to be a known problem(?)
Pity not fixed for "perfect" out of the box working installation.
Much Much better than the previous version I was on....
No major issues - 6 net cams so far - still working on the rest
Thanks to all for this and occonor for the package.
cyclic_redundancy_check

bbunge
Posts: 2720
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Kubuntu 14.04 LTS

Post by bbunge » Sun Aug 17, 2014 1:52 am

Try this:
http://www.zoneminder.com/forums/viewto ... 31&t=22477

The install is for server but you can install it on any Ubuntu version from a terminal. Be advised that you may get an error on your desktop when booting the system. Have not figured out what it is but dies not seem to bother ZM or the desktop system.

Here is another for 1.26.5 :
http://www.zoneminder.com/wiki/index.ph ... e_easy_way

About the only difference is the addition of the master PPA and the extra VLC libraries.

bb

cyclic
Posts: 23
Joined: Mon Jan 26, 2009 7:01 pm
Location: The deep south

Re: Kubuntu 14.04 LTS

Post by cyclic » Mon Aug 18, 2014 9:21 am

I will be sticking with 1.27... - its better and it works on 14.04.1 LTS
Also using "64bit server" version by choice as it is visibly faster with ZM (no X etc)
cyclic_redundancy_check

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest