Upgrade to 1.26.4?

Forum for questions and support relating to the 1.26.x releases only.
Post Reply
Magic919
Posts: 360
Joined: Wed Sep 18, 2013 6:56 am

Upgrade to 1.26.4?

Post by Magic919 » Mon Oct 07, 2013 1:50 pm

My UI seems to be prompting this, but there's no actual download available. I can grab it from Git, but is this the intention?

c128
Posts: 71
Joined: Sat Sep 14, 2013 3:36 pm

Re: Upgrade to 1.26.4?

Post by c128 » Mon Oct 07, 2013 6:54 pm

I'd be interested in knowing the procedure here too.

I'm using a Puppet install of Zoneminder, but I have tweaked some of the Puppet configured apache config for my own system.

Do you just pull the latest repo, re-run the full Puppet install and Zoneminder itself will get re-built without upsetting anything else?

lpallard
Posts: 85
Joined: Fri Mar 05, 2010 10:59 pm

Re: Upgrade to 1.26.4?

Post by lpallard » Mon Oct 07, 2013 9:24 pm

I just went to my fresh install of ZM by clicking on the "v1.26.3" version number at the top of the main page and I got:

"You are running the most recent version of ZoneMinder, v1.26.3.
No update is necessary."

SO I wonder how you guys got a notification that a new version was available?!

codabiz
Posts: 54
Joined: Sun Jan 04, 2009 10:16 am
Location: London, UK

Re: Upgrade to 1.26.4?

Post by codabiz » Mon Oct 07, 2013 9:46 pm

Check out Isaac Connor's Zoneminder work on 1.26.4 here:

https://launchpad.net/~iconnor/+archive ... /+packages

windracer
Posts: 61
Joined: Sat Jul 23, 2011 1:15 am

Re: Upgrade to 1.26.4?

Post by windracer » Tue Oct 08, 2013 1:27 am

I was getting the 1.26.4 upgrade notice as well, so I just downloaded the latest git branch and re-compiled from source.

Magic919
Posts: 360
Joined: Wed Sep 18, 2013 6:56 am

Re: Upgrade to 1.26.4?

Post by Magic919 » Wed Oct 09, 2013 10:20 am

Download has now appeared on the website.

silox
Posts: 1
Joined: Sun Aug 21, 2011 8:03 am

Re: Upgrade to 1.26.4?

Post by silox » Wed Oct 09, 2013 12:22 pm

I'm using Issac Connor's ZoneMinder PPA repo on Ubuntu Server 12.04 LTS and upgraded from 1.26.3 to 1.26.4 successfully, however there were a few issues during the upgrade process I thought I would mention here to assist others.

1.) The upgrade may fail initially because the 'db' directory cannot be found in /build/buildd/zoneminder-1.26.4. Create a symbolic link named 'db' in /build/buildd/zoneminder-1.26.4 pointing to /usr/share/zoneminder/db.

2.) It appears the upgrade script that's executed when installing the new zoneminder package via 'apt-get upgrade' changes your 'zmuser' database user password to the default 'zmpass'. I would suggest backing up your zm.conf file before installing the newer zoneminder package from the PPA repo and allow your zm.conf to be replaced with the newer version when prompted during the upgrade. After the upgrade has completed successfully, stop ZM, edit the new zm.conf to reflect your original DB user pass you set, change the DB user's password to the same and then start ZM again.

Hope this helps!

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests