ERR socket_sendto connection refused

Forum for questions and support relating to the 1.25.x releases only.
Post Reply
ciscoswitch
Posts: 1
Joined: Tue Jan 15, 2013 5:16 am

ERR socket_sendto connection refused

Post by ciscoswitch » Tue Jan 15, 2013 5:37 am

Hi,

I've searched all the forums and tried all the solutions that I could find on this problem, and have not been successful. The full error message that I see in the apache access file is: ERR [socket_sendto( /tmp/zm/zms-413454s.sock ) failed: Connection refused]. I'm not sure what else to try or to check, so was hoping that someone might be able to give me some direction as to what to do.

I'm running Zoneminder 1.25.0 on a CentOS 2.6.32-279.el6.x86_64 box. When I try to turn on streaming, by setting the method to mpeg, is when I get this error. Everything works fine with it set to jpeg. I also have eyeZM installed and that works fine as well. I seem to recall when I first setup this box that everything worked, even the mpeg streaming, but I left it setup for jpeg, and used the cambozola.jar which works fine. But, recently I was playing around with it, and set it to mpeg and noticed that it's not working, and it frustrates me. I have even tried turning off OPT_USE_AUTH and setting AUTH_RELAY to plain or none, and all the different combinations. Also, when I first started troubleshooting this, it didn't say "Connection Refused" it said that the zms-######s.sock file didn't exist, file not found. But in messing around with different solutions, and I can't remember which one, I got it to where it creates the file, but I now get the Connection refused.

PHP version is 5.3.3 and the short_open_tag is on. Apache is 2.2.15 Apache and Zoneminder are running under user apache.

Zoneminder is compiled with the following:

$ ./configure --with-webdir=/var/www/zoneminder --with-cgidir=/var/www/cgi-bin --with-webuser=apache --with-webgroup=apache ZM_DB_HOST=localhost ZM_DB_NAME=zm ZM_DB_USER=zoneminder ZM_DB_PASS=******* ZM_SSL_LIB=openssl --with-extralibs=-L/usr/lib64 -L/usr/lib64/mysql -L/usr/local/lib -lmp3lame --with-libarch=lib64 --with-ffmpeg=/usr/lib --with-mysql=/usr --with-webhost=XXXX --disable-debug --disable-crashtrace --enable-mmap

ffmpeg = 0.6.5

I have zoneminder video streams setup for .mov but I have tried using asf, mpeg, mpg, wmf, avi, swf as well.

My client computer that I'm using is a Mac running OSX 10.8.2 Mountain Lion and using Safari 6.0.2 to test with. I also have Chrome installed, but since I'm using cambozola, it doesn't work under Chrome as there is not a Java plugin for Chrome (I believe).

If there is any other information you require, let me know. It can be something really simple that I just overlooked or didn't think of to check. Though I have it working for now, I would like to get the streaming to work properly.

Thanks,

licchende
Posts: 13
Joined: Thu Aug 09, 2012 8:19 am

Re: ERR socket_sendto connection refused

Post by licchende » Wed Mar 20, 2013 8:28 pm

Hello,

at the end have you sove with this issue?
I've the same problem but just recently, may be that some upgrade make upset apache.
I've zms connection refused in apache log.
Can You or someone help me?
Thanks :)

licchende
Posts: 13
Joined: Thu Aug 09, 2012 8:19 am

Re: ERR socket_sendto connection refused

Post by licchende » Tue Mar 26, 2013 10:15 am

After several tests I've found some conditions that create this problem:
-if I meake a new fresh installation on ubuntu lts1204 al work fine
-if I clone hdd in to another disk to make a server copy all still work fine
-if I resize LVM partition to fit the new hard-disk size ( bigger ) event replay stop to work with socket connection refused error on apache log.
Have you idea why happen that?

Regards

ctimbrell
Posts: 27
Joined: Thu Apr 19, 2012 6:36 pm

Re: ERR socket_sendto connection refused

Post by ctimbrell » Sat Mar 30, 2013 8:17 pm

i had the same problem and mine was down to port numbers (using 78 as opposed to the usual 80) i therefore guess this error is essentially apache based but i wouldnt swear to it. I initially thought it was permissions but giving full access across the board to the directory in question just created more problems hence my arriving at the conclusion it is an apache setu/configuration issue

Hope this helps

licchende
Posts: 13
Joined: Thu Aug 09, 2012 8:19 am

Re: ERR socket_sendto connection refused

Post by licchende » Tue Apr 16, 2013 10:16 am

I think too that the problem is apache... but I don't understand why when I modify the LVM volume start to have this problem...
Really I can't explain that...

Torsten73
Posts: 26
Joined: Thu Sep 19, 2013 9:45 pm

Re: ERR socket_sendto connection refused

Post by Torsten73 » Fri Sep 20, 2013 5:01 pm

i also have the same error message, when using mpeg instead jpeg. I need a solution, has someone found a way to get it working?

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest