Page 1 of 1

Ubuntu 12.04 Server BT878A process crashes

Posted: Mon May 28, 2012 10:40 am
by dkellygb
I successfully installed version 1.24 on an old AMD Sempron box using Ubuntu 10.04 desktop and a Camsecure BT878A. Everything worked after using the instructions on ... x)_Desktop. to set the system up.

The system trundled along but the CPU usage was very high. I had a spare Dell Poweredge 1600sc server with dual Xeon processors which I thought might be better suited to Zoneminder.

I installed Ubuntu 12.04 and Zoneminder 1.25 from the repositories following the instructions on ... e_easy_way. The BT878A card seemed to install fine with lspci listing 01:08.0 Multimedia video controller:

Code: Select all

Brooktree Corporation Bt878 Video Capture (rev 11)
for each of the eight chips.

When I grep bttv /var/log/syslog, everything looks normal as far as I can tell.

However, when I add a monitor, I get nothing but a black screen and there are errors in the Zoneminder logs like:

Code: Select all

2012-05-28 11:04:39.367060	zmdc	1366	INF	'zmc -d /dev/video1' crashed, signal 134	
2012-05-28 11:04:39.364980	zmdc	1366	INF	'zmc -d /dev/video0' crashed, signal 134	
2012-05-28 11:04:39.130110	zmc_dvideo1	1593	PNC	Zone 2/All for monitor Reception extends outside of image dimensions, -319, 0, 0, 0	zm_zone.cpp	927
2012-05-28 11:04:39.120703	zmc_dvideo0	1591	PNC	Zone 1/All for monitor Toilets extends outside of image dimensions, -319, 0, 0, 0	zm_zone.cpp	927
2012-05-28 11:04:39.053490	zmdc	1593	INF	'zmc -d /dev/video1' started at 12/05/28 11:04:39	
2012-05-28 11:04:39.053400	zmdc	1366	INF	'zmc -d /dev/video1' starting at 12/05/28 11:04:39, pid = 1593	
2012-05-28 11:04:39.044130	zmdc	1366	INF	Starting pending process, zmc -d /dev/video1

Does anybody have any ideas what this might mean?

Re: Ubuntu 12.04 Server BT878A process crashes

Posted: Tue May 29, 2012 8:18 am
by dkellygb
Just some added information, it is Ubuntu 12.04 server 32 bit.

When I use zmu -d /dev/video0 -q -v

I get:

Error, failed to open video device /dev/video0: Success

So I tried changing permissions on /dev/video0 using "chmod 777 /dev/video0"

I re ran the zmu command and got the following output.

Code: Select all

Video Device: /dev/video0
General Capabilities
  Driver: bttv
  Card: BT878 video (IVC-200)
  Bus: PCI:0000:01:08.0
  Version: 3.2.16
  Type: 0x5000015
    Supports video capture (X)
    Does not support video output
    Supports frame buffer overlay
    Supports VBI capture
    Does not support VBI output
    Does not support sliced VBI capture
    Does not support sliced VBI output
    Does not support video output overlay
    Does not have tuner
    Does not have audio in and/or out
    Does not have radio
    Supports read/write i/o (X)
    Does not support async i/o
    Supports streaming i/o (X)
    8 bpp, gray (GREY)
    8 bpp, dithered color (HI24)
    15 bpp RGB, le (RGBO)
    15 bpp RGB, be (RGBQ)
    16 bpp RGB, le (RGBP)
    16 bpp RGB, be (RGBR)
    24 bpp RGB, le (BGR3)
    32 bpp RGB, le (BGR4)
    32 bpp RGB, be (RGB4)
    4:2:2, packed, YUYV (YUYV)
    4:2:2, packed, YUYV (YUYV)
    4:2:2, packed, UYVY (UYVY)
    4:2:2, planar, Y-Cb-Cr (422P)
    4:2:0, planar, Y-Cb-Cr (YU12)
    4:2:0, planar, Y-Cr-Cb (YV12)
    4:1:1, planar, Y-Cb-Cr (411P)
    4:1:0, planar, Y-Cb-Cr (YUV9)
    4:1:0, planar, Y-Cr-Cb (YVU9)
Crop Capabilities
  Bounds: 1063 x 608
  Default: 924 x 576
  Current: 924 x 576
Inputs: 1
  Input 0
    Name: Composite0
    Type: Camera
    Audioset: 00000001
    Standards: 0xffbfff
    Power on  (X)
    Signal not detected  (X)
    Colour Signal detected
    Horizontal Lock not detected
I thought that the chmod might have made a difference but still black screen. Perplexing as this card worked fine under 10.04.

Re: Ubuntu 12.04 Server BT878A process crashes

Posted: Tue May 29, 2012 1:18 pm
by B F
I believe the crashed reports in the log are because the zone you have defined has dimensions outside that of the image source. However I don't believe this is why you get a black screen. I don't know the Camsecure BT878A but perhaps the Device Channel is not set correctly (under the Source tab) or the Capture Palette is incorrect? Alternatively maybe it's just coincidence and the feed from your camera is dead?

Re: Ubuntu 12.04 Server BT878A process crashes

Posted: Wed May 30, 2012 6:04 pm
by dkellygb
Thank you very much for the useful information. Although the cameras were not the problem, your advice helped me led me down the right road to sorting out the problem.

I thought ZoneMinder was the problem (I have six) because I tried to configure my first two cameras on Video0 and Video1. Those two channels did not work. After your suggestion, I thought that I should check all of the six cameras just in case that there is a problem with the first two cameras. I don't know how a camera problem would cause a process to crash but just in case, I decided to configure all six of my cameras.

Well the cameras on video2, 3 and 5 worked. The camera on video4 had the same symptoms as 0 and 1. I then swapped the camera on video2 to video0 and video2 continued to work with the camera which was on video0.

Thus, it seems that all my cameras work.

I decided to review (again) the set up under the source tab of the monitor set up. I carefully compared them all and they were all the same. Three video channels were working and three were not. I verified that I used the same set up on all the cameras.

Although I had not made any changes from the defaults for the zones on any of these cameras, taking a clue from the logs above, I decided to delete the existing zones on the non-working cameras and recreate them. Voila, the cameras started working.

The process crashes were caused by something flaky in the default zones for three of the cameras. What is was, I do not know. Why only three random cameras? Your guess is as good as mine.