The problem with the transmission SWF ffmpeg

Forum for questions and support relating to the 1.24.x releases only.
Post Reply
sezamnet
Posts: 20
Joined: Mon Sep 21, 2009 11:20 am
Location: Poland

The problem with the transmission SWF ffmpeg

Post by sezamnet » Sat Apr 17, 2010 5:38 pm

hi, I have a problem running the ffmpeg video swf.
My card is a Conexant 878A, Sony camera is 420 lines maximum resolution of 512x582 is four cameras for the other is 500x582, OpenSUSE system, 4GB of RAM ...

Four cameras are working correctly at a resolution of 384x288 but not at higher.
(Video0, video4, video6, video7)

Four cameras are working at 320x240 resolution but with higher not work.
(VIDEO2, video1, video3, video5)

When a higher resolution than I gave above and white image error in the logs.

[Sat Apr 17 19:19:42 2010] [error] [client 80.xx.xxx.x] socket_sendto( /tmp/zms-983573s.sock ) failed: No such file or directory, referer: http://79.xxx.xx.xx/zm/index.php?view=watch&mid=1
[Sat Apr 17 19:19:42 2010] [error] [client 80.xx.xxx.x] array (\n 0 => \n array (\n 'file' => '/srv/www/htdocs/zm/ajax/stream.php',\n 'line' => 51,\n 'function' => 'ajaxError',\n 'args' => \n array (\n 0 => 'socket_sendto( /tmp/zms-983573s.sock ) failed: No such file or directory',\n ),\n ),\n 1 => \n array (\n 'file' => '/srv/www/htdocs/zm/index.php',\n 'line' => 116,\n 'args' => \n array (\n 0 => '/srv/www/htdocs/zm/ajax/stream.php',\n ),\n 'function' => 'require_once',\n ),\n), referer: http://xx.xxx.xx.xx/zm/index.php?view=watch&mid=1

on montage:
Apr 17 19:50:53 t1 zms[15169]: ERR [Signal address is 0x206, no eip]
Apr 17 19:50:53 t1 zms[15169]: ERR [Backtrace: /lib64/libpthread.so.0 [0x7f9429d86a90]]
Apr 17 19:50:53 t1 zms[15169]: ERR [Backtrace: /lib64/libc.so.6(gsignal+0x35) [0x7f9428c99645]]
Apr 17 19:50:53 t1 zms[15169]: ERR [Backtrace: /lib64/libc.so.6(abort+0x183) [0x7f9428c9ac33]]
Apr 17 19:50:53 t1 zms[15169]: ERR [Backtrace: /srv/www/cgi-bin/nph-zms [0x40f1cb]]
Apr 17 19:50:53 t1 zms[15169]: ERR [Backtrace: /srv/www/cgi-bin/nph-zms [0x42d799]]
Apr 17 19:50:53 t1 zms[15169]: ERR [Backtrace: /srv/www/cgi-bin/nph-zms [0x4230ef]]
Apr 17 19:50:53 t1 zms[15169]: ERR [Backtrace: /srv/www/cgi-bin/nph-zms [0x423b3d]]
Apr 17 19:50:53 t1 zms[15169]: ERR [Backtrace: /srv/www/cgi-bin/nph-zms [0x406b8f]]
Apr 17 19:50:53 t1 zms[15169]: ERR [Backtrace: /lib64/libc.so.6(__libc_start_main+0xe6) [0x7f9428c85586]]
Apr 17 19:50:53 t1 zms[15169]: ERR [Backtrace: /srv/www/cgi-bin/nph-zms [0x406339]]
Apr 17 19:50:53 t1 zms[15169]: INF [Backtrace complete]


When the transmission method is a jpeg everything works correctly at a resolution of 384x288 with a higher I do not know why the effect of horizontal lines when the object in motion.
Image
http://en.wikipedia.org/wiki/Interlace

pls help

whatboy
Posts: 304
Joined: Mon Aug 31, 2009 10:31 pm

Post by whatboy » Sat Apr 17, 2010 6:29 pm

HUH??? WTF??? you posted a pic from the wiki about INTERLACE and you DON'T KNOW WHY???

READ THE FSKING WIKI ENTRY!!!

mastertheknife
Posts: 679
Joined: Wed Dec 16, 2009 4:32 pm
Location: Israel

Post by mastertheknife » Sat Apr 17, 2010 7:19 pm

Use JPEG streaming mode only. MPEG is buggy at the moment.
For Internet Explorer support and other browsers that don't support JPEG streaming natively, you need to enable cambozola. I also recommend upgrading cambozola to latest version (replace cambozola.jar):
http://www.charliemouse.com/code/cambozola/
Here is a patch i wrote to fix ZM's auto detection to support more browsers for JPEG streaming mode:
http://www.zoneminder.com/forums/viewtopic.php?t=15429

And for the interlacing, its because your capture resolution too high.
if you don't want those weird lines, for PAL cameras, capture at no higher than 384x288 and for NTSC cameras, capture at no higher than 320x240

mastertheknife.

sezamnet
Posts: 20
Joined: Mon Sep 21, 2009 11:20 am
Location: Poland

Post by sezamnet » Sun Apr 18, 2010 12:48 am

Thanks for your reply
mastertheknife wrote:Use JPEG streaming mode only. MPEG is buggy at the moment.
It's not good, I have a low bandwidth connection. Neither version of ZoneMinder does not support the transmission method correctly?
mastertheknife wrote: For Internet Explorer support and other browsers that don't support JPEG streaming natively, you need to enable cambozola. I also recommend upgrading cambozola to latest version (replace cambozola.jar):
http://www.charliemouse.com/code/cambozola/
Here is a patch i wrote to fix ZM's auto detection to support more browsers for JPEG streaming mode:
http://www.zoneminder.com/forums/viewtopic.php?t=15429
I have no problems with the transmission of JPEG but thank you, may come in useful.
mastertheknife wrote: And for the interlacing, its because your capture resolution too high.
if you don't want those weird lines, for PAL cameras, capture at no higher than 384x288 and for NTSC cameras, capture at no higher than 320x240

mastertheknife.
I understand, but having a camera in accordance with specifications can display the image at a resolution of 512x582 (PAL) and the card 768x576 (PAL), 384x288, 192x144. there is no way to go through this restriction in ZoneMinder?
Assuming that the construction of ZoneMinder is the cause.

mastertheknife
Posts: 679
Joined: Wed Dec 16, 2009 4:32 pm
Location: Israel

Post by mastertheknife » Sun Apr 18, 2010 5:24 am

The interlacing is not because of ZoneMinder.
PAL and NTSC are interlanced formats. for example, PAL is 576 vertical lines, but it doesn't transmit them at all at once. It trasmits 288 even and then 288 odd lines, this causes the interlacing effect that you see.

By capturing at 288 vertical lines (e.g. 384x288) or less, you only capture the odd lines or the even lines.

The reason you don't see this weird effect when watching TV is because they all use a process called de-interlacing.
So for ZoneMinder, the solution is to use 384x288 for PAL or 320x240 for NTSC.
Although someone made a thread with some information on setting up deinterlacing for ZoneMinder:
http://www.zoneminder.com/forums/viewtopic.php?t=15501

Keep in mind though, that using 384x288 instead of 768x576 (or 320x240 instead of 640x480 for NTSC) requires 4 times less processing power, this is useful with many cameras especially when running in motion detect mode.

mastertheknife.

sezamnet
Posts: 20
Joined: Mon Sep 21, 2009 11:20 am
Location: Poland

Post by sezamnet » Sun Apr 18, 2010 3:54 pm

mastertheknife wrote: Although someone made a thread with some information on setting up deinterlacing for ZoneMinder:
http://www.zoneminder.com/forums/viewtopic.php?t=15501
It is possible that this solution works, but only one camera, I need for eight.

Thank you for your help in understanding the topic.

In summary:
- The maximum resolution with good image quality is 384x288
- Do not see the difference when buying a camera 420 lines 512x582 (PAL) and 500 lines 753x582 (PAL)
- MPEG transmission is not stable in ZoneMinder

If I buy a DVR I can record a picture in higher resolution?
The specification for the DVR and the TV card you can read that record an image at a resolution of 768x576, which is misleading, the person did not understand the topic.
Such as I

mastertheknife
Posts: 679
Joined: Wed Dec 16, 2009 4:32 pm
Location: Israel

Post by mastertheknife » Sun Apr 18, 2010 5:07 pm

Do not see the difference when buying a camera 420 lines 512x582 (PAL) and 500 lines 753x582 (PAL)
There is a difference in quality, the higher the TVL (lines) means better picture usually, even at 384x288.

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests