Page 1 of 1

Error Message "Mootools not found"

Posted: Wed Mar 03, 2010 5:20 pm
by mikeeyy
Hello together,

i installed zoneminder on debian 5 after this guide:

installation finsihed wihtout any problems. but if i try to access the zonminder frontend i get the message that mootools not found. i only receive this message on IE8, Firefox 3.5.8 and my Blackberry. Firefox 3.6 seems to operate. i have no idea whats the problem. an previous zonminder installation was without any problems.

i downloaded the last mootools file 1.2.4 from ( ... classes.js) and copied this in /var/www/zm as mootools.js. after then i changed the rights with chown www-data.www-data mooto*

any idea whats happen?`

Posted: Wed Mar 03, 2010 9:54 pm
by whatboy
I have this...

Code: Select all

-rwxr-xr-- 1 apache apache 96051 2010-02-04 14:02 mootools-
-rwxr-xr-- 1 apache apache 66610 2010-02-04 14:03 mootools-1.2.3-core-yc.js
lrwxrwxrwx 1 apache apache    46 2010-02-04 14:03 mootools.js -> /usr/share/zoneminder/mootools-

Posted: Thu Mar 04, 2010 4:16 pm
by mikeeyy
Hi whatboy,

thank you for your answer. where did you located the files mootools- and mootools-1.2.3-core-yc.js ?
did you set rights for mootools.js?

Posted: Thu Mar 04, 2010 6:40 pm
by whatboy

Posted: Thu Mar 04, 2010 7:29 pm
by mikeeyy
i reinstalled the hole server again.. where was no mootools.ext.js file in a zm folder. ?????

Posted: Thu Mar 04, 2010 7:51 pm
by mikeeyy
sorry.. i found mootools.ext.js in /var/www/zm/js and link it to /var/www/zm/mootools.ext.js

then i linked /var/www/zm/tools/mootools/mootools-1.2-more-yc.js to /var/www/zm/mootools.js

Posted: Mon Mar 08, 2010 11:22 am
by mikeeyy
no more tips????

Posted: Thu Apr 29, 2010 9:29 am
by Lord_Lethris
I have the same problem.

Zoneminder has been working for months, with no issues.

Then suddenly, and for no known reason, one morning it throws up
  • "Mootools not found, download from and install in zoneminder root"
My Zoneminder server ISNT on the web, so no updates have been installed to Ubuntu or Zoneminder. Noone has tampered with it eather (or I'd know about it ;) )

It still captures though. as the "..\events\1" directory is still filling up with images, its only the web administration thats fubar'd.

Just dont understand what happened.

Any fixes? Will it happen again?

Posted: Fri Apr 30, 2010 1:53 pm
by ZonerBoner
Same Problem here. ZM has worked fine for a month; this morning suddenly mootools is missing. What is the fix?

I am using the vmware appliance.

Posted: Mon May 17, 2010 6:20 am
by ChristopheDavid
Same problem here too, using Firefox 3.6.3 / Ubuntu 10/04.
No change made to ZoneMinder for months.

The problem is intermittent: when refreshing the events page every minute (using the "tab mix plus" Firefox extension), it occurs about once an hour. That never happened "before".


There is also another "new" error, that might be related to this issue : the server ***sometimes*** returns

>>> Bad Request

>>> Your browser sent a request that this server could not understand.
>>> Request header field is missing ':' separator.

>>> cache

>>> Apache/2.2.14 (Ubuntu) Server at localhost Port 443

That never happened "before" either.

Any help would be appreciated.


Posted: Tue May 25, 2010 7:33 pm
by freak
I get the same error intermittently. Running zm 1.24.2. Everything seems to work fine though.

Posted: Thu Jun 24, 2010 2:19 pm
by PatMcLJr
me 2

zm's been up for months with only a few issues, today it started spitting up this error. I rebooted the box and it's gone now.

It's got ubuntu 9.04 on it now but I'm getting ready to reinstall with fedora 13 LXDE

Pat Jr.

Re: Error Message "Mootools not found"

Posted: Thu May 02, 2019 6:44 pm
by BobLaske
All you people saying the same thing but not one person took the time to come back and explain what happened and/or how to fix it? :).

It's now 2019, I'm running 1.32... I think since I cannot see the dashboard as I am also getting this error.

Now my dashboard won't even come up and no idea what suggestions to use searching google since so many are old posts.