got only gray image on pico2000 card

Post here to ask any questions about hardware suitability, configuration in ZoneMinder, or experiences. If you just want to know if something works with ZoneMinder or not, please check the Hardware Compatibility sections in the forum, and the Wiki first. Also search this topic as well.
Post Reply
hellvy
Posts: 5
Joined: Tue Oct 04, 2005 7:16 pm

got only gray image on pico2000 card

Post by hellvy » Tue Oct 04, 2005 7:47 pm

Hello, i'm using CTU 3.67 distribution. My hardware is
PIII 933, 128MB
Pico2000 capture card (like this one)
LYD-808C CCD camera

My problem is, i can't get color image from this camera. When i try capture palette other than grey, the stream image will freeze and camera list turn red. Tried all channel. I also have another b/w camera, there's no differnece i connect them together or not.
I've tried this card&camera on windows xp, it work and has color with PAL setting.
One thing catched me is, when i do zmu -d -q-v, i got this info
# /usr/lib/zm/bin/zmu -d /dev/video0 -q -v
Video Capabilities
Name: BT878 video (MATRIX-Vision MV-D
Type: 171
Can capture
Can tune
Overlay onto frame buffer
Can clip
Scalable
Video Channels: 5
Audio Channels: 1
Maximum Width: 924
Maximum Height: 576
Minimum Width: 48
Minimum Height: 32
Window Attributes
X Offset: 0
Y Offset: 0
Width: 320
Height: 240
Picture Attributes
Palette: 1 - Linear greyscale
Colour Depth: 8
Brightness: 32768
Hue: 32768
Colour :32768
Contrast: 32768
Whiteness: 0
why zmu detect palette as only Linear greyscale?
Anybody has experienced or sugesstion on this problem?
Here's my modprobe.conf
# cat /etc/modprobe.conf
alias eth0 e100
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
alias char-major-81 bttv
alias usb-controller uhci-hcd
options bttv card=45 radio=0 tuner=-1
thank you.

jameswilson
Posts: 5111
Joined: Wed Jun 08, 2005 8:07 pm
Location: Midlands UK
Contact:

Post by jameswilson » Tue Oct 04, 2005 8:22 pm

its not a pico.
Add
options bttv card=77
to you modeprobe.conf and reboot

James

User avatar
cordel
Posts: 5210
Joined: Fri Mar 05, 2004 4:47 pm
Location: /USA/Washington/Seattle
Contact:

Post by cordel » Wed Oct 05, 2005 12:17 am

Yep go with James on that. That card type is norm card=77
Regards,
Cordel

jameswilson
Posts: 5111
Joined: Wed Jun 08, 2005 8:07 pm
Location: Midlands UK
Contact:

Post by jameswilson » Wed Oct 05, 2005 12:21 am

woohoo I got one right lol
Cheers Cordel

James

hellvy
Posts: 5
Joined: Tue Oct 04, 2005 7:16 pm

Post by hellvy » Wed Oct 05, 2005 12:38 pm

well.. it works now. I can get color image from color camera without changing any config. May be it's hardware glitch or misconfigured zm. I'll try to reinstall and start setting it from scratch to make sure it always work.

I think this card is OEMed so it may has many names. I've tried card=77 before and it's not working so i changed to 45 after read some threads around here and still not work. Now it's working, changing from 45 to 77 back and forth make no difference.

Another problem though, how can i know maximum resulotion for each camera? My ccd camera manual say validity pixel:PAL 512X582, definition:380 line. It works fine on current 320X240 reso. I've tried 512X582 reso. and it's not work. For 380line i don't know the matched vertical resolution for this. I'll try to random it out, but just in case anyone tried it so it save my time :)

thank you all you guys:)

jameswilson
Posts: 5111
Joined: Wed Jun 08, 2005 8:07 pm
Location: Midlands UK
Contact:

Post by jameswilson » Wed Oct 05, 2005 4:43 pm

you can run this card at 720 x 576 but if it fails its more likeley a shared mem problem, but try that and see what your logs say.

Be carefull though if you go above 288 vert res you will get interlace comb effect and i cant get round this as yet.

James

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests