OV511 chip doesn't work with 2.6.11 :(

Post here to ask any questions about hardware suitability, configuration in ZoneMinder, or experiences. If you just want to know if something works with ZoneMinder or not, please check the Hardware Compatibility sections in the forum, and the Wiki first. Also search this topic as well.
Post Reply
gungner
Posts: 35
Joined: Tue Feb 08, 2005 8:24 pm

OV511 chip doesn't work with 2.6.11 :(

Post by gungner » Tue May 17, 2005 6:08 am

I just upgraded to Mandriva 2005 which comes with kernel 2.6.11 and my USB cameras doesn't work any more :( I found this :

"ov511-2.28 driver does not work under linux 2.6.11 for three reasons: 1. remap_page_range does not exist (The log message is \"ov511: Unknown symbol remap_page_range\") 2. USB parameters idProduct and idVendors are kept in little endian format (previous kernels converted those data in cpu format) 3. usb_unlink_urb is deprecated (messages and stack dumps on the logs), usb_kill_urb must be used instead for synchronous streams. 1. and 3. affect all the systems while 2. appears only on Big Endian computers (with log error messages like: \"Unknown product ID 0x1105\"). I wrote a patch, see http://www.bononia.it/~renzo/keap/ Please insert the patch in the mainstream. Do not forget to put a tiny \"credit\" for the bugfix."

I'm a bit stuck now what to do, is it to recompile the driver and install the new one. Anyone done it already?'

cheers, tord

hrabe
Posts: 47
Joined: Tue Apr 12, 2005 12:01 am

Post by hrabe » Tue May 17, 2005 9:40 am

I have 2.6.11.8 kernel and driver ov511 (with Creative Labs WebCam 3) works fine.
Martin

gungner
Posts: 35
Joined: Tue Feb 08, 2005 8:24 pm

Post by gungner » Tue May 17, 2005 4:40 pm

That's good to know, thanks. When I plug my creative webcam III I get the following from dmesg.

3rdparty/ov511/ov511_core.c: USB OV511 video device found
3rdparty/ov511/ov511_core.c: model: Creative Labs WebCam 3 (id=21)
3rdparty/ov511/ov511_core.c: Device at usb-0000:00:10.1-1 registered to minor 0
kobject_register failed for ov511 (-17)
[<c0103c8e>] dump_stack+0x1e/0x20
[<c02143fb>] kobject_register+0x5b/0x70
[<c0281e51>] bus_add_driver+0x71/0xd0
[<c02824c1>] driver_register+0x31/0x40
[<f883816a>] usb_register+0x4a/0xb0 [usbcore]
[<f8c66013>] usb_ov511_init+0x13/0x36 [ov511]
[<c018a952>] sys_init_module+0x1e2/0x270
[<c0102e5d>] sysenter_past_esp+0x52/0x75
usbcore: error -17 registering driver ov511

/var/log/message gives:

May 17 18:35:43 srv kernel: 3rdparty/ov511/ov511_core.c: USB OV511 video device found
May 17 18:35:43 srv kernel: 3rdparty/ov511/ov511_core.c: model: Creative Labs WebCam 3 (id=21)
May 17 18:35:43 srv kernel: 3rdparty/ov511/ov511_core.c: Device at usb-0000:00:10.1-1 registered to minor 0
May 17 18:35:44 srv kernel: kobject_register failed for ov511 (-17)
May 17 18:35:44 srv kernel: [pg0+947761171/1068971008] usb_ov511_init+0x13/0x36 [ov511]
May 17 18:35:44 srv kernel: [<f8c66013>] usb_ov511_init+0x13/0x36 [ov511]
May 17 18:35:44 srv kernel: usbcore: error -17 registering driver ov511

It just doesn't work after the upgrade. How you upgraded or installed from scratch?

cheers,tord

hrabe
Posts: 47
Joined: Tue Apr 12, 2005 12:01 am

Post by hrabe » Tue May 17, 2005 7:14 pm

I have vanilla kernel from source with no patch.

dmesg:

drivers/usb/media/ov511.c: USB OV511 video device found
drivers/usb/media/ov511.c: model: Creative Labs WebCam 3
drivers/usb/media/ov511.c: Sensor is an OV7610
drivers/usb/media/ov511.c: Device at usb-0000:00:0f.2-2 registered to minor 6
usbcore: registered new driver ov511
drivers/usb/media/ov511.c: v1.64 for Linux 2.5 : ov511 USB Camera Driver

Martin

gungner
Posts: 35
Joined: Tue Feb 08, 2005 8:24 pm

Post by gungner » Wed May 18, 2005 6:03 am

thanks, I think I'm using version 2.28 which seems to differ from your setup. I'll try "downgrade" and see how it goes.

cheers, tord

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests