How to preload library for webcam

Post here to ask any questions about hardware suitability, configuration in ZoneMinder, or experiences. If you just want to know if something works with ZoneMinder or not, please check the Hardware Compatibility sections in the forum, and the Wiki first. Also search this topic as well.
Post Reply
athoopen
Posts: 13
Joined: Sun Jun 14, 2009 2:48 pm
Location: Almere

How to preload library for webcam

Post by athoopen » Sun Jun 14, 2009 3:09 pm

All,
I'm running on opensuse 11.1 and it seems from opensuse documentation that some webcams don't work with the gspca drivers within the kernel.
There is a work around (described in http://en.opensuse.org/HCL/Web_Cameras): preloading the libv4l-compat library.
This works for me (checked with kopete) but what do I need to do to preload the lib within ZoneMinder.

FYI:

Code: Select all

$ zmu -d /dev/video0 -q 
N:Camera,T:1,nC:1,nA:0,mxW:352,mxH:288,mnW:48,mnH:32,X:0,Y:0,W:320,H:240,P:0,D:8,B:0,h:0,Cl:0,Cn:0,w:0,n0:spca561,C0:0,Fl0:
$lsusb
Bus 001 Device 004: ID 046d:092f Logitech, Inc. QuickCam Express Plus
$uname -a
Linux Schuur 2.6.27.23-0.1-pae #1 SMP 2009-05-26 17:02:05 -0400 i686 i686 i386 GNU/Linux
$
TIA
Arjan ten Hoopen

User avatar
rdmelin
Posts: 863
Joined: Wed Oct 29, 2003 2:23 pm
Location: Ellensburg, WA USA

Post by rdmelin » Sun Jun 14, 2009 11:43 pm

See user azir's post in this thread
http://www.zoneminder.com/forums/viewto ... 3462#53462

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 15 guests