Solved: Reolink RLC-420 smearing with ffmpeg

A place for discussion of topics that are not specific to ZoneMinder. This could include Linux, Video4Linux, CCTV cameras or any other topic.
Post Reply
Posts: 1
Joined: Tue Mar 03, 2020 7:06 pm

Solved: Reolink RLC-420 smearing with ffmpeg

Post by zooder » Tue Mar 03, 2020 7:22 pm

For some reason, I've been getting terrible smearing and artefacts trying to use the RTSP streams with FFMPEG from the Reolink RLC-420 cameras.

It seemed to work ok if I used the older 'Remote' zoneminder monitor mode, but this method doesn't allow mp4 pass through with audio.

So after much trial and error, I've managed to get FFMPEG mp4 pass through with audio working glitch free with this camera by using the RTMP stream that these cameras have. It's not well documented, but the Clear/Balanced & Fluent (high med low quality) streams are all available. ... -v1.61.pdf

Preview URL:

hopefully this might be useful for anyone trying to set these cameras up.

Posts: 3
Joined: Mon Dec 16, 2019 4:36 am
Location: Huntington

Re: Solved: Reolink RLC-420 smearing with ffmpeg

Post by endtyranny » Fri May 29, 2020 5:18 am

i remember seeing this solution in some blog. i think the shinobee blog

Posts: 7
Joined: Sat Jun 06, 2020 9:48 pm

Re: Solved: Reolink RLC-420 smearing with ffmpeg

Post by dmac » Mon Jun 22, 2020 1:06 am

Can you please post your configuration? I am not able to get RTMP working with zone minder.

The URL works with VLC but fails in zone minder... Using a packet sniffer and it seems it is trying to use the RTSP port, even with the RTMP url (even manually adding the correct port number to the URL does not work).


Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest