Reolink RLC-410 Data Streams

Post here to indicate any hardware you have used and which is known to work with ZoneMinder. Not for questions.
diode
Posts: 10
Joined: Sun Jan 27, 2019 5:08 am

Re: Reolink RLC-410 Data Streams

Post by diode » Thu Feb 21, 2019 4:52 am

Anyone else having any issues with alarm triggering and recording with the reolink cameras? I can record a streaming event just fine, but when I try and set up the feed for a modect sometimes the alarm will record just fine and other times the image will freeze half way through and then catch up towards the end. I have plenty of memory (16GB with only 5 cameras) and the load never exceeds 4.0 on a 12 process CPU. I'm trying to play with the h.264 profiles in the reolink encoder settings to see if that will help at all, but I figured I'd reach out in the meantime to see if anyone cares to share their camera and ZM settings that are working for them.

camboi
Posts: 3
Joined: Tue Nov 06, 2018 11:24 am

Re: Reolink RLC-410 Data Streams

Post by camboi » Wed Mar 06, 2019 12:07 pm

TheSwert wrote:
Fri Dec 14, 2018 4:46 pm
One thing I had to do to make all of my Reolink camera stop smearing is to use the RTMP urls. They're not well documented, but it solved my smearing issues.

https://reolink.com/wp-content/uploads/ ... -v1.61.pdf

Example for sub stream and main stream below. You set those to be your source path and then set the method to TCP.

Sub stream:

Code: Select all

rtmp://192.168.1.100/bcs/channel0_sub.bcs?channel=0&stream=0&user=admin&password=password
Main Stream:

Code: Select all

rtmp://192.168.1.100/bcs/channel0_main.bcs?channel=0&stream=0&user=admin&password=password
Thank you! You are real hacker

lewsut
Posts: 10
Joined: Sun Jan 02, 2011 12:46 am

Re: Reolink RLC-410 Data Streams

Post by lewsut » Sun Mar 17, 2019 3:06 pm

Oddly rtmp works perfectly with my 410-4mp, but doesn't work well with the 410-5mp /420-5mp, just drops out all the time.

The image to VLC via the rtmp stream is perfect!?

DerGraf
Posts: 29
Joined: Fri Aug 17, 2018 7:33 pm

Re: Reolink RLC-410 Data Streams

Post by DerGraf » Wed Mar 20, 2019 5:21 pm

I use rtmp on ZM 1.32 for my RLC-410-5MP. No probs. Maybe wrong buffer setting?

lewsut
Posts: 10
Joined: Sun Jan 02, 2011 12:46 am

Re: Reolink RLC-410 Data Streams

Post by lewsut » Fri Mar 22, 2019 5:33 am

What buffer settings are you using?

Rstp works fine with the buffers I have, until a smear event happens maybe 48 hours in

The error I get constantly for the 5mp "Unable to read packet from stream 0: error -11 "Resource temporarily unavailable".

RTMP stream works fine with libVLC... I'm now very confused.

fajita01
Posts: 1
Joined: Sun Mar 31, 2019 1:35 pm

Re: Reolink RLC-410 Data Streams

Post by fajita01 » Mon Apr 01, 2019 2:11 am

Hi Lewsut did you find a solution for this? Currently having the same issue with my 5mp 410, 4mp cameras are all good.

joshstrange
Posts: 2
Joined: Fri May 24, 2019 6:58 pm

Re: Reolink RLC-410 Data Streams

Post by joshstrange » Fri May 24, 2019 7:03 pm

I am having the same issue with my ReoLink RLC-410-5MP. I am using ffmpeg with a connection string of:

Code: Select all

"rtmp://192.168.1.100/bcs/channel0_main.bcs?channel=0&stream=0&user=admin&password=password"
I see this line in my logs regularly and the feed sometimes hangs up and sometimes drops completely:

Code: Select all

Unable to read packet from stream 0: error -11 "Resource temporarily unavailable".
I have the camera set to 8 frames a second and ZM left blank for those settings. Oddly enough I can see movement faster on the ZM interface (when it's working) than the flash preview on the camera's web UI.

joshstrange
Posts: 2
Joined: Fri May 24, 2019 6:58 pm

Re: Reolink RLC-410 Data Streams

Post by joshstrange » Fri May 24, 2019 7:34 pm

Quick update, after searching around some more I tried the following:

Source Type: Ffmpeg

Source Path: rtsp://admin:pass@10.0.1.XXX/h264Preview_01_main
Method: TCP
Options: buffer_size=128000
Capture Width: 2560
Capture Height: 1920

(Those last 2 will prob be dependent on what you set on the Web UI for the camera. Also I set the Web UI to use 8 frames a second and left ZM's frames option blank).

Not going to say this will have no issues but I was able to get it to smear really easily before and now I can't and it's not having the locking-up issues that the rtmp stream did. I hope this helps someone.

Huge thanks to this github issue: https://github.com/ZoneMinder/ZoneMinder/issues/811
And the forum post that lead me there: viewtopic.php?p=99569#p99569

netrapradhan
Posts: 1
Joined: Fri Jul 05, 2019 11:17 am

Re: Reolink RLC-410 Data Streams

Post by netrapradhan » Fri Jul 05, 2019 11:19 am

Very well explained.

Sidicas
Posts: 4
Joined: Mon Dec 31, 2012 7:31 am

Re: Reolink RLC-410 Data Streams

Post by Sidicas » Fri Aug 02, 2019 4:43 am


Source Path: rtsp://admin:pass@10.0.1.XXX/h264Preview_01_main
Method: TCP
Options: buffer_size=128000
Capture Width: 2560
Capture Height: 1920
I tried this. It still smears on my Reolink 420. Just like everybody else, it's very sporadic. If you play the stream constantly you will notice it. If you turn off your alarm overloads, you will definitely notice it.

Using rtmp has been working reliably for the past couple of days. In fact, I set up two monitors for the camera. One for rtmp and one for rtsp. Watching them side-by-side, sporadically the RTSP smears on my Reolink 420 for minutes at a time but thus far the RTMP looks fine. Additionally, logged into the camera's web client the video stream looks fine but I think the camera's web client does not use RTSP.

When I connect directly to the cameras using RTSP with VLC, the framerate is smooth until the period of smearing in zoneminder. When it starts smearing in zoneminder, the framerate drops to near 0 over RTSP. RTMP continues on as if nothing is wrong. It's clearly dropping frames like crazy with RTSP but it might be tricky to notice it. Better seen late at night when you have that granularity noise from the camera in the picture where you can see the framerate is very jittery over RTSP.

So I've spent hours fiddling with it, trying every possible setting that you can on the camera. Resolution. Frame Rate. Bit Rate. Nothing makes a difference. Sometimes it seems like it makes a difference but it's only because the RTSP stream problems are sporadic. For a while I even thought maybe the cameras were overheating because they got quite hot but then I ruled that out when it was happening during the winter when it was 0F outside.

I just have not been able to get RTSP to work reliably with this camera. So I'm just going to use RTMP.

You can configure the resolution/bitrate/framerate of the two streams the camera puts out. One is sub and the other is main.

RTMP is supposedly "flash" but I'm getting a H.264 stream with audio using the RTMP URLs according to VLC. I'm happy with it.

Edit: Also, with RTSP my framerates in general on the Reolink 420 are very rough. Usually +/- several FPS and even worse when it's smearing.. With RTMP the framerates stay the same constantly within 1/10th of a FPS all day long even if it's smearing or dropping frames over RTSP. Currently my RTMP streams are 1/100th of an FPS within each other for all cameras and the RTSP streams are +/- 4 FPS across all cameras. Keeping in mind the FPS setting fpr the camera applies to both RTSP and RTMP.

jasongrimme
Posts: 1
Joined: Tue Aug 06, 2019 12:53 am

Re: Reolink RLC-410 Data Streams

Post by jasongrimme » Tue Aug 06, 2019 12:57 am

I have RCL-410 cameras, running 1.32 on Ubuntu 16.04. Using ffmpeg and the rtmp urls, everything looks great, but I get NO motion detection. I've even setup a substream, have the zones set to the most sensitive possible, and with cars going by and trees swaying in the wind, I still never have any motion triggers.

Any ideas?

niketsurve
Posts: 1
Joined: Fri Aug 16, 2019 8:50 am

Re: Reolink RLC-410 Data Streams

Post by niketsurve » Fri Aug 16, 2019 8:58 am

Thanks for the information.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests