Search found 68 matches

by sgn
Wed Dec 15, 2004 12:50 am
Forum: Feature Requests
Topic: Feature request.
Replies: 2
Views: 1785

Feature request.

First of all: ZM is wicked! The world owes you bigtime, Coombes :) I do, however, have a few feature requests: 1: Users should be able to change their own password. 2: ZM should be able to move archived events to a different location. 3: Perhaps storing events/images in the DB would improve performa...
by sgn
Tue Dec 07, 2004 3:13 pm
Forum: ZoneMinder Previous Versions
Topic: i can't see image both via cambozola/stream and still image
Replies: 8
Views: 6217

I have no experince with GConf, it might be the issue, however i have no chance of knowing that. Also, the error in apache's logs might indicate that zms is not executed in the right way, but it's also the warning you'll get if there is nothing to stream. You're not using PHP safe mode or anything, ...
by sgn
Mon Dec 06, 2004 7:47 am
Forum: ZoneMinder Previous Versions
Topic: i can't see image both via cambozola/stream and still image
Replies: 8
Views: 6217

Cambozola reports signal 500, meaning zms works now, however it can't find anything to stream. The reason why it cant find anything is that zm is unable to start without certain perl-modules (used for timestamping, communication with MySQL etc.) Debian does not have all of them installed by default,...
by sgn
Sun Dec 05, 2004 7:17 pm
Forum: ZoneMinder Previous Versions
Topic: i can't see image both via cambozola/stream and still image
Replies: 8
Views: 6217

Can I assume you configured zm with the --with-webuser and --with-webgroup accordingly? You are able to look at old events as stills, right? Take a look at apache's logs, they tend to be useful. What kind of message do you get from Cambozola? Do you have a JVM (Java Virtual Machine (If not, get it a...
by sgn
Sun Dec 05, 2004 6:03 pm
Forum: ZoneMinder Previous Versions
Topic: i can't see image both via cambozola/stream and still image
Replies: 8
Views: 6217

First of all, you have to make sure that the httpd-user can access cgi-bin/zms and that it can access event-images (I presume it can do both, as you are obviously recording). Then apache has to be configured to treat the zms binary as a CGI. This is done by adding the following to httpd.conf: <Direc...
by sgn
Sat Dec 04, 2004 12:44 pm
Forum: ZoneMinder Previous Versions
Topic: Interesting bug.
Replies: 0
Views: 955

Interesting bug.

When I install ZM, I use the --with-cgidir option. Thing is, if the dir does not already exist, the install-script will make a binary called cgi-bin instead of creating binaries inside cgi-bin/.

At least thats the way its working over here.
by sgn
Wed Dec 01, 2004 10:47 pm
Forum: ZoneMinder Previous Versions
Topic: automically old event delete ??
Replies: 3
Views: 2347

Sure. If you look in the "Hints/Tips"-section of the forum, you'll find a great script to be run in cron. ZM has such a function integrated, in the Event-filter window there is a dropdown with the "PurgeWhenFull"-filter.

Configure, save, sit back and let it do the work.
by sgn
Wed Dec 01, 2004 2:23 pm
Forum: ZoneMinder Previous Versions
Topic: VidGen fails and logs are swamped.
Replies: 9
Views: 4011

It isnt there. I am recompiling ffmepg with the --enable-shared option, hopefully it will compile libavcodec. I set the following option: Buffer size: 10 (Was 25) Warmup: 5 Pre: 5 Post: 5 Alarm: 2 Now it gives a "close to buffer overrun, increase ring-buffer" in syslog. Memory consumption is the same.
by sgn
Wed Dec 01, 2004 7:46 am
Forum: ZoneMinder Previous Versions
Topic: VidGen fails and logs are swamped.
Replies: 9
Views: 4011

Is the ring buffer the same as the "buffer"-option for each monitor? Tried to reduce it from 100 to 5, rendering all /dev/video* in the console orange and recording events that didn't contain anything. Runs at 25 or 50 now, can't remember, however vacating 1.5G of system memory. I installed ffmpeg i...
by sgn
Tue Nov 30, 2004 9:37 pm
Forum: ZoneMinder Previous Versions
Topic: VidGen fails and logs are swamped.
Replies: 9
Views: 4011

Well, the nature of this particular ZM installations location provides plenty of motion camerazone-wise. Isn't motion an alarm event in Mocord mode? Anyways, the log-issue is only a minor one, cron can take care of it. However, FEEL FREE to give my the whatever you know on how to divert logs going f...
by sgn
Tue Nov 30, 2004 2:29 pm
Forum: ZoneMinder Previous Versions
Topic: VidGen fails and logs are swamped.
Replies: 9
Views: 4011

Something in the order of:
Motion detected
Alarm
Returned from alarm state

The other "log-posts" here advise linking syslog to devnull. I want logs, just not from ZM.

I cannot find a solution to the ffmpeg issue, either by using Google or this forums Search.
by sgn
Mon Nov 29, 2004 8:12 pm
Forum: ZoneMinder Previous Versions
Topic: VidGen fails and logs are swamped.
Replies: 9
Views: 4011

VidGen fails and logs are swamped.

I have managed to get ZM to a running state, it records from all 15 cameras and can play back through Cambo. Video-Gen fails, however, zmvideo.log says "Incorrect frame rate". FFserver is executed with -r 0.0 for some reason. Events are recorded at 0.5 FPS. Another thing is my logs. Setting a monito...
by sgn
Sun Nov 28, 2004 3:29 pm
Forum: ZoneMinder Previous Versions
Topic: The whole shebang of problems.
Replies: 6
Views: 4545

All the above has now been resolved. However, right now I am extremely close to giving up, I have managed to get as far as none of the logs complaining abaout anything at all, alas, no cambozola-streaming from the server. Just the copyright-message. After a few seconds another message is printed ove...
by sgn
Sun Nov 28, 2004 1:21 pm
Forum: ZoneMinder Previous Versions
Topic: The whole shebang of problems.
Replies: 6
Views: 4545

Ok, I resolved that by disabling PHP Safe mode. The state is now "Running", but trying to stream images from a "Monitor"-Monitor fails, just shows me the Cambozola Copyright. The syslog is again whining about ERR: Failed to set window attributes, Invalid Argument. Even though ZM_STRICT is off, and I...
by sgn
Sun Nov 28, 2004 10:31 am
Forum: ZoneMinder Previous Versions
Topic: The whole shebang of problems.
Replies: 6
Views: 4545

I have fixed the initial problems above, seems that apache was not allowed to write to /var/log/zm/, hence it died :) Running into other problems now. /var/log/zm/zmdc.log "zmc -d 0" starts, reports started, then crashes, exit status 255. /var/log/syslog The "Failed to set window attributes" error o...