Search found 196 matches

by SkippyDo
Wed Apr 29, 2020 6:28 am
Forum: ZoneMinder 1.34.x
Topic: Debian Buster install procedure for Zoneminder 1.34.x
Replies: 63
Views: 71553

Re: Debian Buster install procedure for Zoneminder 1.34.x

After being really close to have upgrades working (both to Buster and to ZM 1.34.10) I'm now totally derailed and looking for some direction on how to proceed. Had some issues with mariadb server (ZM failing to connect- DB updated fine, I was able to look at data directly through mysql) so I removed...
by SkippyDo
Wed Apr 29, 2020 2:32 am
Forum: ZoneMinder 1.34.x
Topic: Upgrade from 1.30.4 to 1.34.x gets me 1.32.2
Replies: 5
Views: 918

Re: Upgrade from 1.30.4 to 1.34.x gets me 1.32.2

Hm... I looked all over but didn't spot that. Sorry.
by SkippyDo
Wed Apr 29, 2020 1:54 am
Forum: ZoneMinder 1.34.x
Topic: Upgrade from 1.30.4 to 1.34.x gets me 1.32.2
Replies: 5
Views: 918

Re: Upgrade from 1.30.4 to 1.34.x gets me 1.32.2

Finally resorted to deleting ZM and installing it via:

sudo apt-get install zoneminder=1.34.10-buster1

This appears to have worked (update DB and all).
by SkippyDo
Wed Apr 29, 2020 1:27 am
Forum: ZoneMinder 1.34.x
Topic: Upgrade from 1.30.4 to 1.34.x gets me 1.32.2
Replies: 5
Views: 918

Re: Upgrade from 1.30.4 to 1.34.x gets me 1.32.2

I've deleted and re-imported the keys for ZM and re-ran update. No change.

Deleted current ZM installation and did an INSTALL and STILL I am ending up with 1.32!
by SkippyDo
Mon Apr 27, 2020 6:59 pm
Forum: ZoneMinder 1.34.x
Topic: Upgrade from 1.30.4 to 1.34.x gets me 1.32.2
Replies: 5
Views: 918

Upgrade from 1.30.4 to 1.34.x gets me 1.32.2

(After a successful upgrade of my OS to Debian Buster...) I'm upgrading ZM from 1.30.4 to 1.34.x using info from here: https://forums.zoneminder.com/viewtopic.php?f=40&t=28969#p113415 I seem to be getting/installing ZM 1.32.3 instead of 1.34.x. Keyring add worked, though I had to re-run due to impro...
by SkippyDo
Thu Jan 23, 2020 9:32 pm
Forum: ZoneMinder 1.34.x
Topic: Upgrade from 1.30.4?
Replies: 3
Views: 1263

Re: Upgrade from 1.30.4?

Would following these instructions be all that's necessary?

https://wiki.zoneminder.com/Debian_10_B ... om_ZM_Repo
by SkippyDo
Thu Jan 23, 2020 5:59 pm
Forum: ZoneMinder 1.34.x
Topic: Upgrade from 1.30.4?
Replies: 3
Views: 1263

Upgrade from 1.30.4?

I imagine that this is a long-shot but figured I'd ask it anyway: Is it possible (within reason) to upgrade to 1.34.x from 1.30.4?

I will be doing an upgrade (rather than fresh install) of Buster. Just too many configuration/modifications to start from scratch.
by SkippyDo
Fri Dec 27, 2019 3:13 am
Forum: ZoneMinder 1.33.x
Topic: Upgrade ZM 1.30.4 on Debian 9 to ZM 1.33.x on Debian 10?
Replies: 3
Views: 1483

Re: Upgrade ZM 1.30.4 on Debian 9 to ZM 1.33.x on Debian 10?

Many thanks for the input!

I suppose it pays to procrastinate :D Looking forward to upgrading: I make regular backups on a separate partition, so should be good there.
by SkippyDo
Mon Nov 04, 2019 7:04 pm
Forum: ZoneMinder 1.33.x
Topic: Upgrade ZM 1.30.4 on Debian 9 to ZM 1.33.x on Debian 10?
Replies: 3
Views: 1483

Upgrade ZM 1.30.4 on Debian 9 to ZM 1.33.x on Debian 10?

Is it possible to [successfully :wink: ] UPGRADE both ZM and Debian, from ZM 1.30.4 on Debian 9 to ZM 1.33.x on Debian 10? My current server has quite a few configurations that I'd rather not risk trashing as would happen with a fresh install: I try to maintain copies of config files (in a sudo repo...
by SkippyDo
Thu May 16, 2019 8:09 pm
Forum: ZoneMinder 1.32.x
Topic: API not working. Missing files?
Replies: 3
Views: 1904

Re: API not working. Missing files?

Please report back on how this combo is working for you. I tried it and ended up with database corruptions and couldn't get it to be stable under Debian "Buster."
by SkippyDo
Thu May 16, 2019 7:14 pm
Forum: ZoneMinder Distributions
Topic: Which one to install on Linux Mint 19.1
Replies: 2
Views: 5961

Re: Which one to install on Linux Mint 19.1

In case someone trips across this... Make sure that you select a version of ZM that actually works on the intended platform. I jumped up to version 1.32 and found that I couldn't make it stable under Debian (because I had to run the development branch of Debian- most likely not a ZM issue). Had to r...
by SkippyDo
Thu May 16, 2019 7:09 pm
Forum: Mobile Apps
Topic: If is isn't broke Event Notification
Replies: 2
Views: 1907

Re: If is isn't broke Event Notification

Verify that your directory where tokens.txt is to be created allows write permission for your web server. I recently had the file blitzed (no idea why) and it wasn't getting recreated. For me, I set the permissions to that of the web server group and no longer any issues.
by SkippyDo
Thu Feb 21, 2019 5:48 pm
Forum: ZoneMinder 1.32.x
Topic: Need help reinstallimg mariaB on Debian
Replies: 5
Views: 1907

Re: Need help reinstallimg mariaB on Debian

Yes, exactly, Debian Sid is unstable, in which case I decided to not spend a lot of time trying to do anything more with the database. For all I know there are/were underlying system libraries that were causing conflicts. I have plenty of system resources (I WAY over-spec'd my hardware), so probably...
by SkippyDo
Thu Feb 21, 2019 3:56 am
Forum: Mobile Apps
Topic: Segfault with zmeventnotification
Replies: 7
Views: 3226

Re: Segfault with zmeventnotification

It works fine, even under ZM 1.30.4. I am not, however, running the detection bits, just push notifications (and no images- although I don't claim to be the definitive source, I don' believe this function will work with a ZM version older than 1.32. I went by the installation documentation (tip of t...
by SkippyDo
Thu Feb 21, 2019 3:48 am
Forum: Mobile Apps
Topic: Trying to get zmeventnotification working with ZM 1.30.4 and Debian Stretch
Replies: 4
Views: 3666

Re: Trying to get zmeventnotification working with ZM 1.30.4 and Debian Stretch

Thanks for the response! There's so many different bits in this entire system. It can be a bit daunting. I'm kind of a masochist, so I tend to readily get myself in over my head, but I try to learn in the process. Not that I needed it, but, and it says so in the code, I wasn't able to get an index i...